Cannot suspend/shutdown XBMC r27017
Hi, I see there are a few threads relating to suspend issues but I am not convinced that they wholly relevant to the problem I am having here.

I have upgraded XBMCLive Camelot 9.11 (r26018) to r27017 today and all seems well except when I try to suspend or shutdown the Asrock Ion 330 through XBMC it just instantly comes back. To be clear these functions worked before I upgraded.

I have re-read the threads about echo USB0 > /proc/acpi/wakeup and setting it permanently through rc.local script and I can confirm that the script is executing as expected. I had done this previously to get sleep/resume to work with XBMCLive 9.11. The output of cat /proc/acpi/wakeup is:

Device  S-state   Status   Sysfs node
SMB0      S4     disabled  pci:0000:00:03.2
USB0      S4     enabled   pci:0000:00:04.0
USB2      S4     disabled  pci:0000:00:04.1
NMAC      S5     disabled  pci:0000:00:0a.0
PBB0      S4     disabled  pci:0000:00:09.0
HDAC      S4     disabled  pci:0000:00:08.0
XVR0      S4     disabled
XVR1      S4     disabled
P0P5      S4     disabled
P0P6      S4     disabled
P0P7      S4     disabled
P0P8      S4     disabled
P0P9      S4     disabled

I have tried combinations of changing the state with USB2 and physically moving the IR receiver USB to different ports with no success. I have returned it to the state it was in when it worked prior to upgrading. Which is the output above. One thing, and I may of imagined this as other examples I have seen in other threads look similar, but I could have sworn that the S-State on the USB devices was S3 before. I haven't even touched the BIOS, but on checking the setting is the same as it ever was "Suspend to RAM = Auto".

I have also tried adding usbcore.autosuspend=-1 to the relevant kernal line in grub, with no effect.

I have included the last part of a debug log related to my attempt to suspend XBMC, as I say similar behaviour occurs when I attemp to shutdown XBMC aswell (please let me know if the debug log is wanted for that too).

I am at a bit of a loss here please can someone take a look? If the entire debug log is required also I can get that posted.

Many thanks.

23:13:08 T:3016461168 M:1713963008   DEBUG: Thread 3016461168 terminating (autodelete)
23:13:08 T:3043343216 M:1713963008   DEBUG: Thread 3043343216 terminating (autodelete)
23:13:08 T:3058494320 M:1713963008   DEBUG: Thread 3058494320 terminating (autodelete)
23:13:08 T:3078702992 M:1713963008   DEBUG: SECTION:UnloadDelayed(DLL: special://xbmc/system/
23:13:08 T:3078702992 M:1713963008   DEBUG: Unloading:
23:13:20 T:3078702992 M:1713971200   DEBUG: LIRC: Update - NEW at 1032251:000000037ff07bf3 00 Power mceusb (Power)
23:13:20 T:3078702992 M:1713971200   DEBUG: OnKey: 196 pressed, action is 122
23:13:20 T:3078702992 M:1713971200   DEBUG: DBus: Creating message to org.freedesktop.DeviceKit.Power on /org/freedesktop/DeviceKit/Power with interface org.freedesktop.DeviceKit.Power and method Suspend
23:13:20 T:3078702992 M:1713971200   ERROR: DBus: Error org.freedesktop.DeviceKit.Power.GeneralError - not authorized
23:13:21 T:3078702992 M:1713971200  NOTICE: Resume: Running resume jobs
23:13:21 T:3078702992 M:1713971200   ERROR: GLX: Same window as before, refreshing context
23:13:21 T:3078702992 M:1713971200    INFO: GL: Maximum texture width: 8192
23:13:21 T:3078702992 M:1714860032   ERROR: GLX: Same window as before, refreshing context
23:13:21 T:3078702992 M:1714860032    INFO: GL: Maximum texture width: 8192
23:13:21 T:3078702992 M:1713082368  NOTICE: Resume: Restarting lirc
23:13:21 T:3078702992 M:1713082368    INFO: LIRC Initialize: sucessfully started on: /dev/lircd
23:13:21 T:3078702992 M:1713082368  NOTICE: Resume: Restarting lcd
23:13:21 T:3078702992 M:1713082368   DEBUG: XLCDproc::Initialize - LCDproc data: Columns 20 - Rows 4.
What other USB devices do you have plugged in? Wireless keyboard/mouse dongle? USB Key (for Live)?
I just wrote a section on Suspend/Wake in the XBMCbuntu wiki page. Go through it and let me know what works and doesn't work.
Pashdown thank you so much for the guide, I am pleased to say that the third part of step 3 was what I needed, i.e. creating /var/lib/polkit-1/localauthority/50-local.d/custom-actions.pkla. Seemed to make sense with the errors in the log where the action was not authorized.

Thank you again.
Worked for me too. Thank you sir!
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Cannot suspend/shutdown XBMC r2701700
This forum uses Lukasz Tkacz MyBB addons.