[LINUX] HOW-TO to use Antec Veris Basic IR Receiver, Harmony/MCE Remote on Ubuntu

the new ir driver of Ubuntu Maverick is kind-a broken, there are fixes upstream. You may want to subscribe to the bug report to help the Ubuntu developers focus on this issue.

Other than that, the fix appears to be to either install a newer kernel than the official Maverick kernel or to re-install the older lirc_imon module after blacklisting the imon and staging/lirc_imon modules in Maverick.
Will this work with other iMon based remote setups? I have a SilverStone GD02MT case that has an iMone LCD/IR.


I tried the lsusb and didn't see anything about soundgraph listed. I've had the LCD unplugged for a while so maybe they are tied in together, I'll look into it when I get home in an hour.
Hmm well doesn't seem like anyone know's, I've found lots of threads about the imon remote but non pertaining to the silverstone exactly. I'll have to tinker with it I suppose.
stpfarms, Is this method functional for RC1?

I cannot get my Veris to function at all.

Same for me here, I cannot get my Antec working Sad - at least not for a long time.
Two days ago I did something and suddenly it worked. But yesterday it refuses to work again. I retried everything I ve done before but nothing helped maybe somebody of you can help ... hopefullyHuh

Maybe its even because I already tried so many guides out there (and installed several packages) that I broke more than I cured...

Tomorrow I ll try with a fresh live "install". Maybe that will help...

I ll keep you informed!Cool

Sorry for my late answer, but as always there have been several things to do after a setup(I do have huge problems with GRUB2... - but thats another story).
However, fortunately I can tell you that everything went smoothly and runs fine now.

So, after the setup I immediately I checked with "lsusb -t" whats going on and I saw that as driver "imon" is already stated there as driver.
After that I just ran "dpkg-reconfiugre lirc" (with sudo) and chose the Antec(which of course fits to my remote) - et voila - everything works as it should.

So, it seems that I somehow miss configured my previous installation with my lack of knowledge.

glad that it works now...

Big GrinBig GrinBig Grin
Hello , i have ubuntu 10.10

well i have problem with imon doesn't work fine (but in my old ubuntu 9.10 work fine),

i have this display in my nox live2 carcase


Quote:Bus 006 Device 002: ID 15c2:0038 SoundGraph Inc. GD01 MX VFD Display/IR Receiver
my lirc config selected
Quote:Soundgraph iMON Antec Veris

with this remote control


Quote:lircd -v
lircd 0.8.7-pre3
Quote:lcdproc -v
LCDproc 0.5.3
Quote:# /etc/lirc/hardware.conf
#Chosen Remote Control
REMOTE="Soundgraph iMON Antec Veris"
REMOTE_MODULES="lirc_dev lirc_imon"

#Chosen IR Transmitter

#Enable lircd

#Don't start lircmd even if there seems to be a good config file

#Try to load appropriate kernel modules

# Default configuration files for your hardware if any

#Forcing noninteractive reconfiguration
#If lirc is to be reconfigured by an external application
#that doesn't have a debconf frontend available, the noninteractive
#frontend can be invoked and set to parse REMOTE and TRANSMITTER
#It will then populate all other variables without any user input
#If you would like to configure lirc via standard methods, be sure
#to leave this set to "false"
#It includes the default configuration for the remote and/or
#transmitter that you have selected during package installation.
#Feel free to add any custom remotes to the configuration
#via additional include directives or below the existing
#Ubuntu include directives from your selected remote and/or

#Configuration for the Soundgraph iMON Antec Veris remote:
include "/usr/share/lirc/remotes/imon/lircd.conf.imon-antec-veris"
can you help me?

Thank you.
Have the same problem:
gentoo 2.6.36-r5, lirc-0.8.7, lirc_imon driver - works perfect.
Because of i915-drm fixes tried to switch to 2.6.37.
so, I am working on bringing up 2.6.37 w/ imon driver.

at least I can recommend upgrade lirc to 0.9.0_pre1. This one works better with kernel 2.6.36+. And of cause you need to enable imon in kernel (make menuconfig).

currently I am trying to debug my home HTPC remotely, but looks like rmmod -f imon made "oops" Smile
so, I'll continue my investigations later evening.

P.S. does anybody know good article about "magic" eth packets to reset PC remotely?
Ok. Now I can control XBMC again. Using kernel 2.6.37 and kernel's imon driver.

First of all I stopped lircd. We don't need it anymore.
Instead of lircd I start using inputlircd. it is pretty enough to control everything using events model.

1. create new simlink to correct eventX using udev rules. this will avoid problems if number changed.
cat /etc/udev/rules.d/11-lirc.rules
KERNEL=="event*", SYSFS{name}=="iMON Remote (15c2:0038)", NAME="input/%k", SYMLINK="input/irremote", MODE="0666"
so we can use /dev/irremote as our IR receiver device.

2. install inputlircd. for gentoo it looks :
sudo emerge app-misc/inputlircd

3. configure inputlircd daemon:
cat /etc/conf.d/inputlircd
# Options to pass to the lircd process
INPUTLIRCD_OPTS="-m 0 -g /dev/input/irremote"

4. start inputlircd
sudo /etc/init.d/inputlircd start

5. add inputlircd to default layer. for gentoo:
sudo rc-update add inputlircd default

6. change ~/.xbmc/userdata/Lircmap.xml to have something like this:
        <remote device="irremote">

7. reboot the system to double check everything works correctly.

8. correct key names you can check either via irw tool from lirc package or just look at /usr/include/linux/input.h

9. Still doesn't work Volume Control on Antec Fusion Case. not critical, but will try to fix it latter.

Logout Mark Read Team Forum Stats Members Help
[LINUX] HOW-TO to use Antec Veris Basic IR Receiver, Harmony/MCE Remote on Ubuntu1
This forum uses Lukasz Tkacz MyBB addons.