•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 55
  •   
Win Yatse 2 : Open Source Media Center Remote Control App for Touch Screen
#61
In the test4 file that i just upload 30 sec ago there's no more splashscreen Smile
You can"t have this error.
Reply
#62
Ok, that runs, and creates this:

Code:
21/03/2010 05:40:42 : Error [ Cannot find DependencyProperty or PropertyInfo for property named 'Effect'. Property names are case sensitive.  Error at object 'grd_Volume' in markup file 'YATSE;component/yatsewindow.xaml'. ]

ThrowException : 0 / 0

   at System.Windows.Markup.XamlParseException.ThrowException(String message, Exception innerException, Int32 lineNumber, Int32 linePosition, Uri baseUri, XamlObjectIds currentXamlObjectIds, XamlObjectIds contextXamlObjectIds, Type objectType)

   at System.Windows.Markup.XamlParseException.ThrowException(ParserContext parserContext, Int32 lineNumber, Int32 linePosition, String message, Exception innerException)

   at System.Windows.Markup.BamlRecordReader.ThrowException(String message, Exception innerException)

   at System.Windows.Markup.BamlRecordReader.CreateInstanceFromType(Type type, Int16 typeId, Boolean throwOnFail)

   at System.Windows.Markup.BamlRecordReader.GetElementAndFlags(BamlElementStartRecord bamlElementStartRecord, Object& element, ReaderFlags& flags, Type& delayCreatedType, Int16& delayCreatedTypeId)

   at System.Windows.Markup.BamlRecordReader.BaseReadElementStartRecord(BamlElementStartRecord bamlElementRecord)

   at System.Windows.Markup.BamlRecordReader.ReadElementStartRecord(BamlElementStartRecord bamlElementRecord)

   at System.Windows.Markup.BamlRecordReader.ReadRecord(BamlRecord bamlRecord)

   at System.Windows.Markup.BamlRecordReader.Read(Boolean singleRecord)

   at System.Windows.Markup.TreeBuilderBamlTranslator.ParseFragment()

   at System.Windows.Markup.TreeBuilder.Parse()

   at System.Windows.Markup.XamlReader.LoadBaml(Stream stream, ParserContext parserContext, Object parent, Boolean closeStream)

   at System.Windows.Application.LoadBamlStreamWithSyncInfo(Stream stream, ParserContext pc)

   at MS.Internal.AppModel.AppModelKnownContentFactory.BamlConverter(Stream stream, Uri baseUri, Boolean canUseTopLevelBrowser, Boolean sandboxExternalContent, Boolean allowAsync, Boolean isJournalNavigation, XamlReader& asyncObjectConverter)

   at MS.Internal.AppModel.MimeObjectFactory.GetObjectAndCloseStream(Stream s, ContentType contentType, Uri baseUri, Boolean canUseTopLevelBrowser, Boolean sandboxExternalContent, Boolean allowAsync, Boolean isJournalNavigation, XamlReader& asyncObjectConverter)

   at System.Windows.Navigation.NavigationService.GetObjectFromResponse(WebRequest request, WebResponse response, Uri destinationUri, Object navState)

   at System.Windows.Navigation.NavigationService.DoNavigate(Uri source, NavigationMode f, Object navState)

   at System.Windows.Navigation.NavigateQueueItem.Dispatch(Object obj)

   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Boolean isSingleParameter)

   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Boolean isSingleParameter, Delegate catchHandler)

a
Reply
#63
Well i have uploaded a Test5 with no effects also Smile

But all i find on the net about this error and the other one about ressources claims the same thing : Bad .NET 3.5 Installation Sad

You need to uninstall .Net and reinstall :
http://blogs.msdn.com/xwebsupport/archiv...setup.aspx

Then it should work with the normal 1.1.2 version Smile
Reply
#64
Hi, I'd already thought that and had reinstalled it before I posted here.

I'm convinced it's something to do with WPF - Microsoft are not renowned for getting things like that right first time ;-)

The other thing that makes me thing that is that when I try to open your .sln or .csprj I get an error telling me that the "application for the project cannot be found" - however, short of completely reinstalling the .net framework again, I don't know how to reinstall the WPF stuff.
Reply
#65
WPF is inside .NET 3.5 SP1 Smile

And it's out since 3.0 so it's quite stable and usable now.

If even visual studio don't find components you really have a problem with .Net Sad
Perhaps you miss some patch on the base OS Sad
(You can try to uninstall all .Net and reinstall the whole pack)

Have you tried the test5 build ?
Reply
#66
Ahh, Test5 is working!

What did you take out?

I know that the WPF stuff is in the .Net framework, but I was convinced that it was something to do with that as I've had no problem with any other .net program (mine or third-party) on this machine.

I am, however, reminded why I don't use Windows any more ;-)
Reply
#67
I take out some blur effects Smile

But a software without icon, without splash and without effect is quite limited :p

Perhaps your install just miss some part that you don't use Smile

The problem will be that V2 goes more deep in WPF things i hope that not too much peoples will have corrupted .Net installations Sad
Reply
#68
Well, thank you - it's still looking good.

I'm not sure what's going on with it to be honest. The first thing I did was reinstall the .net framework, so I've done that twice on this machine now.

It's a pity the WPF stuff can't be accessed from Xubuntu - I'd have that on the machine like a shot ;-)
Reply
#69
Sadly, I think the machine I'm running on is not quite up to the job of running this - I can feel a new machine getting a new home soon!

You've really sparked my interest in WPF - I'm gonna start in earnest tomorrow!

Thank you.
Reply
#70
What kind of machine do you use it on ?

So i have more information and needed power for my app Smile

And please don't look to my code to get inspiration on WPF :p wait V2 Smile
For V1 i started coding before even reading what c# and WPF is about :p
Reply
#71
Ha - fair play!

I'm a c#/.net/php/c/c++/python/younameit programmer, I'd just never heard of WPF before today!!

The machine I'm running on is a 900Mhz Mini-ITX box that I put together some time ago - It sits in my living room with a touchscreen on the wall, and I control my lights, doors, heating etc... through it.

I'd written various versions of a 'jukebox' control for it as well, but always ran into problems (like not being able to queue remotely through VLC or Mplayer etc...) and started writing my own remote front-end for my own backend media player (audio only), but just last night, for some reason I revisited XBMC just to see how it was getting on (I first used it 5/6 years ago and fell in love with it, but moved on to MythTV as XBMC wasn't doing the TV stuff), and I came across your post.

...and that seems perfect for what I want, although I know I won't be able to help myself and I'll end up redesign everything (I do it with everything, please don't take offence ;-) )

EDIT: I noticed with my own programs (almost exclusively C# or VB.Net on this machine) ran much smoother when the machine was patched to SP2 (XP). With SP3, all of the .Net progs on there has slowed down noticably.).
Reply
#72
Lol no offence Smile

But V1 is really ugly, i'll be glad if you make changes to V2 and send them back Smile
Reply
#73
Hey, I'd love to be involved - and I'll try and get a machine that can handle it a bit better this week. I have several machines dotted about the house that are much more powerful, but I don't like putting windows on them if I can help it.

However, I may be able to get it working well enough in a VM. I'll give it a try tomorrow night.

I just love that video of v2 you have on youtube - that's what 3d graphics were invented for Wink

I'd better get reading up on WPF!
Reply
#74
I've been using YATSE for awhile now and I have some basic complaints that hamper its useability.

1) The touchscreen swipe actions don't work very well. I'd have to shoot a video to really explain this properly, but its just not 'natural'. Trying to swipe one item at a time is nearly impossible. it either doesn't swipe at all, or it swipes 3-4 items at once.

2) There is no visual feedback that your swipe is working until its done. What I mean is, as you're swiping, nothing is happening on screen. Once the swipe is done it 'snaps' to the item. This is not the way this kind of gesture normally works.

examples of how swipe gestures work properly and are very useful:

- Chome-touch extension. This extension lets you scroll up and down in chrome with a touchscreen. It works very well. You put your finger down, it 'grabs' the page. Now when you move your finger up and down, the page moves with it. It has inertia so you can 'flick' the page up and it will continue scrolling. All settings regarding speed, sensitivity, and inertia are editable through the settings. VERY useful and extremely well implemented.

- I phone or Palm-Pre style swiping. On these devices, any time you grab something to swipe it over or up or down, its just like above. You put your finger down, it grabs it, then you can swipe it and the animation follows your finger. You can change your mind mid-swipe and go in the other direction if you want, and it will do what you expect.

3) The 'now playing' screen only seems to update once. If I go back to the screen later, it is still stuck showing whatever I was playing hours ago.

4) After installing the web-based library management interface, YATSE stopped working, and will not refresh the library. This is likely a problem with the other app, but notable either way. The Web-OS interface on my phone still works.
Reply
#75
@dchurch24 : WPF needs directx 9 compliant video card to works correctly. I currently dev on an XP Vm under Workstation 7 and it works quite well (but Windows 7 is the host don't know if directx emulation works under linux).

@vinistois : Scrolling is not perfect but it should give feedback, do you have the same effect under video and music or only one ?
I hope V2 will be better for that. But for the moment even if it laggy sometimes it's implemented like you iphone description, with the faster you move your finger the faster the list scroll but you can do left right left right the list should follow.

For the now playing it updates every time there's a change on XBMC side for text data and image and every second if something is playing for progress bar and times.
Can you change the debug option in the config file to true, and send the log file ?

(And of course do you use 1.1.2 ? )
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 55
  •   



Logout Mark Read Team Forum Stats Members Help
Yatse 2 : Open Source Media Center Remote Control App for Touch Screen5
This forum uses Lukasz Tkacz MyBB addons.