•   
  • 1
  • 230
  • 231
  • 232(current)
  • 233
  • 234
  • 389
  •   
[RELEASE] Rom Collection Browser - Browse and launch emulator game ROMs
(2013-05-22, 03:49)iceman600 Wrote: is it just me or its just launching the RCB is so slow? i mean hitting enter on RCB takes a while to launch. it kinda takes you out of the mood from playing anymore Sad

Guess it depends on your computer..mine loads almost instantly
Reply
NewYears1978 Wrote:Problem: Artwork that I change locally does not seem to change.
Solution: Items were going into XBMC cache, clearing the textures cache file fixed this issue.
What file did you delete exactly? And did you have other issues in XBMC after doing this? I once deleted the cache db and all artwork was gone inside XBMC (also for movies etc) and it took some days until everything was working again. Maybe I even had to rescrape everything, not sure anymore.

NewYears1978 Wrote:Problem: Is it possible for me to redirect the launcher file to another file instead of applaunch-vbs.bat. I want to write a small VBS script that is invisible that runs applaunch-vbs.bat so that I don't have a DOS box popping up.
Only in the code itself. You will find it in launcher.py line 72. If it works well you could post your solution and I may add it as an option.

NewYears1978 Wrote:Problem: One new question is with Aeon, on the mode that shows video, the little box placeholder for video is larger than the video size..is there a way to modify this so they fit together. See image
http://i573.photobucket.com/albums/ss171...ef2e66.jpg
This is a skin issue. You could ask Marcos if he can fix it. But I guess he is only fixing serious bugs in MQ4. Ace (the new skin of Marcos) has also RCB support. Maybe you like this one better.

NewYears1978 Wrote:Problem: What does the message Control with id: 1100 could not be found mean every time I launch a game?
Also a skinning issue. RCB tries to focus a control that the skin does not provide. I have in mind that this happens in MQ4 when you use solo mode?

NewYears1978 Wrote:Problem: Save states don't work, I assume this is due to the script copying the rom file to a temp folder in appdata... but I can't seem to make it work no matter what. I don't want the popup in RCB asking about save states I want to be able to use normal savestates as I can in my emu (Zsnes in this case) as normal...I can't figure a way to do this aside from putting my save states in the tmp folder. (Edit tried copying to tmp they still don't work. They work fine when emulator is launched by itself...but from XBMC RCB..they won't)
Maybe you can try to enable Do not extract zip files in Edit Rom Collection dialog (if your emulator supports running compressed files). Then the files should not be copied to the tmp dir.

NewYears1978 Wrote:For the record I can get saves working when I put in all the savestate params in the options, where when I launch a game it asks me which save to load. But I want to just load my saves IN GAME like normal without that menu popping up on game launch..is that possible? (Then again, the menu is kinda cool...however I might rather it just launch the last save then give me a list)
Maybe I could add the option to always launch the last savestate.

(2013-05-22, 17:46)NewYears1978 Wrote:
(2013-05-22, 03:49)iceman600 Wrote: is it just me or its just launching the RCB is so slow? i mean hitting enter on RCB takes a while to launch. it kinda takes you out of the mood from playing anymore Sad

Guess it depends on your computer..mine loads almost instantly
And it depends on the size of your rom collection. If you have thousands of games it will take a while until RCB is ready. You could try to set the filters to display only a subset of your colltection. RCB should launch with these filter settings the next time.
Reply
Welp, I have searched the nets for this and have found no answer. Does anyone know how to get The sega saturn emulator to work inside this. I have managed to get the other emulators to work. Please help
Reply
(2013-05-23, 07:22)toki5 Wrote: Welp, I have searched the nets for this and have found no answer. Does anyone know how to get The sega saturn emulator to work inside this. I have managed to get the other emulators to work. Please help

it's not easy. you will need either yabause or ssf with a disc emulation tool like daemon tools or alcohol 120% and some scripting abilities.

or you can try RoM-Jacket
Reply
You really answered all my questions I need to go over the data and I will get back to you Smile
Reply
Quote:Problem: Artwork that I change locally does not seem to change.
Solution: Items were going into XBMC cache, clearing the textures cache file fixed this issue.

What file did you delete exactly? And did you have other issues in XBMC after doing this? I once deleted the cache db and all artwork was gone inside XBMC (also for movies etc) and it took some days until everything was working again. Maybe I even had to rescrape everything, not sure anymore.

I deleted the textures.db file, I did have to have my other images reload but it only took a min and all was well after that.

Quote:Problem: Is it possible for me to redirect the launcher file to another file instead of applaunch-vbs.bat. I want to write a small VBS script that is invisible that runs applaunch-vbs.bat so that I don't have a DOS box popping up.

Only in the code itself. You will find it in launcher.py line 72. If it works well you could post your solution and I may add it as an option.

I will check into this...never edited a py file I assume I can do so in Notepad++ Will let you know how it turns out

Quote:Problem: One new question is with Aeon, on the mode that shows video, the little box placeholder for video is larger than the video size..is there a way to modify this so they fit together. See image
http://i573.photobucket.com/albums/ss171...ef2e66.jpg

This is a skin issue. You could ask Marcos if he can fix it. But I guess he is only fixing serious bugs in MQ4. Ace (the new skin of Marcos) has also RCB support. Maybe you like this one better.

Ah okay..not a big issue. I tried Ace and I almost liked it..but there was no video support in RCB except for trailer mode.

Quote:Problem: What does the message Control with id: 1100 could not be found mean every time I launch a game?

Also a skinning issue. RCB tries to focus a control that the skin does not provide. I have in mind that this happens in MQ4 when you use solo mode?

Yes you are correct..Solo mode in MQ4 -it's not a huge problem more an annoyance..any way to correct it?

Quote:Problem: Save states don't work, I assume this is due to the script copying the rom file to a temp folder in appdata... but I can't seem to make it work no matter what. I don't want the popup in RCB asking about save states I want to be able to use normal savestates as I can in my emu (Zsnes in this case) as normal...I can't figure a way to do this aside from putting my save states in the tmp folder. (Edit tried copying to tmp they still don't work. They work fine when emulator is launched by itself...but from XBMC RCB..they won't)

Maybe you can try to enable Do not extract zip files in Edit Rom Collection dialog (if your emulator supports running compressed files). Then the files should not be copied to the tmp dir.

I tried the zip file thing but it turns out even when I put all my saves in the tmp folder they still didn't work.

Quote:For the record I can get saves working when I put in all the savestate params in the options, where when I launch a game it asks me which save to load. But I want to just load my saves IN GAME like normal without that menu popping up on game launch..is that possible? (Then again, the menu is kinda cool...however I might rather it just launch the last save then give me a list)

Maybe I could add the option to always launch the last savestate.

I never could get saves to work without putting the save parameters in the settings. I learned to live with it..it's kinda cool to have a list asking which save...BUT the option to load last save automatically would be nice!

Do you have a list of which Skins have working video display in RCB and not just in trailer mode ( in MQ4 on one mode the video plays or each rom as you browse..automatically..I like this)

Update:

I tried editing launcher.py and changed the launch line for applaunch-vbs.bat to applaunch-vbs.vbs, I then made a file applaunch-vbs.vbs with this

Code:
Set WshShell = CreateObject("WScript.Shell")
WshShell.Run chr(34) & "C:\Users\HTPC\AppData\Roaming\XBMC\userdata\addon_data\script.games.rom.collection.browser\scriptfiles\applaunch-vbs.bat" & Chr(34), 0
Set WshShell = Nothing

It seemed to launch it but a cmd window pops up and I am kicked back to XBMC. Any ideas?
Reply
(2013-05-23, 07:37)sudopinion Wrote:
(2013-05-23, 07:22)toki5 Wrote: Welp, I have searched the nets for this and have found no answer. Does anyone know how to get The sega saturn emulator to work inside this. I have managed to get the other emulators to work. Please help

it's not easy. you will need either yabause or ssf with a disc emulation tool like daemon tools or alcohol 120% and some scripting abilities.

or you can try RoM-Jacket

I have tried creating the .bat that someone suggested, it didnt work. I couldnt even get the ROMs to scrape. Thanks for getting back to me, dont really have scripting abilities or such. I will take a look a at ROM jacket and see if maybe with that. If anyone has successfully entered ssf or satourne in the ROM collection browser, please let me know how you did it?
Reply
I also have another question, I have games which are pre configured. They are Daphne emulator games, pre configured. I can get it to run in the RCB, I just cant get RCB to scrape the correct info for the games. I dont want to change the name of the zip folders for fear that it may cause the .bat files to stp working correctly. Any ideas what I could possibly do to get all infos correct so that I can keep these in the RCB? To note, I am on windows 7 32 bit
Reply
(2013-05-23, 21:19)toki5 Wrote: I also have another question, I have games which are pre configured. They are Daphne emulator games, pre configured. I can get it to run in the RCB, I just cant get RCB to scrape the correct info for the games. I dont want to change the name of the zip folders for fear that it may cause the .bat files to stp working correctly. Any ideas what I could possibly do to get all infos correct so that I can keep these in the RCB?

Aren't there only a few Daphne games, you could manually create a gamedesc file and do your collcetion that way..would be pretty easy. In fact I use gamedesc for all mine it reads a premade file instead of online scraping.

See here: http://code.google.com/p/romcollectionbr...scriptions
Reply
I tried that, I dont know the parsing part. Also, I cant get gameboy emulator to work. I have tried iceman600 parameters, it didnt work. I have tried normal way, that didnt work. I have been able to do gameboy color, I just cant get regular gameboy emulator in.
Reply
The parsing is included in the file when you download it You select the txt file and then the parsing file ( it's actually called parsing..is an XML file)
Reply
I started getting this error recently I am running RCB in that mode which closes xbmc....when its time to open xbmc again after the rom is closed i get this error.

"ERROR: Unable to create application

I never got that until recently...


Using xbmx 12.2
Reply
Nevermind noticed a new option to turn on vbscript in rcb, now works!


Very nice.
Reply
Hi!
Is there any simple way to select artwork when importing games from online? Scrapper grabs only first image and it's not always the best one.

P.S. malte, your addon is great. Thanks for your job.
Reply
(2013-05-25, 04:37)Ghostdivision Wrote: I started getting this error recently I am running RCB in that mode which closes xbmc....when its time to open xbmc again after the rom is closed i get this error.

"ERROR: Unable to create application

I never got that until recently...


Using xbmx 12.2

After switching to the VB scripts (which work great!) I started getting this error with only MAME. As far as I can tell the xbmc process was holding the xbmc.log file and this was preventing xbmc from restarting. Windows will not allow the deletion of the log file while its being used, although a app called Unlocker is able to delete the in use log file via the command prompt/batch file. Using the method described here to bypass the UAC pop up as this program runs as administrator. Then I added the shortcut to the eventghost action I have for closing emulators + app-launch.bat script file and now xbmc restarts after MAME now.
Reply
  •   
  • 1
  • 230
  • 231
  • 232(current)
  • 233
  • 234
  • 389
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Rom Collection Browser - Browse and launch emulator game ROMs20
This forum uses Lukasz Tkacz MyBB addons.