•   
  • 1
  • 268
  • 269
  • 270(current)
  • 271
  • 272
  • 395
  •   
[RELEASE] Rom Collection Browser - Browse and launch emulator game ROMs
(2014-03-20, 14:48)malte Wrote: You can edit the skin files directly to change the delay. In RCBs addon directory open the file: "resources/skins/Default/720p/script-Rom_Collection_Browser-main.xml" and search for these lines:

Code:
<animation delay="300" effect="fade" start="100" end="100">Focus</animation>
<onfocus>XBMC.PlayMedia($ESCINFO[ListItem.Property(gameplaymain)],1)</onfocus>
I guess you know what part to editSmile

Note: this code should occur two times in the file.

It didn't worked. Changed delay from 300 to 1000 on both lines, and nothing has changed. Tried putting 3000 too, but still I couldn't see no changes.

Tried changing delay from 300 to 900, and edited "start" and "end" attributes to 450 each one, but still no change.

Am I missing something?


Aww sorry. I forgot that I've changed RCB skin to Simplicity, and I had to edit its respective XML file for changing delay attribute.

Anyway, I've edited "script-Rom_Collection_Browser-main.xml" files from all skins, and now It's working.

Thanks for the help, and sorry for the misunderstanding.
Reply
Is there any good way to exit from emulators with a remote press?
Basically I am looking for something that when I run a game from RCB it sets a remote button to be ALT+F4 then after I press the button and go back to XBMC it removes this feature so that I do keep accidentally closing XBMC etc.
Would it be possible to do this something like a bat file and run it with the pre-launch command?

I'm using windows 7 btw.
Reply
(2014-03-20, 19:08)Malakesher Wrote: Is there any good way to exit from emulators with a remote press?
Basically I am looking for something that when I run a game from RCB it sets a remote button to be ALT+F4 then after I press the button and go back to XBMC it removes this feature so that I do keep accidentally closing XBMC etc.
Would it be possible to do this something like a bat file and run it with the pre-launch command?

I'm using windows 7 btw.

I guess you can't do it directly from XBMC. You'll have to see if each emulator has this feature implemented.

Some emulators have an option that can open ROMs directly in fullscreen, automatically mapping "Esc" key to force close the emulator when pressed. This way, you won't need to map ESC key to a remote button, since most remotes already have this key mapped to a button. This way, "Esc" will only close emulators, and won't do nothing on XBMC besides going back to previous menu or option.

MAME (arcade emulator) already have this: All games are opened on fullscreen, and you can close it by simply pressing Escape key.

Kega Fusion (emulator for sega consoles and handhelds) have this too, but you'll have to pass a few command-line parameter for it to work. Examples:
Code:
fusion gamename.ext -sms -fullscreen // For Sega Master System games
fusion gamename.ext -gen -fullscreen // For Sega Genesis games

If you don't like Kega Fusion, the same can be done on Gens or Gens/GS by passing "--quickexit" parameter (two traces). A good thing about Gens is that you don't need to specify the platform you want to emulate. Simply pass rom path with these parameter and you're good to go. Examples:
Code:
gens --quickexit gamename.ext

ZSNES (Super Nintendo emulator) is the same as Kega Fusion and Gens: Load ROMs in command-line by passing "-m" and -"c" parameters before game name. The first one will disable GUI and force close emulator on Esc keypress, and the second one will force fullscreen. Example:
Code:
zsnes -m gamename.ext

Of course, If you need to change emulator configs, such as controller mappings, you'll need to open emulator without these parameters, since you'll need to exit fullscreen mode first, and sometimes the only way to exit fullscreen is by pressing Esc. Neither "Alt + Enter" will work. However, there's some exceptions: on Kega Fusion, you can simply press mouse right button and go to settings window from there. On Snes9x, you can press Alt+F7 (or Alt+F8, don't remember), and you'll be redirected to command settings window.

For another emulators, if there's no way to force close on Escape key, you'll have to use AutoIt or AutoKey scripts. Here's an example for Snes9x, that don't have this feature implemented by default.
Reply
I've just done a fresh install of XBMC 12.3 and Rom Collection Browser 2.0.10, and I'm unable to get past the first run wizard. When it asks me for the emulator path, the only drive that shows up to be browsed is the DVD drive. Neither of my hard drives are listed. Any suggestions?
Reply
(2014-03-21, 05:20)Peristarkawan Wrote: I've just done a fresh install of XBMC 12.3 and Rom Collection Browser 2.0.10, and I'm unable to get past the first run wizard. When it asks me for the emulator path, the only drive that shows up to be browsed is the DVD drive. Neither of my hard drives are listed. Any suggestions?

yeah that is annoying. you may have to go to your file manager and add a source there.
Theater: The PS4/XBONE killer running Kodi 17.3 3D Movie Box: Raspberry Pi running LibreElec 8.0 Alpha BROKEN Family Room: "A6-Pack" running Kodi 17.3 Whole House: FireTV running Kodi 17.3
Reply
IncognitoMan Wrote:If you need any help lemme know...
As a start I just want to be able to launch a game on my Android phone. I made some changes to RCBs source files so that I am sure that it reaches the "os.system(cmd.encode('utf-8'))". In the log I can see that the cmd is this:
Code:
"/system/bin/am" start -n com.explusalpha.Snes9xPlus/com.imagine.BaseActivity -a android.intent.action.VIEW -eu Uri "file:///storage/sdcard0/Games/SNES/3 Ninjas Kick Back.smc"
When I run this command via adb everything works fine. From XBMC/RCB it does just nothing.

And one more question: In your guide you mention to edit applaunch.sh but you never set RCB to "Use solo mode". In this case applaunch.sh should not be executed anyway. Did you do your launching tests in solo mode?

Should I send you some logs or more info about my setup?

Solid One Wrote:It didn't worked. Changed delay from 300 to 1000 on both lines, and nothing has changed. Tried putting 3000 too, but still I couldn't see no changes.
Strange. Just tested it here and it works fine. When I set the delay to 3000, it waits 3 secondes before the video starts to play.

I am editing this file: "C:\Users\YourName\AppData\Roaming\XBMC\addons\script.games.rom.collection.browser.dev\resources\skins\Default\720p\script-Rom_Collection_Browser-main.xml"

and it looks like this now:
Code:
line 113:
<animation delay="3000" effect="fade" start="100" end="100">Focus</animation>
<onfocus>XBMC.PlayMedia($ESCINFO[ListItem.Property(gameplaymain)],1)</onfocus>

line 617:
<animation delay="3000" effect="fade" start="100" end="100">Focus</animation>
<onfocus>XBMC.PlayMedia($ESCINFO[ListItem.Property(gameplaymain)],1)</onfocus>

Malakesher Wrote:Is there any good way to exit from emulators with a remote press?
There are external tools like XPadder or eventghost that could do this. Not 100% sure if they work with a remote or only with gamepads.

Peristarkawan Wrote:I've just done a fresh install of XBMC 12.3 and Rom Collection Browser 2.0.10, and I'm unable to get past the first run wizard. When it asks me for the emulator path, the only drive that shows up to be browsed is the DVD drive. Neither of my hard drives are listed. Any suggestions?
Read here
Reply
(2014-03-21, 09:07)malte Wrote: Strange. Just tested it here and it works fine. When I set the delay to 3000, it waits 3 secondes before the video starts to play.

I am editing this file: "C:\Users\YourName\AppData\Roaming\XBMC\addons\script.games.rom.collection.browser.dev\resources\skins\Default\720p\script-Rom_Collection_Browser-main.xml"

and it looks like this now:
Code:
line 113:
<animation delay="3000" effect="fade" start="100" end="100">Focus</animation>
<onfocus>XBMC.PlayMedia($ESCINFO[ListItem.Property(gameplaymain)],1)</onfocus>

line 617:
<animation delay="3000" effect="fade" start="100" end="100">Focus</animation>
<onfocus>XBMC.PlayMedia($ESCINFO[ListItem.Property(gameplaymain)],1)</onfocus>

Aww sorry. I forgot that I've changed RCB skin to Simplicity, and I had to edit its respective XML file for changing delay attribute.

Anyway, I've edited "script-Rom_Collection_Browser-main.xml" files from all skins, and now It's working.

Thanks for the help, and sorry for the misunderstanding.
Reply
No problem, glad that it worked. I will also think about a config option. Until now I thought the 300ms will suffice for all devices.
Reply
Another question that came to my mind: On Confluence, can I add custom item menus for each rom collection?

Let me elaborate: I have four rom collections (Master System, Genesis, NES and SNES). On XBMC main menu, I want to add four custom items, one for each rom collection, and when I open one of them, RCB will show only the games specific to the selected console.

I know I can add a custom menu item that open RCB, simply by changing <onclick> function this way (or something like that):

Code:
<item id="3">
    <label>2</label>
    <onclick>RunAddon(script.games.rom.collection.browser)</onclick>
    <icon>-</icon>
    <thumb>-</thumb>
</item>

However, I don't know how to pass parameters to the <onclick> function, in order to specify which rom collection to show.

Is it possible to do?
Reply
I'm having trouble launching Project 64 2.1 with Glide64 final through RCB. My main goal is to launch games through xbmc with hd textures from Project 64 but when I try to do so I get an error message from P64. Help is very much appreciated and if this is not the right place for this I'll make a thread.
Reply
(2014-03-21, 09:07)malte Wrote:
IncognitoMan Wrote:If you need any help lemme know...
As a start I just want to be able to launch a game on my Android phone. I made some changes to RCBs source files so that I am sure that it reaches the "os.system(cmd.encode('utf-8'))". In the log I can see that the cmd is this:
Code:
"/system/bin/am" start -n com.explusalpha.Snes9xPlus/com.imagine.BaseActivity -a android.intent.action.VIEW -eu Uri "file:///storage/sdcard0/Games/SNES/3 Ninjas Kick Back.smc"
When I run this command via adb everything works fine. From XBMC/RCB it does just nothing.

And one more question: In your guide you mention to edit applaunch.sh but you never set RCB to "Use solo mode". In this case applaunch.sh should not be executed anyway. Did you do your launching tests in solo mode?

Should I send you some logs or more info about my setup?

Hmm if the command is working in adb it *should* work just fine in RCB.

At the moment I'm mucking around with linux on ouya but I'll get back to trying the android build later today... iirc my tests were not in solo mode and solo mode actually broke launching... the reason for the change on applaunch.sh was because of OS detection ( ouya doesnt have uname so it will just return with unsupported device... hence why i commented it out )

If you could send me logs and more info I'd love to take a look
Reply
Solid One Wrote:However, I don't know how to pass parameters to the <onclick> function, in order to specify which rom collection to show.
Basically you should be able to pass arguments like this:
Code:
RunAddon(script.games.rom.collection.browser,name=value)
But this will not work right now as RCB has no feature implemented that will accept a platform as parameter and automatically sets the filters.

But this feature is requested quite frequently and I hope that I will find some time to implement this or something similar in the near future.

djm1319 Wrote:I'm having trouble launching Project 64 2.1 with Glide64 final through RCB. My main goal is to launch games through xbmc with hd textures from Project 64 but when I try to do so I get an error message from P64.
I need your IP address. Then I can hack your computer and check the error message. Or you could just tell me what error message you get Wink.
If the error occurs inside XBMC please upload an xbmc.log file to xbmclogs.com and post the link here.

IncognitoMan Wrote:Hmm if the command is working in adb it *should* work just fine in RCB.
Woohoo, got it. Just wanted to send you a logcat and found the error myself. I had the same issue as user Anorax in the other thread and I also had to add --user 0 to the parameters. Now I am able to launch emulators on my Android phone!

I will upload a new RCB version that does not need any manual code changes soon. In the next step I will try to add some more configuration support.
Reply
http://i.imgur.com/gE9FWZp.jpg
Reply
Did you try to run it outside XBMC?

You should also check configuration hints here.

Also, in this thread user Loftoman had the same issue as you. On the second page it seems that he found a solution.
Reply
New test version available: 2.0.13

List of changes:

Launch Games
  • fix issues when launching games on Android

With this release you should be able to launch games on Android devices without any manual changes to RCBs code files. For more info about setting up your emulators see this thread (skip the part about the code changes).

When you have issues launching games you should also make sure that you disable following options in RCB:
- Addon Settings -> Launch Games -> Minimize XBMC
- Edit Rom Collection -> Launch Games -> Use Emulator in solo mode

Note: this is still very experimental. You will need to edit your config.xml manually as it may be hard (or impossible) to enter the required emulator params via RCBs config dialogs.

Previous version: 2.0.12
Reply
  •   
  • 1
  • 268
  • 269
  • 270(current)
  • 271
  • 272
  • 395
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Rom Collection Browser - Browse and launch emulator game ROMs20
This forum uses Lukasz Tkacz MyBB addons.