•   
  • 1
  • 376
  • 377
  • 378(current)
  • 379
  • 380
  • 394
  •   
[RELEASE] Rom Collection Browser - Browse and launch emulator game ROMs
(2020-04-03, 23:47)malte Wrote: I think Python 3/Matrix compatibility is almost complete.

If anyone wants to test and report bugs, please try out the Matrix branches of my repositories.

You can download the installabe zip files here:
Rom Collection BrowserRom Collection Browser WidgetRom Collection Browser Service

I installed the kodi nightly from 3rd of april and then your linked zip files.
Launching RCB for the first time it asked me to create a new config file but the text in this window is a bit out of place.

Image

After finishing my rom collection I got a white screen:

Image

This is an old issue though. I left RCB. When I started RCB the next time I got this:

Image

If I choose 'Import Games' I end up in RCB but it didnt import anything.

And if I'm opening the rom collection settings:

Image

Missing font again

Here is my logfile: https://paste.kodi.tv/lubasejuve.kodi
Reply
(2020-04-03, 23:42)malte Wrote:
trihy Wrote:I added a new collection ( game & watch ) but cant get rcb to scrape any game. maybe those games are not in any database?

Tried mobygame, thegamedb, but nothing.
Even if they are listed on these sites, RCB needs to address them correctly. So, "new" platforms won't work out of the box.  

Hi. Thanks. Do you mean it has to be native on the rcb list?

Could you add them?

Its just nintendo game & watch, old portable systems https://en.wikipedia.org/wiki/Game_%26_Watch_series
Reply
(2020-04-04, 02:43)Kupo91 Wrote: Here is my logfile: https://paste.kodi.tv/lubasejuve.kodi 
Thanks for the report.

Seems that I created the config file with an older Kodi nightly. I can reproduce these issues now.
Reply
(2020-04-02, 08:16)malte Wrote:
slinkygn Wrote:Thanks.  I did see that, but was hoping to run a release version thinking it'd be more stable.  After some thought I went ahead and just installed the Git version.  I wonder why the official repo is so far behind.
As Kupo91 said, the latest stable release should always be linked at the first page of this thread. Atm there is one newer (more stable Smile) release that fixes the issues with thegamesdb scraper. I wanted to wait if there will be more changes on thegamesdb before I mark this as the new "official" one. But then I somehow forgot about it. Sorry for the confusion.

No, I'm sorry -- I think I caused more confusion there!  In short: I did see the stable release on the first page, and that was fine; I just chose to use the git version because it had some of those fixes you speak of.  Both were very easy to find, you had the release very clearly marked and the git version instructions were great.  Not confusing at all.  I think you're keeping up great considering how much work has to go into Python 2->3 conversions for them to be done well!  Thank you again for all your work that we benefit from.

The issue I was mentioning is one I think you may not even have direct control of; I suspect it might be on Kodi's end.  When I talked about old versions being up, I was referring to issues with the Kodi repo, not RCB itself, which I think I didn't state as clearly as I had hoped -- see, the confusion was probably my fault! Smile  The Kodi 18 repo has 2.1.3 listed as the "current" version, as can be seen on their addons page: https://kodi.tv/addon/scripts/rom-collection-browser  It even has the old Google Code repo listed there as the location of the source instead of Github.  For whatever reason the repo seems to have not picked up on your update.  No matter -- I know where to find new versions now. Smile
Reply
(2020-04-04, 05:18)trihy Wrote: Hi. Thanks. Do you mean it has to be native on the rcb list?

Could you add them?

Its just nintendo game & watch, old portable systems https://en.wikipedia.org/wiki/Game_%26_Watch_series 
It looks like it is supported by thegamesdb.net. So I think I can add it with next release (the release after Python 3/Matrix compatibility is finished).
Reply
(2020-04-05, 04:37)slinkygn Wrote: The issue I was mentioning is one I think you may not even have direct control of; I suspect it might be on Kodi's end.  When I talked about old versions being up, I was referring to issues with the Kodi repo, not RCB itself, which I think I didn't state as clearly as I had hoped -- see, the confusion was probably my fault! Smile  The Kodi 18 repo has 2.1.3 listed as the "current" version, as can be seen on their addons page: https://kodi.tv/addon/scripts/rom-collection-browser  It even has the old Google Code repo listed there as the location of the source instead of Github.  For whatever reason the repo seems to have not picked up on your update.  No matter -- I know where to find new versions now. Smile 
It is not Kodis fault. They don't pull new addon releases automatically. The addon author (me Smile) has to tell Team Kodi that there is a new release that should be included in the repo. I did not do that for a long time as the rules (guidelines) to be included in the Kodi repo changed some time ago and RCBs current code does not meet them. So I have to do some homework first before everything is up to date again.
Reply
I updated the Matrix branch again and hope that most features should work again as expected.

You can download the installabe zip files here (Same links as in the last post. It just always gets the current state of the Matrix branches):
Rom Collection Browser
Rom Collection Browser Widget
Rom Collection Browser Service
Reply
(2020-04-05, 21:28)malte Wrote: I updated the Matrix branch again and hope that most features should work again as expected.

You can download the installabe zip files here (Same links as in the last post. It just always gets the current state of the Matrix branches):
Rom Collection BrowserRom Collection Browser WidgetRom Collection Browser Service

What I noticed:

1) Not a bug but maybe a feature request. After creating my first 2 rom collections I started importing games. However I was a bit suprised that it actually started to download *.nfos and artworks, because I stored these locally. The reason was that the option "Use foldername as gamename" is off by default. Maybe you could ask for this option being on or off in the configuration wizard? But its not a big deal

2) As I said I created only 2 rom collections in the beginning. I created the other ones afterwards though the settings menu. And I noticed that sometimes after ending the config wizard it didnt save some of my rom collection(s).
Here is a log file when it didnt save my psp and wii collection. https://paste.kodi.tv/ekiwupezal.kodi
But it doesnt depend on platforms. The same happened with gameboy color for example. But at the the next try it worked.

3) When I tried to launch a gameboy game I got this error note:

Image

Here is the log file https://paste.kodi.tv/kucamezofu.kodi
(The screenshot is from when I tried to launch a ps1 game, the logfile is from when I tried to launch a gameboy game. But it came to the same result)
Reply
(2020-04-06, 00:12)Kupo91 Wrote: What I noticed:

1) Not a bug but maybe a feature request. After creating my first 2 rom collections I started importing games. However I was a bit suprised that it actually started to download *.nfos and artworks, because I stored these locally. The reason was that the option "Use foldername as gamename" is off by default. Maybe you could ask for this option being on or off in the configuration wizard? But its not a big deal
I don't think it is the foldername option. I guess it is just the fact that the config wizard aims at new users with new collectios (without available artwork/info). In earlier releases there have been options to point RCB to your existing artwork folders but this was quite confusing for new users.

Maybe I could add kind of an expert mode where you can adjust more advanced settings during the setup process.
(2020-04-06, 00:12)Kupo91 Wrote: 2) As I said I created only 2 rom collections in the beginning. I created the other ones afterwards though the settings menu. And I noticed that sometimes after ending the config wizard it didnt save some of my rom collection(s).
Here is a log file when it didnt save my psp and wii collection. https://paste.kodi.tv/ekiwupezal.kodi
But it doesnt depend on platforms. The same happened with gameboy color for example. But at the the next try it worked.
I have to check that. I also noticed some misbehaviour whether or not you save the config file after adding/removing rom collections. It only works if you DON'T save the config file after adding or removing a rom collection. Otherwise it will just rewrite the current configuration. This is quite confusing and I have to change this behaviour.
(2020-04-06, 00:12)Kupo91 Wrote: 3) When I tried to launch a gameboy game I got this error note:

Image

Here is the log file https://paste.kodi.tv/kucamezofu.kodi
(The screenshot is from when I tried to launch a ps1 game, the logfile is from when I tried to launch a gameboy game. But it came to the same result)
Thanks for the report. I just tested launching games with RetroPlayer. It is fixed now in Matrix branch.
Reply
Quote:I don't think it is the foldername option. I guess it is just the fact that the config wizard aims at new users with new collectios (without available artwork/info). In earlier releases there have been options to point RCB to your existing artwork folders but this was quite confusing for new users.

Maybe I could add kind of an expert mode where you can adjust more advanced settings during the setup process.

I just uninstalled RCB and made sure that there is no profile folder with old settings anymore. Then I installed RCB again and created 2 rom collections when the config wizard appeared. After creating these I clicked 'Cancel' in the import-games-dialog. Btw after the very first import dialog RCB always look like this:

Image

But since this happens only for the first start its not a big deal. I left RCB and reentered it. I again clicked 'Cancel' in the import-games-dialog and I got into my empty rom collection browser. I straight went into the rom collection settings and enabled the option 'Use foldername as gamename'. I saved my settings, left RCB, reentered it, the 'import-games-dialog' appeared, I clicked on 'Import' and voilá it imported my games without downloading any new artwork or nfo files. It only used my local data. (Even if it displayed 'Downloading .nfo'. But if this was true it would need a lot of time more than it actually did. So I'm pretty sure it used my local data)
 
Quote:I have to check that. I also noticed some misbehaviour whether or not you save the config file after adding/removing rom collections. It only works if you DON'T save the config file after adding or removing a rom collection. Otherwise it will just rewrite the current configuration. This is quite confusing and I have to change this behaviour.
You're right. When I click 'Cancel' instead of 'Save config' it saved all my 13 rom collections.
 
Quote:Thanks for the report. I just tested launching games with RetroPlayer. It is fixed now in Matrix branch.
Yes, Retroarch works too.
Reply
Hi @malte  , please try to solve the mame scraping problem when you have some time. Just try to scrape entire mame library (I think you dont need to own all the roms, since scraping is based on a dat file). 90% or more roms just get the filename, not game name.
Reply
(2020-04-06, 16:25)Kupo91 Wrote: I left RCB and reentered it. I again clicked 'Cancel' in the import-games-dialog and I got into my empty rom collection browser. I straight went into the rom collection settings and enabled the option 'Use foldername as gamename'. I saved my settings, left RCB, reentered it, the 'import-games-dialog' appeared, I clicked on 'Import' and voilá it imported my games without downloading any new artwork or nfo files. It only used my local data. (Even if it displayed 'Downloading .nfo'. But if this was true it would need a lot of time more than it actually did. So I'm pretty sure it used my local data)
Can you show me your config.xml? I will see if I can reproduce this error.
(2020-04-06, 18:31)trihy Wrote: Hi @malte  , please try to solve the mame scraping problem when you have some time. Just try to scrape entire mame library (I think you dont need to own all the roms, since scraping is based on a dat file). 90% or more roms just get the filename, not game name.
I added this to the todo list for (one of the) next release(s).
Reply
(2020-04-06, 22:23)malte Wrote: Can you show me your config.xml? I will see if I can reproduce this error.

What error do you mean? This is my config.xml https://paste.kodi.tv/voqidimobu
Don't be suprised about my emulatorcmd. Since I didnt need to launch a game yet, I just used a placeholder and took the first file which I found.
Reply
(2020-04-07, 00:03)Kupo91 Wrote: What error do you mean?
The error that it ignored your available data when you don't set "Use foldername as gamename". But I still can't imagine that this is the case. You don't have your games in folders and you are using RCBs default folder structure for artwork. So it should always find your available data. When I try this in my setup everything works as expected. When you scrape again and notice this behaviour, can you send me a log file again?
Reply
(2020-04-07, 07:00)malte Wrote:
(2020-04-07, 00:03)Kupo91 Wrote: What error do you mean?
The error that it ignored your available data when you don't set "Use foldername as gamename". But I still can't imagine that this is the case. You don't have your games in folders and you are using RCBs default folder structure for artwork. So it should always find your available data. When I try this in my setup everything works as expected. When you scrape again and notice this behaviour, can you send me a log file again?    

Oh sorry, you misunderstood me. Its not a bug. The reason why it ignores my local data is because my rom files have different names than my folder names. So if I dont set "Use foldername as gamename" it starts downloading because the names dont match.
When I said that Im suprised that it started downloading new artworks and nfo files I meant that I didnt had in mind that there is this option which I have to enable first. And it didnt came to my mind because you only find this option in the rom collection settings but not in the config wizard. So when the user is launching RCB for the very first time and there are no rom collections yet the config wizards appears. And when you finished the config wizard the import-games-dialog appears. There is no way to see this option until you cancel the import-games-dialog and go into settings first.
So my suggestion was to add a new dialog between the config wizard and the import-games-dialog. Something like: Check your entry. And then the rom collection settings appear. So the user can change these settings before the first import process got initiated. And he aso has the chance to correct his entries if something went wrong.
Sorry for the confusion.
Reply
  •   
  • 1
  • 376
  • 377
  • 378(current)
  • 379
  • 380
  • 394
  •   



Logout Mark Read Team Forum Stats Members Help
[RELEASE] Rom Collection Browser - Browse and launch emulator game ROMs20
This forum uses Lukasz Tkacz MyBB addons.