• 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 135
[OBSOLETE] Pandora Radio (Script) Music Addon
#61
@wowser,
Make sure when trying to log in that you are using your full email address. If you are then the only thing I can suggest is to check the email and pass again because the server is claiming it's invalid. Do you have any special characters in your password that might be getting translated incorrectly? If so try changing your password to purely alphanumeric as a test.


RE: Issues with encryption key files:
You need to actually open the file on github, not just right-click save as from the folder view, then make sure to click the raw link in the top right corner to get the actual file.
Image
Reply
#62
Works like a charm...

Thanks for the great script...
Reply
#63
spbogie Wrote:RE: Issues with encryption key files:
You need to actually open the file on github, not just right-click save as from the folder view, then make sure to click the raw link in the top right corner to get the actual file.

How did I miss that, shame on me, thanks!
Reply
#64
Is anyone having a problem with authentication? The script was working perfectly last night and today when I went to launch its giving me an authentication error message. "Failed to authenticate listener. Check username/password and try again".

I tried to reenter my credentials and getting the same error.
Reply
#65
There was a bump of the API version number. Fix is up on gitorious.
Reply
#66
spbogie Wrote:@wowser,
Make sure when trying to log in that you are using your full email address. If you are then the only thing I can suggest is to check the email and pass again because the server is claiming it's invalid. Do you have any special characters in your password that might be getting translated incorrectly? If so try changing your password to purely alphanumeric as a test.


RE: Issues with encryption key files:
You need to actually open the file on github, not just right-click save as from the folder view, then make sure to click the raw link in the top right corner to get the actual file.
Image

Thanks for the response. I never got it to work by editing the settings file or entering it when running the script.

However i edited the default.py and added my login information directly there and it works!

thanks for the great script.
Reply
#67
I've just added experimental proxy support. I have no way of testing it myself so I'm not sure if it actually works. For those who can test please grab the latest revision from the proxy branch on gitorious and let me know how it works. Just set your proxy server in xbmc's network settings and it will pull from there. If it works without breaking anything else, I'll merge it back into the master branch.
Edit: Few stupid mistakes on my part. Fixed in 193ba54
Reply
#68
Hi @spbogie,

Curious if you have any update as to the problems that Necromancyr was seeing with XBOX loading the stations, but then hanging on Opening File and not actually opening it. Do you happen to have an update on this? Thanks!
Reply
#69
I've done a quick fix to get this script running with the current svn trunk of xbmc.
It works, but with the current xbmc build it crashes after one song, at least on my machine. At least it runs, and plays the first song. Hope this is useful.

To get this working in trunk, do the following:

Place the pandora addon directory in your 'addons' folder within your xbmc directory.
Change the name of the pandora addon directory (probably 'xbmc-pandora') to 'com.pandora.music'

In default.py:
Insert the following after line 23:
__scriptid__ = 'com.pandora.music'
self.id = __scriptid__

Change the line reading:
self.settings = xbmc.Settings( path=scriptPath )
To:
self.settings = xbmc.Settings( self.id )

Create file called description.xml in the pandora addon folder with the following content:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<addoninfo>
<id>com.pandora.music</id>
<type>script</type>
<supportedcontent>
<content>audio</content>
</supportedcontent>
<title>Pandora</title>
<version>2.1.4</version>
<platforms>
<platform>all</platform>
</platforms>
<minversion>
<xbmc>25000</xbmc>
</minversion>
<!-- minimum revision of xbmc your addon will run on. Leave blank all for revisions-->
<minrevision></minrevision>
<summary>Pandora Music Streaming</summary>
<description>Pandora Music Streaming</description>
<authors>
<author name="spbogie" email="spbogie@xbmc.org" />
</authors>
<tags>
<tag>pandora</tag>
<tag>streaming</tag>
</tags>
<license>GPL</license>
</addoninfo>
Reply
#70
I had this great script working for a few days but today it will not authenticate my user name and password!
I erased the script and downloaded ir again and did a fresh install, added mu user name and password, but still not working.
(I can log in to Pandora from my PC)
I am using XBMC on ATV.

Any ideas as to what I should try to bring it back to life?

Thanks for the the great script.
Reply
#71
@viagrawal
As I do not have an xbox, I have no way to test this, but looking at the error it appears the player is having an issue with the file. Check your log files to see if it is the same error. A full debug log may give a better hint as well. Have you tried changing the file format in the script settings? You could also try changing the player core used in the play() function in pandaplayer.py. You can find valid values in the pydocs.

@changeling
Thanks for trying that out. I've been waiting for things to settle down in the trunk and them to release some proper documentation of the new addon framework before making any changes for it. A debug log may help track down the issue with playback.

@mique
Make sure you grabbed the most recent revision and double check your email and password. Is it actually reporting failed authentication, or just erroring?
Reply
#72
It is saying 'failed to authenticate...'
I did download the latest and re- entered my user and password, still same problem.
Perhaps I should add my user and password manually to the code? I would need to know where to enter it though!

Thanks
Reply
#73
Can you post a debug log of a failed authentication attempt please? (Use pastebin preferably)
Reply
#74
I activated debug mode and assigned a folder.
Rebooted and tried to get Pandora running. Went to debug folder via Tunnelier and nothing is in the debug folder!!
What am I doing wrong?
Mique.
Reply
#75
OK, I got it now. I have it on paste bin but not sure how to point to it!
How is this?
http://xbmc.pastebin.com/vKJcSvxA

Thanks for your help,
Reply
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 135

Logout Mark Read Team Forum Stats Members Help
[OBSOLETE] Pandora Radio (Script) Music Addon11
This forum uses Lukasz Tkacz MyBB addons.