• 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 135
[OBSOLETE] Pandora Radio (Script) Music Addon
#76
Quote:org.apache.xmlrpc.XmlRpcException: 000.000.000.000|0|INCOMPATIBLE_VERSION|Pandora does not support your client version.
Check <scripts>/Pandora/libpandora/pandora.py, PROTOCOL_VERSION should be set to 27. If not then you have an old version of the script. Download the latest from gitorious. http://gitorious.org/xbmc-pandora/xbmc-p...ees/master
Reply
#77
All Good now, thanks.

Great to have this script up and working again.
Reply
#78
Just pushed an update adding a "Hidden Player" mode. Click the little arrow under the play/pause button and the player will disappear to show fullscreen visualizations. Tested and working under Windows. Running into a few issues on Linux, feel free to try it but it may not work.
Reply
#79
spbogie Wrote:Just pushed an update adding a "Hidden Player" mode. Click the little arrow under the play/pause button and the player will disappear to show fullscreen visualizations. Tested and working under Windows. Running into a few issues on Linux, feel free to try it but it may not work.

What button stops this script. It runs full screen visualization and if I hit escape or stop, it just restarts a new song.
Reply
#80
Windows or Linux? As I said, Linux is having issues with the Hidden Player mode right now. If you're on Linux, stick with commit 4e4b37e for the time being.
Reply
#81
Hi spdogie,

I was wondering if you could help me out with this error.

INFO: -->Python script returned the following error<--
ERROR: Error Type: exceptions.AttributeError
ERROR: Error Contents: 'NoneType' object has no attribute 'doModal'
ERROR: Traceback (most recent call last):
File "/home/xbmc/.xbmc/scripts/Pandora/xbmc-pandora-xbmc-pandora/default.py", line 140, in ? panda.main()
File "/home/xbmc/.xbmc/scripts/Pandora/xbmc-pandora-xbmc-pandora/default.py", line 115, in main self.gui.doModal()
AttributeError: 'NoneType' object has no attribute 'doModal'
INFO: -->End of Python script error report<--

Thanks,



Update, I noticed your post about the latest 4e4b37e version for Linux. I updated to this version and I am still getting the above error. I have also tried downloading and copying and pasting the 2 key files. Again, same error as above. The Script page gets a Pandora Failed to authenticate listener. Not sure if that helps or not.
Reply
#82
Can you post a more complete log please. That error suggests something went wrong earlier in the script execution.
Reply
#83
spbogie Wrote:Windows or Linux? As I said, Linux is having issues with the Hidden Player mode right now. If you're on Linux, stick with commit 4e4b37e for the time being.

I am on windows.
Reply
#84
spbogie Wrote:Can you post a more complete log please. That error suggests something went wrong earlier in the script execution.

Thanks again for taking a look at this. I belive I have from the select button that starts the script. If this is not enough please let me know.

23:46:10 T:3077687184 M:1042812928 DEBUG: OnKey: 168 pressed, action is Right
23:46:11 T:3077687184 M:1042821120 DEBUG: LIRC: Update - NEW at 53571499:000000037ff07bdd 00 OK mceusb (OK)
23:46:11 T:3077687184 M:1042821120 DEBUG: OnKey: 11 pressed, action is Select
23:46:11 T:3077687184 M:1042821120 DEBUG: ------ Window Deinit (DialogPluginSettings.xml) ------
23:46:11 T:2604661616 M:1042821120 INFO: Loading skin file: DialogProgress.xml
23:46:11 T:2604661616 M:1042821120 DEBUG: Load DialogProgress.xml: 19.29ms
23:46:11 T:2604661616 M:1042821120 DEBUG: DialogProgress::StartModal called
23:46:11 T:2604661616 M:1042821120 DEBUG: ------ Window Init (DialogProgress.xml) ------
23:46:11 T:2604661616 M:1042821120 DEBUG: Alloc resources: 0.09ms (0.01 ms skin load)
23:46:11 T:2604661616 M:1042821120 NOTICE: Error:
23:46:11 T:2604661616 M:1042821120 NOTICE: com.savagebeast.radio.api.protocol.xmlrpc.RadioXmlRpcException: 192.168.160.76|1272685567090|AUTH_INVALID_USERNAME_PASSWORD|Invalid username and/or password
23:46:11 T:2604661616 M:1042821120 NOTICE: Code:
23:46:11 T:2604661616 M:1042821120 NOTICE: 1
23:46:12 T:2604661616 M:1042821120 INFO: Loading skin file: DialogYesNo.xml
23:46:12 T:2604661616 M:1042821120 DEBUG: Load DialogYesNo.xml: 18.92ms
23:46:12 T:3077687184 M:1042821120 DEBUG: ------ Window Init (DialogYesNo.xml) ------
23:46:12 T:3077687184 M:1042821120 DEBUG: Alloc resources: 0.09ms (0.01 ms skin load)
23:46:12 T:3077687184 M:1042821120 DEBUG: ------ Window Deinit (DialogProgress.xml) ------
23:46:13 T:3077687184 M:1042821120 DEBUG: LIRC: Update - NEW at 53573612:000000037ff07bdd 00 OK mceusb (OK)
23:46:13 T:3077687184 M:1042821120 DEBUG: OnKey: 11 pressed, action is Select
23:46:13 T:3077687184 M:1042821120 DEBUG: ------ Window Deinit (DialogYesNo.xml) ------
23:46:13 T:2604661616 M:1042821120 INFO: -->Python script returned the following error<--
23:46:13 T:2604661616 M:1042821120 ERROR: Error Type: exceptions.AttributeError
23:46:13 T:2604661616 M:1042821120 ERROR: Error Contents: 'NoneType' object has no attribute 'doModal'
23:46:13 T:2604661616 M:1042821120 ERROR: Traceback (most recent call last):
File "/home/xbmc/.xbmc/scripts/Pandora/xbmc-pandora-xbmc-pandora/default.py", line 140, in ?
panda.main()
File "/home/xbmc/.xbmc/scripts/Pandora/xbmc-pandora-xbmc-pandora/default.py", line 115, in main
self.gui.doModal()
AttributeError: 'NoneType' object has no attribute 'doModal'
23:46:13 T:2604661616 M:1042821120 INFO: -->End of Python script error report<--
23:46:13 T:3077687184 M:1042821120 DEBUG: ------ Window Init (DialogKaiToast.xml) ------
23:46:13 T:3077687184 M:1042821120 DEBUG: Alloc resources: 0.01ms (0.01 ms skin load)
23:46:14 T:2604661616 M:1042825216 INFO: Python script stopped
23:46:14 T:2604661616 M:1042825216 DEBUG: Thread 2604661616 terminating
23:46:14 T:3077687184 M:1042825216 DEBUG: python thread 26 destructed
23:46:14 T:3077687184 M:1042825216 DEBUG: CGUIMediaWindow::GetDirectory (special://home/scripts/Pandora/)
23:46:14 T:3077687184 M:1042825216 DEBUG: ParentPath = [special://home/scripts/Pandora/]
23:46:14 T:3077687184 M:1042825216 WARNING: CRITSEC[0xb0bec74]: Trying to initialze initialized section.
23:46:14 T:3077687184 M:1042825216 DEBUG: CDatabase: Connecting to database ViewModes at /home/xbmc/.xbmc/userdata/Database:
23:46:14 T:3077687184 M:1042825216 DEBUG: CDatabase: Connecting to database ViewModes at /home/xbmc/.xbmc/userdata/Database:
23:46:14 T:3077687184 M:1042825216 DEBUG: CDatabase: Connecting to database ViewModes at /home/xbmc/.xbmc/userdata/Database:
Reply
#85
@igotdvds
Hmmm, whatever key/button is set to trigger ACTION_PREVIOUS_MENU (should be Esc by default) should exit the script (or bring the player back up if you've hit the hide player button). Can you describe a little more detail about what's happening. Is the script starting directly into fullscreen vis mode, or are you starting a station playing first? Are you clicking the hide arrow or is it doing it on its own? A debug log may also be useful.

@xbmcTG
Slight mistake on my part with that error, however it should only be triggered if you press No after a failed login attempt, in which case the script would be exiting anyways. I'll push a fix once I figure out the issues with Hidden Player mode, but shouldn't really cause a problem. Double check your username(e-mail) and password in the script settings are correct.
Reply
#86
I have installed all of the needed files on my XBOX. It will log me on but it doesn't load/download my playlists. It just hangs there with nothing populating on the screen. How do I get to deplug log of the script?

I am using an older version of XBMC for XBOX.

Thanks All

Also the only way I can get out of it is to reboot the xbox.
Reply
#87
spbogie Wrote:@xbmcTG
Slight mistake on my part with that error, however it should only be triggered if you press No after a failed login attempt, in which case the script would be exiting anyways. I'll push a fix once I figure out the issues with Hidden Player mode, but shouldn't really cause a problem. Double check your username(e-mail) and password in the script settings are correct.


@spbogie

I had retyped in username and password a couple of times with no luck previously, but I went ahead and did it again. This time before I launched the script, I went to the script settings and deleted out all the info and typed it in anew. Hit ok, then launched the script.

It worked!?? Thank you for the script and suggestion but I not sure why it worked this time and not before. I may have missed something when typing it in the first few times, I did this previously by running the script and at the prompt that it could not log in I chose the Yes option to show the setting and entered the info in here. This shouldn't matter, but more then likely it was my fault.

Apologies and thanks again.
Reply
#88
@powerismine
http://wiki.xbmc.org/index.php?title=Log_File

@xbmcTG
Glad you got it working.
Reply
#89
@spbogie. in linux the stop button on my ASRock 330 remote switches to the next track instead of stopping the music. the only way i've been able to successfully exit the script is to press the green (media) button.

is there a way the script can be edited in the next version to stop the music if a user presses stop on the remote?
Reply
#90
I'm still having dreadful performance on Linux, current script takes 10 minutes to get past the "Logging In" and the "Fetching Stations" part is still running.
Reply
  • 1
  • 4
  • 5
  • 6(current)
  • 7
  • 8
  • 135

Logout Mark Read Team Forum Stats Members Help
[OBSOLETE] Pandora Radio (Script) Music Addon11
This forum uses Lukasz Tkacz MyBB addons.