Thread Rating:
  • 0 Vote(s) - 0 Average
themoviedb scraper now partly broken
#31
Not working for me as of 5 minutes ago, picking up maybe 5-10% of thumbnails and cant find any more thumbnails when adding individually.

Major pain, is there any other way to reliably scrape the info?
Reply
#32
The info should be updated as of 24hrs of the correction, according to the time it was actually updated (see here for the last post where travis bell says)

Quote:Update was just deployed. In approx. 24 hours, as the cached items get refresh things should start working again.
as of
5/03/2010 01:49:08
(never did much like waiting myself but thanks to everyone helping with the fix Smile )
4 Xbox1's 500GB WD HD with XBMC-9.04.1-FIXED-BABYLON-T3CH (was PM3.HD 1080i but streaming larger files...PMIII in 720P)
2 Acer Revo 1600s 2gb ram 1.6 Ghz (yes, 1.6 single...sigh) -> Linux 2.6.31-16-generic #53-Ubuntu XBMC 9.11 R26018 (Influence 1080P)
Just started with DDS, one word, awesome!
.bat files for windows dds creating here (must have nvcompress installed)
Reply
#33
Confirmed working again for Xbox, made my day. Thanks to those involved!
Reply
#34
Cast is now having a similar problem to images.

XBMC expects the person element to look like:
<person {some stuff} name="someone" character="someone" job="Actor" ...

Whereas TMDB have changed their API and it is now appearing as:
<person job="Actor" character="someone" url="somewhere" name="someone" ...

So the regex is not matching.
Reply
#35
aptalca Wrote:*********IMPORTANT - - - PLEASE READ***********



I just talked to Travis who runs tmdb, he wasn't aware of the problem we were having. The change in their api was not supposed to break the scrapers. He will update his api so the original (unmodified) tmdb scrapers should work after the update.

Keep in mind that whatever is currently cached in their system will take about 24 hours to update.

If your scraper is currently not working, do not do anything, just wait a day, it will start working as before.

If you already modified your scraper, you are probably going to have to revert back to the original one by tomorrow.

So I unwisely did not create a tmdb.xml.old before applying the modified version posted earlier in this thread. Can someone pastebin a default version of the common tmdb.xml so I can revert back?

Thanks in advance!
Reply
#36
The beauty of open source
http://trac.xbmc.org/browser/trunk/addon...g/tmdb.xml
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#37
Hello together,

im an absolut noob in xbmc. I just started a few days ago. Here in Croatia is the supprt not so well, and i hope my english is good enough Huh

So i must ask this: All i have to do is just wait "1 day" and the scraper will works fine again? Cuz i got covers from imdb BUT no fanarts since 2 days=(

I have over 400 Movies and don't want to loose my libary...

Thx 4 answer
Reply
#38
A question for those more knowledgeable on regex or XBMC scraper's than me. Why is that the following query matches.

Code:
<thumb>(.*?)url="([^"]*)" width="[^"]*" size="mid"(.*?)</thumb>

But this query doesn't

Code:
<thumb>(.*?)url="([^"]*)".*?size="mid"(.*?)</thumb>

The first matches because it finds the width attribute, but in the second regex I'm trying to mask out anything between the URL close quote and the size attribute. This always fails. Frustrating, because this would make it simple to take out the width parameter whether it was there or not. But my regex knowledge is very limited.
Reply
#39
sho Wrote:The beauty of open source
http://trac.xbmc.org/browser/trunk/addon...g/tmdb.xml

Beautiful indeed! Muchas muchas!!
Reply
#40
I'm getting this problem as well and not able to get fanart scraped. I'm assuming I just have to sit tight? I'm using XBMC Live 9.11.

The other problem that I am noticing is that in the synopsis I get the movie description, but they all have "Fullsummary&raquo;" at the end of the film blurb. I'm guessing this is a separate issue, but how do I fix it? I can't seem to find much in the way of info.
Reply
#41
I see the order of the attributes are changing now. I scraped 6 movies, and 4 of them had the old attribute order, two of them were new. So you should find the scraper starting to work from now.
Reply
#42
splobber Wrote:The other problem that I am noticing is that in the synopsis I get the movie description, but they all have "Fullsummary&raquo;" at the end of the film blurb. I'm guessing this is a separate issue, but how do I fix it? I can't seem to find much in the way of info.

I haven't seen this problem. Can you give me a movie name, and your XBMC version?
Reply
#43
Working now for me (version number for my revo below). I don't see any problems with the plot or anything else Smile thanks again ev1 Nod


edit:3 (now)
except for HHGTTG (The Hitchhiker's Guide to the Galaxy). My other new movies scraped fine, this one didn't. --------fixed
edit2:
The Chronicles of Narnia: The Lion, the Witch, and the Wardrobe (gonna add new titles without edit note) --------fixed
Cinderella --------fixed
City Slicker's 2: The Legend of Curly's Gold --------fixed
so 5 scraped well and 4 did not (all data on those 4 but thumbs/fanart) the next 15 hours or so should put most/all of the movies through that 24 hr cache.


@Travisbell thanks for the update and re-correction, it is a wonderful service your site offers and y'all do one heck of a job Smile.
4 Xbox1's 500GB WD HD with XBMC-9.04.1-FIXED-BABYLON-T3CH (was PM3.HD 1080i but streaming larger files...PMIII in 720P)
2 Acer Revo 1600s 2gb ram 1.6 Ghz (yes, 1.6 single...sigh) -> Linux 2.6.31-16-generic #53-Ubuntu XBMC 9.11 R26018 (Influence 1080P)
Just started with DDS, one word, awesome!
.bat files for windows dds creating here (must have nvcompress installed)
Reply
#44
so i got 20 newer movies.... 19 got a cover just 2 the fanart...

so actually it's not running good... ! I got dhe xbmc 9.11 running under vista ultimate... ! Do i have to update something?
Reply
#45
I would suggest everyone waits a while. As I said, the website is in the process of changing over - I'm not sure how it works internally, but if caching is involved then it is just a matter of time before all of the xml returned is in the correct order.

And don't forget - if you don't get a poster, it might be because the movie doesn't have one. I suggest you check the TMDB website first.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
themoviedb scraper now partly broken00