Problems compiling latest SVN
#1
Hi,

I'm currently trying to compile latest SVN on Ubuntu 10.04 running on a Acer Revo R3610.
Used the following configure line:

PHP Code:
configure --enable-external-libraries --enable-vdpau --enable-mid --enable-goom --enable-asap-codec --enable-libdts --enable-liba52 

Installed all the required lib/dev packages.
Now I get the following error trying to compile the DVDCodecs module:

PHP Code:
In file included from DVDFactoryCodec.cpp:49:
Audio/DVDAudioCodecPassthrough.h:47errorconflicting return type specified for ‘virtual int8_tCDVDAudioCodecPassthrough::GetChannelMap()
Audio
/DVDAudioCodec.h:96error:   overriding ‘virtual PCMChannelsCDVDAudioCodec::GetChannelMap()
Audio
/DVDAudioCodecPassthrough.hIn member function ‘virtual int8_tCDVDAudioCodecPassthrough::GetChannelMap():
Audio/DVDAudioCodecPassthrough.h:47errorinvalid conversion from ‘uint8_t*’ to ‘int8_t*
make
[1]: *** [DVDFactoryCodec.oError 1
make
[1]: Leaving directory `/home/derchris/xbmc/xbmc/cores/dvdplayer/DVDCodecs'
make: *** [xbmc/cores/dvdplayer/DVDCodecs/DVDCodecs.a] Error 2 

Anyone knows how to fix this?
Could it be a problem with one of the libs/dev packages installed?

Thanks in advance,
Christian
Reply
#2
Strip this off: "--enable-libdts --enable-liba52"
Reply
#3
Thanks,

I was actually looking at the .cpp file in question right after I posted it here, and could see that libdts and liba52 are including the files in question.
So I re-run configure and system is now compiling again.

Let's see how this goes, but should be ok now.

Out of interest, what are these 2 options used for, or better when should they be used.

Regards,
Christian
Reply
#4
I tried installing latest svn to, but it failed to make install.
so gave up, but i cant revert back to ppa?,
so now i cant get xbmc to start since its trying to start the compiled version

an easy command to remove compiled version and go back to ppa?
Reply
#5
nevermind, did a make uninstall and things went back to normal.

happy times.
Reply
#6
make install doesn't work because it still points to the 'old' skin, visualizations and screensavers folders
to install, after make install fails while doing install-arch, you can run make install-datas (which will fail the same because the skin folder is not there) and make install-web, and everything will work (or at least does here)
Reply
#7
I was just about to post about this! install-datas and web both worked for me but how do we go about fixing the install-arch failure? I'm not sure what effect this has but I noticed my system crashing whenever it tried to get to the screen-saver so I figured something must be missing...?
Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
Reply
#8
succo Wrote:make install doesn't work because it still points to the 'old' skin, visualizations and screensavers folders
to install, after make install fails while doing install-arch, you can run make install-datas (which will fail the same because the skin folder is not there) and make install-web, and everything will work (or at least does here)

seems to be fixed in r29730.
Reply
#9
Same here, fixed and working! I saw configure.ini update and crossed my fingers - sure enough it's fine now. Thanks DEVS!!!
Openelec Gotham, MCE remote(s), Intel i3 NUC, DVDs fed from unRAID cataloged by DVD Profiler. HD-DVD encoded with Handbrake to x.264. Yamaha receiver(s)
Reply
#10
Cool, will give it another try then.

Edit:

Compile was ok, but had to tweak it a little. (rev 29739)
Couldn't get Goom compiled, so left it out, and had to replace 2 libtools for libdvd and libid3tag

After make install it will start, but I could see some problems with the default Skin, not able to load some of the scripts for latest Movies/TVs ...
Now what I see is, it will not show any of my Scripts/Program, which were available before in the PPA release of XBMC.

It looks like it is not loading anything from .xbmc, as I'm also not able to switch to any of the Skins I downloaded.
Is there anything else I need to check?

Apart from that, the latest SVN fixed all my recent errors I got:

- No more stutter when selecting "Sync to Display refresh rate"
- Digital Audio over HDMI

I'm looking forward to the next XBM release, which I hope has all this already included.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Problems compiling latest SVN00
This forum uses Lukasz Tkacz MyBB addons.