Thread Rating:
  • 1 Vote(s) - 5 Average
Is it possible to turn on my Revo remotley?
#16
gabbott Wrote:True you have to enable it in the BIOS, but you also have to configure the Ethernet interface within linux to support it, otherwise it doesn't work.

so what am I doing wrong? I think its my mac address on the eth0 being different. has anyone got a solution or some suggestions on this? should I try to change my mac address? can this be done?


jhsrennie- i will try that software and see if it works.
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#17
Do you have ethtool installed? Be sure to do that first.

I followed the Manual installation method here:
http://ubuntuforums.org/showthread.php?t=234588
Reply
#18
well I checked my router and it gives me three options for a router MAC address

use default address (currently on this option)
use computer mac address
use this mac address

so should I change this to use computer mac address? maybe that is my problem that the magic packs are not being received by my pc as the router is stopping it before it gets to the PC hardware.

my router is a netgear WNDR3300.
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#19
LurkAzusa Wrote:Do you have ethtool installed? Be sure to do that first.

I followed the Manual installation method here:
http://ubuntuforums.org/showthread.php?t=234588

I have ethtool installed already. also I am following the same guide.

I tried to switch using the option "use computer mac address" and then I could not get on the internet anymore.
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#20
Help anyone.
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#21
rflores2323 Wrote:Help anyone.

Switch to Windows. The wake on lan just works without needing any messing around.

Why WOL should have any interaction with the OS escapes me since it operates when the computer is powered off and therefore no OS is running. Perhaps the Linux NIC drivers disable WOL in some way that survives a power cycle.

JR
Reply
#22
Right, you'll have to enable it (for some reason) via ethtool. Search the forums and/or the wiki for detailed instructions.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#23
vdrfan Wrote:Right, you'll have to enable it (for some reason) via ethtool. Search the forums and/or the wiki for detailed instructions.

it is enabled.
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#24
Given it's activated in BIOS and you're waking from the same network, it should work. No idea why it should fail.
Always read the online manual (wiki), FAQ (wiki) and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules (wiki).
Please read the pages on troubleshooting (wiki) and bug reporting (wiki) before reporting issues.
Reply
#25
rflores2323 Wrote:I have ethtool installed already. also I am following the same guide.

I tried to switch using the option "use computer mac address" and then I could not get on the internet anymore.

What is your output when you run 'ethtool eth0'?
Reply
#26
gabbott Wrote:What is your output when you run 'ethtool eth0'?

well I thought it was enabled. my output shows below

[email protected]:~$ ethtool eth0
Settings for eth0:
Cannot get device settings: Operation not permitted
Cannot get wake-on-lan settings: Operation not permitted
Cannot get link status: Operation not permitted
No data available

have gone and enabled it as per below.

Code:
[email protected]:~$ sudo ethtool -s eth0 wol g
[sudo] password for xbmc:
[email protected]:~$ sudo ethtool eth0
Settings for eth0:
    Supported ports: [ MII ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 1
    Transceiver: external
    Auto-negotiation: on
    Supports Wake-on: g
    Wake-on: g
    Link detected: yes
[email protected]:~$ ethtool eth0
Settings for eth0:
Cannot get device settings: Operation not permitted
Cannot get wake-on-lan settings: Operation not permitted
Cannot get link status: Operation not permitted
No data available
[email protected]:~$

so what in the heckHuh Im confused.
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#27
rflores2323 Wrote:well I thought it was enabled. my output shows below

[email protected]:~$ ethtool eth0
Settings for eth0:
Cannot get device settings: Operation not permitted
Cannot get wake-on-lan settings: Operation not permitted
Cannot get link status: Operation not permitted
No data available

have gone and enabled it as per below.

Code:
[email protected]:~$ sudo ethtool -s eth0 wol g
[sudo] password for xbmc:
[email protected]:~$ sudo ethtool eth0
Settings for eth0:
    Supported ports: [ MII ]
    Supported link modes:   10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Supports auto-negotiation: Yes
    Advertised link modes:  10baseT/Half 10baseT/Full
                            100baseT/Half 100baseT/Full
                            1000baseT/Full
    Advertised auto-negotiation: Yes
    Speed: 100Mb/s
    Duplex: Full
    Port: MII
    PHYAD: 1
    Transceiver: external
    Auto-negotiation: on
    Supports Wake-on: g
    Wake-on: g
    Link detected: yes
[email protected]:~$ ethtool eth0
Settings for eth0:
Cannot get device settings: Operation not permitted
Cannot get wake-on-lan settings: Operation not permitted
Cannot get link status: Operation not permitted
No data available
[email protected]:~$

so what in the heckHuh Im confused.


So your output:

Code:
Supports Wake-on: g
    Wake-on: g

Is showing your NIC supports it and currently set for WOL via magic packet. Not sure why it wouldn't be working. Maybe hit up the Ubuntu forums.
Reply
#28
gabbott Wrote:So your output:

Code:
Supports Wake-on: g
    Wake-on: g

Is showing your NIC supports it and currently set for WOL via magic packet. Not sure why it wouldn't be working. Maybe hit up the Ubuntu forums.

man this is frustrating. I will go over to the ubuntu forums and see if anyone there can help me figure it out. Thanks again.
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#29
rflores2323 Wrote:man this is frustrating. I will go over to the ubuntu forums and see if anyone there can help me figure it out. Thanks again.

Do you have port 7 forwarded in your router?

If not then that is probably why it is not working.

Jerry
Reply
#30
Yes i did forward that port
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply



Is it possible to turn on my Revo remotley?51