Thread Rating:
  • 1 Vote(s) - 5 Average
Is it possible to turn on my Revo remotley?
rflores2323 Wrote:Yes i did forward that port

How? What exactly did you put in the router?

jawilljr Wrote:How? What exactly did you put in the router?



went into router and set it up like above.

also my router status shows this (dont know if this makes a difference as the MAC address is different)

ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Was any one able to find a resolution on this? I'm running into the same issue and its driving me nuts.
Are you TRYING to wake over the internet? Or on your internal network. I ask because the router configuration change you've made is only necessary if you need to send the WOL from the internet. If you are only after WOL from inside the house, you should remove the router rule.

I have had NO success getting WOL working on either of my Revo R3600 machines. I have tried several methods of sending the magic packet - with no success.

Out of interest, has ANYONE reading this thread managed to get WOL working on an Acer Revo?
OK... let's try some basics.

Ensure WOL is enabled in the BIOS, reboot the Revo and press F12 to get the boot options menu up. Hold down the power button to shutdown the Revo. Now try to WOL from another PC. Does this work? (Probably if the BIOS is setup correctly).

If that works, restart the Revo, let XBMC start. Then SSH to the Revo - or go to a console session and recheck your WOL settings with "sudo ethtool eth0" as you did before.

Is "wake on" still set to g? Or d?

If "d", enable WOL with:-

sudo ethtool -s eth0 wol g

and check that worked with

sudo ethtool -s eth0

Now SUSPEND the Revo from the XBMC menu. Try to WOL again. Does this work? If it does, reboot the Revo, let XBMC start, and check WOL status with "sudo ethtool eth0" again. Is "wake on" set to "d" again?

If so, the OS is disabling WOL on each boot. Try:-

sudo nano -w /etc/rc.local

and add the following to the end of rc.local

ethtool -s eth0 wol g

This might hopefully fix the issue. And therein lies the answer of why the hardware-only WOL is OS-dependant.... I think the Ubuntu OS is DISABLING WOL on boot. Smile

Try it - if it works, damn - wished I'd thought of this at the weekend. I was playing with XBMCCommander on the iPad - really cool and TOTALLY perfect if I can get WOL working!
Well I finally got it work. The reason it did not work was that I had s3 enabled in the BIOS. I read HERE about putting it on S1 and it worked with WOL from hibernation and the pc off to wake it up. Great.

One thing however is when it wakes up from hibernation it asks me to login to get back into ubuntu. how can I make this automatically log in?

ok found my answer

Enabling automatic Login after suspend HERE

1. Type gconf-editor in a terminal (Alt+Ctrl+T to call the terminal).
2. Go to apps/gnome-power-manager/locks
3. Check "use_screensaver_settings".
4. If still asked for password, you can (also in gconf-editor) go to desktop/gnome/lockdown and check: "disable_lock_screen"
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Thanks for these posts, spent a day and a half on this now and finally got it to work thatnks to jpennell's post. Would never have thought the OS was setting a parameter on the NIC, thought it was all down to the BIOS.

Regarding the last post from the originator you may want to have a look at the latest BIOS from Acer (1.4 I think) which some peole are saying lets you WOL from S3 which is the more prefereable hibernation state (in my opinion). After applying jpennell's change to my XBMC Ubuntu setup I can now WOL from a complete shutdown and from S3 using a number of diferent WOL clients using the latest BIOS.

I'm still having one last issue with the XBMC remote for the iPhone as that will only WOL from Suspend (S3) and not from a complete shutdown... It's got to be perfect Smile

I'll post if I get that working too in case anyone else has this setup.

Is it possible to turn on my Revo remotley?51