Sudden problem to stream files to xbox
#1
Hi.
So I was running a June 09 XBMC and suddenly started to have problems with lock precerence on new files I added to my shared folder on my PC.
I upgraded to newest version xbmc. Iv removed user/pass from SMB settings so they are blank in xbmc.
I can see all the files and folders on my pc from my xbox, but when I try to play them either nothing hapends or i get "playback failed". Checking the log I get some error 0
But strangly it seems its only the files thats in sub folders in my shared folder that wount run. The files directly in the shared folder works fine.

Im running xp media center edition and here is my debug log: http://pastebin.ubuntu.com/432421/

Also I was wondering, how do you delete the shortuts you make to computers, folders on the disk and more?
Hope someone can help.
#2
So I searched around and found out the best way might be to make a new user in windows called xbox and use that to connect.

My problkem is that I was foolish and am using the default user profile that windows xp uses. So if I try to make another user my entire user and everything wil be deleted. Is there a way I can copy this or get around this problem?
#3
Adding a new user to your system will not cause the deletion of other user accounts. Unless there's some weird quirk in XP Media Center Edition I've somehow never heard of.

That said, there's no real need to create another user account, and that route is more trouble then it's worth. It's just that the sharing permissions on your subfolders aren't set to allow the Guest account access (or the Everyone group, to be more precise). Even if you created another user account, you'd need to tweak these settings to give that access...

Assuming you're using Simple File Sharing (SFS) (and if you're not sure, you probably are - it's on by default), just unsharing and resharing your shared folder will probably be enough to sort things out.

By "shortcuts", do you mean the link icons within Windows, or the entries on your source list within XBMC?
XBMC Manual - BlackBolt - SVN Guide - Skin SVN - Wide Icon SVN - ROM Shortcut Generator
You're just jealous 'cause the voices only talk to me :P
#4
Hi.
Iv removed easy sharing.

Iv also tried with upnp but it seems many of the new versions is not stable on this, so I tried downgrading with no luck. With upnp the xbox on some xbmc versions freezes while searching for folder, and on other dont freeze there but dos afer a few minutes use in upnp mode. I am using windows media connet 2.
I have tried using SMB as you said, and after working with the sub folders in the setting I hope I got it right. It works for now atleast.
Also when adding new sub folders on a later date, do I have to re share the intire folder?
#5
That depends entirely on what mood Windows is in at the time. It might happen again, it might not.

I assume it depends how the sub-folders are introduced to the share, but I've never bothered to research it. Doesn't seem to happen all that often.
XBMC Manual - BlackBolt - SVN Guide - Skin SVN - Wide Icon SVN - ROM Shortcut Generator
You're just jealous 'cause the voices only talk to me :P
#6
Hm, I see.
I seem to have a problem of it doh. My sub folders and files are introduced by utorrent. So when an torrent has finished to download, the whole folder and file is moved to the share xbox folder.
So all new folders/files added that way cannot be read by the xbox. I can see them, but not enter. Tried to unshare and share with no effect.


Edit:
So it seems that I have a different problem I cnat get. And this is why I dont get it. Iv been downloading 2 tv series, smallville and supernatural. All the supernatural epps all avi plays fine straight from utorrent to smb. Smallville avi not a chance... 5 files of both, same problem... All downloaded from utorrent all in smb. ANY ideas why identical files but different series get different responses? Wink
#7
Perhaps if you share your uTorrent folder as well (even if you don't intend to access it as a share), then similar permissions would be applied to begin with and moving the files later won't trigger the issue?
XBMC Manual - BlackBolt - SVN Guide - Skin SVN - Wide Icon SVN - ROM Shortcut Generator
You're just jealous 'cause the voices only talk to me :P
#8
Bomb Bloke Wrote:Perhaps if you share your uTorrent folder as well (even if you don't intend to access it as a share), then similar permissions would be applied to begin with and moving the files later won't trigger the issue?

That was what I was thinking, and is the reason why I moved the torrent folder inside my smb so its shared. The strange thing is that it seems some avi work great, but some dont. Is there something special with xbmc and some videos, tv series and sutch? I t seems strange that one tv-series avi does work and another avi tv series dont.
#9
Check what your debug log has to say on the matter. It may be it's still a permissions-related issue, that is to say, nothing to do with XBMC.
XBMC Manual - BlackBolt - SVN Guide - Skin SVN - Wide Icon SVN - ROM Shortcut Generator
You're just jealous 'cause the voices only talk to me :P
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Sudden problem to stream files to xbox00