[RELEASE] Swiss-Army-Knife Addon - Blu-ray and DVD-Video Ripper and Transcoder
I worked on getting Swiss-Army-Knife (SAK) to recognize the valid MKV license so I could try the BD feature. Put a BD disk in the drive and selected Transcode BD to mkv. 15 seconds later a message appears, yep you guessed it, "File swiss-army-knife/media/state could not be openend".

Oh, by the way, I finally got the SD dvd to backup. I manually ran the dvd-iso.sh and entered in the 3 variables it was looking for and it copied 7.72 GB of Avatar. And those 3 variables were taken from the scripts that I ran manually, then I executed ./dvd-iso.sh /dev/sr0 ~/Videos/ Avatar.
I created a wiki page with all the shell-scripts including all parameters

zilexa Wrote:Could you perhaps add the option to copy dvd to video_ts folder (instead of ISO)?

Next release 0.6.12 do use vobcopy to copy all vob's to a local disk.
I made the scripts ... and they work like expected ...
Regards Hans
release 0.6.12 is ready to test over repository
What means this error:

Prior to run this addon setup.sh must be executed

Please do as it is described in the message .... (and in the readme btw)
Run setup.sh
Hi Linuxluemmel

Just discovered this new plugin ( was using red pill before ). Gratz. Cool

Installer setup.sh seems to work flawlessly on Debian Testing here.

On what i 've could test with ( dvd only ), it seems to be ok so far with default installation.

One important thing is missing to me from your previous plugin. You can't transcode dvd or blueray from iso image or VIDEO_TS directory.
Is it a planned feature on your roadmap ?

yes ...it is on the agenda ...
I guess we should use the old thread luemmels-dvd-ripper ....
linuxlemmel where can i get this addon, i can't seem to find it anywhere?
Press THANK USER if I Help
you have 2 choices ....

repository version 0.6.14


svn checkoout of 0.6.15

svn checkout http://swiss-army-knife.googlecode.com/s...rmy.knife/ swiss-army-knife-read-only

edit :
could we use this thread in the futue ....

After I just found out how to run the setup.sh file all is good. Beeing a n00b it took me a while to discover that I had to write

sudo bash setup.sh xbmc

kudos for doing the job!

Hello could you make this work for windows also..

Thank You
When I tried to install this I get that makemkv was unsuccessful. I tried to rerun the setup.sh file a few more times with no luck and now when I try to open Swiss Army Knife in XBMC 10.1 (as OS) it says that configured ssh user is not current user. I feel like I am making things worse. I have entered a few different names for the ssh step of the setup.sh file (is there a specific way to enter this)

A) How can I fix these two things or
B) Remove all progress and start over with the latest version.

I am currently trying to use sak-svn-snapshot-09032011.zip

I am still pretty new to this and do not know how to properly get this going with the tar.gz compression. (I know how to dpkg but I do not know what to do with the .deb files from there)

Again I am using XBMC 10.1 as my OS on a Jetway HBJC231C63P-330D-B

This is the last step to getting my HTPC running how I want it!
Use this thread to post questions, this one needs to be closed.

edit :
could we use this thread in the futue ....


Also, you need to right click on the SAK and go to add on settings. That is where you setup the ssh login and other stuff. All plugins have that option, jsut some of them do not need a addon set up, SAK does.

From the command line in a terminal enter ssh [email protected] and if it does not ask for a password and opens another session, then that is what you put in the add on settings within SAK (type exit to end session). Otherwise you need to rm .ssh from your home directory then start from scratch with setting up ssh no passwd user login. Good luck.
I had a "fun" time getting this to work on gentoo . . . haha. One thing I'd suggest is using sshpass or some other authentication . . . basically I changed line 411 of resources/lib/Linux.py to this:
commandexec = "sshpass -p 'whywouldigiveawaymypassword' ssh " + __configLinux__[6] + " " + __configLinux__[40] + command + " "

And it seems to work so far, or at least doesn't crash XBMC as soon as I try to start it.

For those running Gentoo, the multimedia overlay (read: layman) has ebuilds for both makemkv and handbrake, which makes the process a little easier Smile.
Thread Rating:
  • 1 Vote(s) - 5 Average

Logout Mark Read Team Forum Stats Members Help
[RELEASE] Swiss-Army-Knife Addon - Blu-ray and DVD-Video Ripper and Transcoder51