•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 11
  •   
[MOD] Custom Home Items the easy way
#61
stevieray Wrote:This looks like a great mod, but I am running into an issue. I can create a Custom Favorite and give it a name... and it appears on my home screen, but I cannot "set favorite"... it gives me the message "Can not find favourites.xml".

Here's what I did... please feel free to point to my error(s):

I unzipped Homemod and saw three folders: 720p, media, and scripts. I opened the 720p folder, copied those files to C:/Program Files(x86)/XBMC/addons/skin.confluence/720p... then I opened the media folder and copied the "backgrounds" file and put it into the pre-existing media folder where it sits with the Textures.xbt folder... and then I copied the whole scripts folder into the skins.confluence folder since there wasn't a pre-existing scripts folder already there.

I assume I put the script.favourites folder in the wrong place -- I thought it should be C:/ Pro. Files/XBMC/addons/skin.confluence/scripts/scripts.favourite?
Huh

Oops... forgot to mention: Windows 7 x64, XBMC version 10 Dharma



I am having the same problem, I have a favorite but when I try to set it it says it cannot find the .xml. Is the above a solution? If so I dont really understand it, if not whats the solution to this?
Reply
#62
I'm not having a problem under Windows (Win 7 x64 ult). The favourites.xml is located at C:\Users\[your logon name]\AppData\Roaming\XBMC\userdata.

I use this addon to put Mythbox on my main menu. The steps I took:
Installed Mythbox add-on.
In TV Shows (file mode) go to video-addons and right click on mythbox setting it as a favorite.
In the custom home menu item setup I then added a name and selected the mythbox favorite.

This doesn't work under XBMCLive as the mythbox favorite doesn't appear when I go to select a favorite. I was able to get around this, but it required booting the live box in recovery mode (press shift(?) during boot) , then SSH'ing in and manually editing the guisettings.xml file.
Reply
#63
I had the 'can't find favorites.xml' problem (on Openelec RC1) - I solved it by copying the 'script.favorites' folder from .xbmc/addons/ to .xbmc/addons/script.confluenceMOD/scripts/

I think this mod uses an old school reference to the favourites script - it's not supposed to be under the skin folder anymore. But popping in a copy of the current script from the main addons dir into the skin/scripts/ seems to make it work
Sorry, no help w/out a *full debug log*
Reply
#64
I also found that setting custom favourites in the GUI only appeared to work...after a little time, the backgrounds would disappear. Very odd, it seemed to be some sort of disconnect to the cached thumbnails. I think it (like the problem I talked about above) - is to do with the way the images are referenced (special://masterprofile/ etc)...I think they need an xbmc.translatepath in there somewhere but I am just guessing. I solved it by simply hard coding the image filensames in home.xml (special://skin/backgorunds/whatever.jpg).
Sorry, no help w/out a *full debug log*
Reply
#65
bossanova808 Wrote:I had the 'can't find favorites.xml' problem (on Openelec RC1) - I solved it by copying the 'script.favorites' folder from .xbmc/addons/ to .xbmc/addons/script.confluenceMOD/scripts/

I think this mod uses an old school reference to the favourites script - it's not supposed to be under the skin folder anymore. But popping in a copy of the current script from the main addons dir into the skin/scripts/ seems to make it work

Any idea where these folders are on the atv2 build?
Reply
#66
elduende Wrote:hi tried to use your mod and is not working (trying in english but no easy being a spanish guy living in France)

more details

using xbmc pre 10.5 r28256
using it in portable mode because testing some features and like this being able to have the DB at a glance (not sure is the best way)
have 2 profiles (master user and kids) because was the way i ve founded for having kids films separately

i have copy your files even create the addon folder djtoll talk about but nothing happens when launching in portable mode but if i run it normally (surely my DB is empty and also all the parameters (profiles, meteo, spanish, etc...) but then i see your custom home

any ideas?

is it the portable mode? or the profile option?

thx in advance

Forgot i have already post this...
and thx for your answer...

At that moment i choose to have two portable xbmc

Now with Dharma same thing and i am sure is the profile stuff.
When no profiles are made i have the menu options in the skin tab but whe i create a profile i lost the mod menus...

Any ideaHuh?
Reply
#67
westcoastbias Wrote:Any idea where these folders are on the atv2 build?

I Had same problem on atv2, the problem is in the default.py file located in the script.favourites folder

Edit the default.py file.. change:

(on line 25)
'special://masterprofile//favourites.xml'

to
'/private/var/mobile/Library/Preferences/XBMC/userdata/favourites.xml

I used notepad++ to edit the file
Reply
#68
This mod works under 10.1 Windows and Live, though I still have the favourites problem. Sad
Reply
#69
This is a big improvement on the out-of-the-box confluence skin.

I realise it is always easier to be critical than to get up and do something - but the custom menus are much slower than the standard menus. Is there anything can be don to have them work as quickly as (say) 'Pictures' and 'Music'.

Also, it would be great to be able to change each of the background pictures for teh customer menus. I assume this is easy to do in the xml.

Otherwise, I think its great . . .

- M
Reply
#70
You can change the backgrounds in the same location you change them for the stock menu items.
Reply
#71
davenyc71 Wrote:I Had same problem on atv2, the problem is in the default.py file located in the script.favourites folder

Edit the default.py file.. change:

(on line 25)
'special://masterprofile//favourites.xml'

to
'/private/var/mobile/Library/Preferences/XBMC/userdata/favourites.xml

I used notepad++ to edit the file

Awesome, this was the fix I was looking for.
Reply
#72
Dont know where the problems some people are posting are coming from, not counting ATV problems as I cant test those. Just did a fresh install of XBMC and installed this MOD, everything went smoothly and everything works as expected...
Image

Check out The Carmichael - A Skin For XBMC

Check out Night - A Skin For XBMC

Check out Unfinished - A Skin For XBMC
Reply
#73
Did you install on Windows or Live?
Reply
#74
This may be a stupid question, or I may not have something configured correctly... but how can I set a custom home screen option for a Program?

I am using Advanced Launcher to launch Boxee, and wanted to have one home menu item to launch it, rather than having to go through the Programs -> Advanced Launcher -> Boxee. Less clicks makes the WAF much better. Thanks for any help.
Reply
#75
NickSoapdish Wrote:This may be a stupid question, or I may not have something configured correctly... but how can I set a custom home screen option for a Program?

I am using Advanced Launcher to launch Boxee, and wanted to have one home menu item to launch it, rather than having to go through the Programs -> Advanced Launcher -> Boxee. Less clicks makes the WAF much better. Thanks for any help.
Add program add-on as custom home menu is not actually working with the stable version of XBMC. You need to install the GIT version of XBMC to be able to add them.
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 11
  •   
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[MOD] Custom Home Items the easy way51