Thread Rating:
  • 0 Vote(s) - 0 Average
Chinavision CVSB-983 IR Remote which Lirc Drivers

ok so I have a Chinavasion CVSB-983 remote it was cheap and I bought it. I plugged it into Ubuntu and it worked the mouse worked, but many of the other buttons do NOT work.

I was able to use this link here >>> Chinavasion CVSB-983 on Logitech forums <<< and get my Monster Cable Avl-300s remote to send the same signals as the remote is sending so now my Monster remote is working via RF Wink but like I said not all the buttons work.

I am not sure what profile the Chinavasion remote is using, but its being sold all over the net, ,,

Dealextreme has the same remote listed twice has it twice


is it possibly to keymap using the hexcode provided in the logitech link or anything I am not thinking of?

This IR receiver identifies it self as an mouse and keyboard.

To make it work in XBMC I guess you have to find out witch keys the OS is receiving when you press the different buttons on the remote.

The command "showkey" in console or "xev" in X might help you.
ok so I have been in contact with the Lirc webguy and he has instructed me on what to do.

I have the hexcode for each button but I need to convert it into lircd.conf file see this link here:
See this bit here:
Quote:[INDENT]To use the program you must have python installed and give it an input file with codes:

> pronto2lirc inputfile
If inputfile is not given a generic usage information for printo2lirc will be shown.

anyone willing to run this through pronto2lirc to generate my lircd.conf file?


I've got the same remote label'd as "PC Remote" Device ID in lsusb is

Bus 002 Device 005: ID 04b4:0100 Cypress Semiconductor Corp.

Most of the keys work with XBMCLive Dharma out of the box - but could use some improvement.

Since these are very popular on Ebay and the China sites - has anyone made a keymap file that makes better use of the buttons ?

I have this remote, or at least a very similar one.

I've spent the afternoon debugging and finding which keys that don't work do what.

I've managed to change one of the keys, with a pic of a folder on and 7pqrs above which previously generated a Notification - MCEKeypress RecordTV 3 (I'm running XBMC Dharma 10)

With a lot of messing around, I created a keyboard.xml file (located: \Users\username\AppData\Roaming\XBMC\userdata\keymaps)

and added the following command:
<key id="127055">ContextMenu</key>

It now opens the Context Menu allowing me to bring up the menu to access movie or tv show info Big Grin Whereas before, I had to use the mouse which on my current Aeon skin is disabled!

I'm going to do some more tweaking tonight so see if I can get the top coloured buttons working too, but they are sending APPCOMMAND at the moment so it isn't looking good.

Anyone aware of how to use the APPCOMMAND function within XBMC?


Has anyone been able to put the Power button to work on XBMC Live 10? I can put all other buttons to work and catch them in XBMC (without using lirc), but not the Power button. However, I know it works because if I put the system to sleep (a Zotac ION) with any other button, I'm able to wake the system up with the Power button!
It seems the system is completely ignoring this button when running...
Any idea?

on my remote the Power Button needs a longer keypress and then it generates:

DEBUG: SDLKeyboard: scancode: 124, sym: 0, unicode: 0, modifier: 0

wheras for example on the Pause/Play Button I get:

DEBUG: SDLKeyboard: scancode: 172, sym: 0, unicode: 0, modifier: 0
DEBUG: OnKey: 61619 pressed, action is Pause

so that one I can use in the keyboard.xml with a key id='61619' statement

Does anyone know how to map a key where I only get the scancode displayed?

the instructions in the Wiki to just use showkey doesnt work in Live for me - the showkey command there only shows the scancode as well

I finally got it working (including the power buttons). I have the same remote as RAL67 (lsub returns Bus 002 Device 005: ID 04b4:0100 Cypress Semiconductor Corp.). The top button colors and assignments are slightly different than the one in the first message of this thread:


The issue is a bug in XBMC that does not handle correctly the keyboard power events (the remote emulates a keyboard and a mouse).

The problem is the same as here:

And more specifically: (Thanks to hb76)

In summary to resolve, you need to:

1 - Be prepared to compile XBMC
2 - Change the code to hardcode the keyboard assignments
3 - Recompile
4 - Insert the proper key ids in keyboard.xml

In more details:

1 - Building XBMC can be complex depending of your distro and which version of XBMC you want to compile. I was only able to compile it using this procedure:

Unfortunatly, you will end up with the latest unstable version of XBMC. If anyone has a procedure to build XBMC Dharma 10.0 on Ubuntu since it was moved to GIT, please let me know.

2 - The change to the code is straight forward. Search for KeyboardStat.cpp in the directory where you downloaded the source. You will need to add the 2 lines indicated by a + sign (don't leave the plus signs!)

static bool LookupKeyMapping(BYTE* VKey, char* Ascii, WCHAR* Unicode, int source, XBMC_KeyMapping* map, int count)
  for(int i = 0; i < count; i++)
    if(source == map[i].source)
        *VKey    = map[i].VKey;
        *Ascii   = map[i].Ascii;
        *Unicode = map[i].Unicode;
      return true;
+  if((source == 150) || (source == 124))
  return false;

3 - Recompile. If you succeeded in step 1, this should be easy enough...

4 - Copy /usr/share/xbmc/system/keymaps/keyboard.xml to $HOME/.xbmc/userdata/keymaps

Add the following keys to the global section:

<key id="61504">ActivateWindow(shutdownmenu)</key> <!-- Power button to Displays the shutdown menu with options -->
<key id="61599">XBMC.Suspend()</key> <!-- Stanby button Directly puts computer to standby -->

You can also customize the other keys. If you want to know what key id to use, simply start XBMC, press the key and exit. In $HOME/.xbmc/temp/xbmc.log, you will find the values like this:

DEBUG: SDLKeyboard: scancode: xxx, sym: 0, unicode: 0, modifier: 0
DEBUG: OnKey: yyyyy pressed, action is ...

On Dharma latest unstable, the values were in Hexadecimal. You can use the Ubuntu calculator to convert them to Decimal. I have personnally added these other keys:

<key id="127055">ContextMenu</key> <!-- Key with a picture of a folder on and 7pqrs above which previously generated a Notification - MCEKeypress RecordTV -->
<key id="323593">CodecInfo</key> <!-- Key with a picture of Windows on and 0 above -->
<key id="61952">Info</key> <!-- Key with a picture of a monitor on and Desktop above -->
<key id="61624">OSD</key> <!-- Key with a picture of a monitor on and Mypc above -->
<key id="61536">ShowSubtitles</key> <!-- numlock key + key with a picture of Windows on and 0 above -->

That's it! The skip keys behave a bit strangely and some key send two events (for instance, if I press Info I also gets the CodecInfo) but this is pretty much usable.

Is there any other way to make that Power and Suspend buttons to work other than recompile from source? I'm running Openelec 0.99.3 (RC3) Generic and I would not like get familiar with compiling from sources...

My remote is that ID 04b4:0100 - the same as RAL67 and jrbastien has.

Another nice bonus would be to have clean hex codes of those remote buttons to put them in Philips Pronto remote.

I also have this remote and I would like to know if it is possible to fix this issue without recompiling XBMC...
Spulit and MIXAL, please go to the bug tracking system and report that this problem affects you too. This might help getting some attention.
jrbastien Wrote:Spulit and MIXAL, please go to the bug tracking system and report that this problem affects you too. This might help getting some attention.

Yep, we both did that.

I tried to overcome this problem by getting HP MCE remote, but it brought me more problems. It powers up both Xbox and XBOX360 when Windows button or power button is pressed. So back to this chinavision like remote wishing fix for its problem.
What bugs me out is the fact that I also cannot get the remote power button to work when XBMC is not running, ie, when I'm running X with a window manager (fluxbox)...
I personally use Ubuntu and its default windows manager (GDM) and the power button of this remote works fine with it. My problem is only when XBMC runs on top of it.
I had the chance to test this hack by recompiling XBMC in an OpenELEC distribution. Unfortunately, it didn't work... Sad
I have the same model as the one referred at the beginning of this thread.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
Chinavision CVSB-983 IR Remote which Lirc Drivers00