Can't connect PC to Apple tv XBMC

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
bigdfromnc Offline
Junior Member
Posts: 1
Joined: Jul 2010
Reputation: 0
Exclamation  Can't connect PC to Apple tv XBMC
Post: #1
My roomate's desktop computer is running windows Vista and it appears under the network as SMB and UPnP.

My crappy dell inspiron laptop running windows XP Pro SP2 appears under SMB.

My Desktop running Windows XP Pro SP3 (which has my terabyte hd full of media) does not appear. However when XBMC is running on the atv, the XBMC remote control show up in "my network places" on my desktop computer.

How do i get XBMC to recognize that my desktop computer is there so that i can stream all of my media to it.

I am having the exact same problem with Boxee so it has to be a setting or something i am missing.

Help would be appreciated. I have been screwing around with this forever.
find quote
xbmc old school Offline
Senior Member
Posts: 128
Joined: Apr 2010
Reputation: 0
Location: British Columbia
Post: #2
Two things i can think of are;

1) When you set up your network it should be a workgroup not a homegroup.

2) In the "advanced sharing settings" you have to turn off "password protected sharing"

To add security to open shares, I MAC filter everything out of my router.

If that doesn't, work dump vista.
find quote
JDizzy Offline
Posts: 390
Joined: Apr 2009
Reputation: 2
Location: Californication
Post: #3
Not knowing where things quit working:

Did you add your laptop as a source in XBMC?

Go to movies (or whatever media it is that is on your laptop), and in File Mode, choose Add Source...
Hopefully your laptop folders (or whatever you have shared) will show up when you Browse. If so, then you can add it. If nothing shows then you need to work your way back and find out why it isn't showing up, or try to add it manually like below.
Then you just define what it is that is in the folder, and scan it into your library...or at this point, it should show up in file mode...

When I add a source, I do it manually like:
smb://username:[email protected]:21/MyComputers/Action/

Of course, you would change that line with your username, password, IP address of your laptop, and directory path where your media is.
find quote
Sam.Nazarko Offline
Posting Freak
Posts: 1,119
Joined: Dec 2009
Reputation: 43
Location: London
Post: #4
xbmc old school Wrote:Two things i can think of are;

To add security to open shares, I MAC filter everything out of my router.

Restricting access to your network by MAC is futile. If this is the only protection you use this is very poor. Using Wireshark one could easily see the destination MAC address of the devices on your network and easily spoof one of these addresses, rendering your access control list useless.
find quote