Mangled settings
#1
EDIT: Ok, after a couple of restarts it has dissapeared, so just the question in bold remains. Maybe the beeping was caused by another program.

Apparently one of my most adventurous users has managed alter the settings through random remote manipulation Rolleyes
Now XBMC is playing a constant alert beep and navigation is almost impossible, the debug log contains lines like these:
Quote:15:32:50 T:2420 M:1661247488 NOTICE: load default skin:[Transparency!]
15:32:50 T:2420 M:1644711936 ERROR: Error evaluating boolean expression Container(5040).HasFocus(5) + [PVR.IsRecording | PVR.HasTimer] + !Player.HasMedia
15:32:50 T:2420 M:1644675072 ERROR: Error evaluating boolean expression !PVR.IsRecording + PVR.HasTimer
15:32:52 T:2420 M:1651089408 NOTICE: CApplication::UpdateLibraries - Starting video library startup scan
15:32:52 T:2420 M:1651122176 NOTICE: initialize done
15:32:52 T:2420 M:1651122176 NOTICE: Running the application...
15:32:52 T:2420 M:1651068928 NOTICE: ES: Starting event server
15:32:52 T:3748 M:1651052544 NOTICE: ES: Starting UDP Event server on 127.0.0.1:9777
15:32:52 T:3748 M:1651036160 NOTICE: UDP: Listening on port 9777
15:32:53 T:3776 M:1641701376 NOTICE: -->Python Interpreter Initialized<--
15:32:57 T:2420 M:1625612288 ERROR: Window Translator: Can't find window tv
15:32:57 T:2420 M:1625600000 ERROR: Error evaluating boolean expression Window.IsVisible(TV) + Control.IsVisible(10)
15:32:57 T:2420 M:1624977408 ERROR: Window Translator: Can't find window tv
15:32:57 T:2420 M:1624977408 ERROR: Error evaluating boolean expression Window.IsVisible(TV) +

I tried to enter Settings | TV but nothing happens, it looks like PVR/TV has been activated somewhere :confused2:

One more thing, without complicating the install with the use of profiles, if I disable the "Settings" item in the menu is there a easy alternative to get it back in the occasions I may actually need to change the settings.

Thanks.
XBMC on Win 7 Professional (32 bit)
Intel E7300
Gigabyte GA-E7AUM-DS2H board
Nvidia 9400 chipset
4GB RAM
Pioneer 436 XDE Plasma TV
Yamaha YSP-1000 Digital Sound Projector
Reply
#2
adsoto Wrote:One more thing, without complicating the install with the use of profiles, if I disable the "Settings" item in the menu is there a easy alternative to get it back in the occasions I may actually need to change the settings.

you can:
a. add it as an item to the shutdown menu
b. map a button on your keyboard/remote to enter the settings screen:
ActivateWindow(Settings)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#3
Both are excellent suggestions , I think the least amount of user interference would happen with the "Settings" absent from the normal menu and the remote. So I will add it to the Shutdown menu.
XBMC on Win 7 Professional (32 bit)
Intel E7300
Gigabyte GA-E7AUM-DS2H board
Nvidia 9400 chipset
4GB RAM
Pioneer 436 XDE Plasma TV
Yamaha YSP-1000 Digital Sound Projector
Reply



Logout Mark Read Team Forum Stats Members Help
Mangled settings0
This forum uses Lukasz Tkacz MyBB addons.