[request]To add in addons-api a possibility to spoof HTTP headers (user-agent,...)
#16
seppius Wrote:I have not found a solution. It looks like the developers do not care about us.

Haha thats a bit harsh buddy, XBMC is an open source project your welcome to go ahead and find the bug.

The problem is in the libmms library which is pulled from the system librarys on linux/mac osx, and compiled in on Windows.

That mms/mmsh does not support the |Referer, simple as that. No need to bash the developers their doing an amazing job, a bit of poking around in the code can go a long way.

It's not really a bug just a lacking feature, libmms is a open source library but it does not allow you to pipe in your own Referrer URL you can always submit a patch to them and then a patch to XBMC to do what you require.

I talked to spiff on IRC and he did mention that XBMC might drop libmms since ffmpeg now has decent support for mms/mmsh but again I think most devs are busy with Dharma, and syncing ffmpeg to the latest always brings about problems.

So instead of bashing the developers and expecting them to spoon feed you step up and do a bit of research took me less than 15 minutes to figure out the culprit was libmms.
Reply
#17
This is not about mms protocol, the protocol http.
The music player is not able to change the headlines.
Video player can do it.
Reply
#18
seppius Wrote:This is not about mms protocol, the protocol http.
The music player is not able to change the headlines.
Video player can do it.

yes...but a lot of sites do MMS through HTTP so it would probably still be going through libmms, actually IT is going through libmms

"User-Agent: NSPlayer/4.1.0.3856" --- Means its using libmms most likely.

Maybe your video is doing something else because I have video streams that don't work because of the same problem HTTP is just a transport method you can encapsulate whatever you want in there. In your audio stream situation it looks like their doing mms over http. In your HTTP situation maybe its something else. Maybe its just an AVI or something.
Reply
#19
@johoja

have a look please
http://forum.xbmc.org/showpost.php?p=599...stcount=38
Nvidia Shield
kodi 18.1 RC1
Reply
#20
johoja Wrote:4
I talked to spiff on IRC and he did mention that XBMC might drop libmms since ffmpeg now has decent support for mms/mmsh but again I think most devs are busy with Dharma, and syncing ffmpeg to the latest always brings about problems.

when have you discussed about it ? (I would like to read your discussions in archive irc list )

and can help compilation of xbmc with --external-ffmpeg flag to solve any mms issues ?
Nvidia Shield
kodi 18.1 RC1
Reply
#21
Oh boy. I found this AFTER I wrote this proxy script: http://forum.xbmc.org/showthread.php?tid=95369 Sad Better research next time.
Reply
#22
There seems to be a small bug with this. If I try to supply a cookie like this:
Cookie: enc=foobar, the = sign is replaced by ": ". No method for escaping the "=" character seems to work.
Edit: Never mind, I'm an idiot. I used ":" characters for separating key and value. It has to be the "=" character.
Reply
#23
could you spoof the user-agent for "http audio" (non video) streams ?
Nvidia Shield
kodi 18.1 RC1
Reply
#24
I can't get it work with XBMC FRODO, many changes about? Can't play any encoded .m3u8 videos from akamaihd.net : http://api.radio-canada.ca/validationMed...uv5zRjGWF0

All these work on my Samsung Smart TV with crypt key and cookies! ffmpeg does'nt work properly on XBMC?

Please help me!
Reply
#25
(2010-07-20, 08:10)Goga777 Wrote: For better work with Internet streams please add in addons-api the posibility to change (spoof) http-headers for internal player of xbmc. I mean the following

- the possibility to change (to spoof) the existing User-Agent - "XBMC/PRE-10.5 r31655 (Linux; openSUSE 11.3 (i586); 2.6.34-12-desktop i686; http://www.xbmc.org)" to another
With it some servers report to xbmc as "HTTP/1.1 403 Bite my shiny metal ass!"

- to handle the cookes
- to handle the Rederer

You can have a look on existing situation when the Internet server refused to the connection with xbmx - HTTP/1.1 403 Bite my shiny metal ass!
Image
I have the following line of code which builds a video url and is expected to play it:

headers = { 'User-Agent': 'Mozilla/5.0 (Windows NT 6.1; rv:27.3) Gecko/20130101 Firefox/27.3' }
vidUrl = "{}/getvid?evid={}|User-Agent={}&Content-Type=video/mp4\".format(response['server'], response['hd'], urllib.quote_plus(headers['User-Agent'])).strip()
item = xbmcgui.ListItem()
item.setPath(vidUrl)
xbmcplugin.setResolvedUrl(int(sys.argv[1]), True, item)


unfortunately I am unable to make this pipeline thing work Sad

all am trying to do is pass a custome Header User Agent and Content-Type.

Can someone please help me, I want to know how I can pass a custom User-Agent and Content-Type header to the Kodi Video player, as currently it returns the following error:

"CCurlFile::Open failed with code 404"
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[request]To add in addons-api a possibility to spoof HTTP headers (user-agent,...)00