Solved - Auto-Repeat of Videos
#1
Hi All,

I finally worked out why my videos would auto-repeat in XBMC. This has been frustrating me for a good year Smile

I was so happy to work it out, I wrote a blog post Smile

http://todayguesswhat.blogspot.com/2010/...os-in.html

Here are the steps to prevent auto-repeat

Navigate to a movie/tv episode etc

Hold down menu button until popup menu appears

from popup menu, choose "Queue item"

hold down menu button once more until popup menu re-appears

from popup menu, choose "Now playing ..."

"NOW PLAYING - VIDEOS" screen should appear

press Previous/Rewind button, and a side-menu on left-hand side should appear

Check the value for the REPEAT option. If it is set to REPEAT:ALL, movie will play over and over.


I can now turn my TV off without explicitly stopping the movie, yay!
Reply
#2
Thanks for the tip. I nearly reinstalled everything before seeing your post! Cheers! Laugh
Reply
#3
Thanks! Two years later and it still helped Smile
Reply
#4
Excellent, this started today on my box, after an hour of looking through all my settings I found this post, solved the problem in seconds. Thanks.
Reply
#5
I have this problem in 12.0 Frodo. Videos keep repeating after playing. I followed the instructions here, and set it to Repeat:Off, and it works temporarily, but after a while it automatically reverts back to Repeat:All no matter what I do.

I noticed that in guisettings.xml in the userdata folder, there's a setting that looks like this:

<settings>
<myvideos>
<playlist>
<repeat>false</repeat>

But in the gui, the options for playlist repeat aren't True/False, they are All/One/Off. So I changed <repeat>false</repeat> to <repeat>off</repeat> in the guisettings.xml file, and lo and behold, it worked. All videos were set to Repeat:Off by default.

Then after a quit and restart, the problem came back. XMBC had reverted guisettings.xml back to <repeat>false</repeat>. Could it be that XBMC no longer knows what 'false' means for that setting, and defaults to All?

Any suggestions for how to fix this (without making guisettings.xml read-only)? Is this a legitimate bug?
Reply
#6
Dare, are you using tvtunes? If so, try disabling play theme in loop. That setting was causing me the same problem with video repeat sometimes getting enabled.
Reply
#7
for some time now, my tv show video's have also been stuck on auto-repeat.

Meaning when a show ends, it immediately restarts the same show with no pause or interruption.

I am not sure for how or why they started doing it.

I had checked all the menu's I can find and have been unable to disable this auto repeating mechanism.

I don't believe it is platform specific, but FWIW this is on ATV2 4.x with frodo 12.2 stable, I found this thread via google, the xbmc form search did not show many any usable results.

I will check the stuff mentioned in the previous posts, hopefully that fixes it.
Reply
#8
I'm having the same issue and this was the first google result. Has anyone had any luck fixing this? Frodo 12.2 windows 7.

Saw this other post with similar instructions to the above... http://forum.xbmc.org/showthread.php?tid=140844 going to try that a bit later.
Reply
#9
No luck. Only option in the left side menu was shuffle. Nothing about repeat.
Reply
#10
(2013-12-10, 19:07)jeffsawyer Wrote: No luck. Only option in the left side menu was shuffle. Nothing about repeat.

http://forum.xbmc.org/showthread.php?tid...pid1194827
Reply
#11
Had this issue today, my cure with your guidelines was to play a video. While it's playing, press c on the keyboard (or evoke the context menu). The activate the sidebar menu and select REPEAT and set it to OFF.

This is with ISENGARD running the MIMIC skin.

http://i.imgur.com/2FoQUyg.png
Reply
#12
Google dug me up this topic :

Since a few days (and I didn't change or updated anything particularly), I have this autoreplay issue. Same as described here.

I can turn it off using Yatse for example during play, or by editing guisettings.xml and turning
Quote:<settings>
<myvideos>
<playlist>
<repeat>false</repeat>

But, after a few times, it re-activates mysteriously. I need to tackle the root-cause, but I have no idea what's turning this option to true again...

Any leads ?

EDIT : I have an idea : i will copy paste the a.m. setting to advancedsettings.xml, which should override the parameter, and hopefully stay in that state. To be continued...

EDIT 2 : It seems to have fixed it ! Thanks me ! Smile

EDIT 3 : It came back Sad wtf ?!! I really have to understand what re-enables this option.
Reply
#13
(2017-03-24, 13:36)flochy Wrote: Google dug me up this topic :

Since a few days (and I didn't change or updated anything particularly), I have this autoreplay issue. Same as described here.

I can turn it off using Yatse for example during play, or by editing guisettings.xml and turning
Quote:<settings>
<myvideos>
<playlist>
<repeat>false</repeat>

But, after a few times, it re-activates mysteriously. I need to tackle the root-cause, but I have no idea what's turning this option to true again...

Any leads ?

EDIT : I have an idea : i will copy paste the a.m. setting to advancedsettings.xml, which should override the parameter, and hopefully stay in that state. To be continued...

EDIT 2 : It seems to have fixed it ! Thanks me ! Smile

EDIT 3 : It came back Sad wtf ?!! I really have to understand what re-enables this option.

I have the same Problem...
Do you use the VideoScreensaver Addon?
Reply
#14
I'm using Aerial (ATV4 Screensavers) screensaver, and I think it's because of it.
http://forum.kodi.tv/showthread.php?tid=246655

I have to investigate and find a fix, if possible other than uninstall it.
Reply
#15
(2010-07-20, 16:27)herod98 Wrote: Hi All,

I finally worked out why my videos would auto-repeat in XBMC. This has been frustrating me for a good year Smile

I was so happy to work it out, I wrote a blog post Smile

http://todayguesswhat.blogspot.com/2010/...os-in.html

Here are the steps to prevent auto-repeat

Navigate to a movie/tv episode etc

Hold down menu button until popup menu appears

from popup menu, choose "Queue item"

hold down menu button once more until popup menu re-appears

from popup menu, choose "Now playing ..."

"NOW PLAYING - VIDEOS" screen should appear

press Previous/Rewind button, and a side-menu on left-hand side should appear

Check the value for the REPEAT option. If it is set to REPEAT:ALL, movie will play over and over.


I can now turn my TV off without explicitly stopping the movie, yay!

I tried this but when i got to the step of now playing it wasn't an option to click.
Reply



Logout Mark Read Team Forum Stats Members Help
Solved - Auto-Repeat of Videos1
This forum uses Lukasz Tkacz MyBB addons.