Stereo Being Upmixed to 5.1
#1
Hi, I have used tv show and movie library features of xbmc for a while and am very happy with it. Just moving into the music playing end of it now and notice xbmc upmixes all of my stereo music to 5.1 (as I have 5.1 channels selected in system settings)...

Is this by design? Shouldn't it play back audio at the original format unless an option is set to upmix? Maybe there is such an option that I can't find?

Can anyone shed light on this for me?
Reply
#2
I haven't researched this topic very heavily, but thanks for bringing it up.

Ideally, I'd like my movies as 5.1 (or stereo for the very few non-HD rips I have) and my mp3's and flac to play as stereo, regardless of what I have picked in system settings.

I guess that's the long way of saying what you did: playback audio in the original format...

NS
Image
Reply
#3
XBMC doesnt upmix to 5.1.. It will play your material as 2.0 however, the remaining channels are empty.. So your receiver reports that its receiving a 5.1 PCM signal, but in fact its not..
Reply
#4
Well have my xonar set to leave the original audio as is. So xbmc is upsampling to 5.1. It sounds horrible. Other apps I have set to 5.1 can output stereo without doing this. Xbmc is the odd one out sadly.
Reply
#5
It's a known issue with the Xonar drivers : they upmix to 5.1 when using wasapi.
Reply
#6
Yes I had that in the past but with the latest directs runtimes mine no longer does. Outputting stereo from mpc through reclock with wasapi gives no upmixing so not the drivers in this case I think.
Reply
#7
Dullie Wrote:XBMC doesnt upmix to 5.1.. It will play your material as 2.0 however, the remaining channels are empty.. So your receiver reports that its receiving a 5.1 PCM signal, but in fact its not..

Really? It's quite obvious that I have vocals coming from my center channel, then I switch my receiver to stereo only, and then the center channel plays no sound.

Maybe upmix is the wrong term, but there's definitely some non-stereo stuff going on.

NS
Image
Reply
#8
Well it seems to be something that others seem to be able to reproduce. Do you think its worth a trac ticket.
Reply
#9
mark007 Wrote:Well it seems to be something that others seem to be able to reproduce. Do you think its worth a trac ticket.

Gotta go to work now, but I'll help later if necessary (I've never submitted a trac ticket, so I'd have to figure out how).
Image
Reply
#10
NotShorty Wrote:Really? It's quite obvious that I have vocals coming from my center channel, then I switch my receiver to stereo only, and then the center channel plays no sound.

Maybe upmix is the wrong term, but there's definitely some non-stereo stuff going on.

NS

Yes, really.. Wink

Well obviously I dont have the same hardware as you do.. But I thought it was the same with me.. Cause I have empty channels on my system.. But if I play stereo it comes out stereo (Center, Surround Left and Right are empty).. BTW the same happens with the PS3 when you select 5.1 or 7.1 from the audio menu, and you play stereo it outputs 5.1 with empty channels.

The pain in this issue is that you cannot apply a DSP. My AVR refuses to apply Dolby Pro Logic II 5.1 since the signal is 5.1 but it is 2.0!
Reply
#11
(2010-08-15, 12:07)Mr_Zebra Wrote: It's a known issue with the Xonar drivers : they upmix to 5.1 when using wasapi.

I have Xonar DX with analog 4.0 speakers playing through wasapi on Win7 x64. I can confirm, that i get stereo upmix in xbmc and foobar via wasapi, but not in Winamp (probably different output plugin). In directsound mode, there is no stereo upmixing. It is strange, because I also use 1.52 Unixonar drivers with upmix disabled, and my source in drivers is set to 6 channel and output to 4.0, - so no upmixing should occur.

I guess, Mr_Zebra is right, it is c-media driver related. Even though I like upmixing (I will check if it's really 2.0 -> 4.0), It is pity, that there is no user control over that.
Reply



Logout Mark Read Team Forum Stats Members Help
Stereo Being Upmixed to 5.10
This forum uses Lukasz Tkacz MyBB addons.