Thread Rating:
  • 0 Vote(s) - 0 Average
CApplication::Create() failed REMOTE DESKTOP
#1
Not sure were to post this, but I’m trying to connect from one computer to another with windows remote desktop. I did that no problem but when I run XBMC 9.11 it crashes with this error.

CApplication::Create() failed - check log file and that it is writable
I check the log and this is what is in there.
:12:27 T:3956 M:2936352768 NOTICE: -----------------------------------------------------------------------
22:12:27 T:3956 M:2936360960 NOTICE: Setup SDL
22:12:27 T:3956 M:2936180736 NOTICE: Found screen: Dummy Monitor on RDPDD Chained DD, adapter 0.
22:12:27 T:3956 M:2936180736 NOTICE: Primary mode: 1680x1050 @ 60.00 - Full Screen
22:12:27 T:3956 M:2936201216 NOTICE: Additional mode: 1680x1050 @ 60.00 - Full Screen
22:12:27 T:3956 M:2936209408 NOTICE: load settings...
22:12:27 T:3956 M:2936180736 NOTICE: special://profile/ is mapped to: special://masterprofile/
22:12:27 T:3956 M:2936180736 NOTICE: loading special://masterprofile/guisettings.xml
22:12:27 T:3956 M:2936180736 ERROR: special://masterprofile/guisettings.xml, Line 0
Failed to open file
22:12:27 T:3956 M:2936180736 ERROR: Unable to load special://masterprofile/guisettings.xml, creating new special://masterprofile/guisettings.xml with default values
22:12:27 T:3956 M:2936180736 ERROR: XFILE::CFile:Big Grinelete - Error deleting file C:\Users\Computer\AppData\Roaming\XBMC\userdata\guisettings.xml
22:12:27 T:3956 M:2936180736 ERROR: XFILE::CFile:Big Grinelete - Error deleting file special://masterprofile/guisettings.xml
22:12:27 T:3956 M:2935623680 NOTICE: Getting hardware information now...
22:12:27 T:3956 M:2935623680 NOTICE: Checking resolution 12
22:12:27 T:3956 M:2935623680 NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
22:12:27 T:3956 M:2935615488 NOTICE: Loaded playercorefactory configuration
22:12:27 T:3956 M:2935615488 NOTICE: Loading player core factory settings from special://masterprofile/playercorefactory.xml.
22:12:27 T:3956 M:2935615488 NOTICE: special://masterprofile/playercorefactory.xml does not exist. Skipping.
22:12:27 T:3956 M:2935615488 NOTICE: No advancedsettings.xml to load (special://masterprofile/advancedsettings.xml)
22:12:27 T:3956 M:2935615488 NOTICE: Default DVD Player: dvdplayer
22:12:27 T:3956 M:2935615488 NOTICE: Default Video Player: dvdplayer
22:12:27 T:3956 M:2935615488 NOTICE: Default Audio Player: paplayer
22:12:27 T:3956 M:2935615488 NOTICE: Loading media sources from special://masterprofile/sources.xml
22:12:29 T:3956 M:2932101120 WARNING: CRenderSystemDX::CreateDevice - initial wanted device config failed
22:12:29 T:3956 M:2932854784 FATAL: CApplication::Create: Unable to init rendering system


I also tried this with the latest nightly build and the same thing. Version xbmc-r32773-Dharma, however I had it working with an earlier nightly release but can’t remember the version number, maybe 4 or 5 updates ago. Anyone have any ideas or is this beyond the scope of the project. Thanks anyways for any advice.
Reply
#2
Why exactly are you trying to run XBMC via Remote Desktop?
Reply
#3
directx don't pass throught remote desktop
Image
Passion-XBMC Repository Download your SVN skins and addons
TvTunes Addon Download Play your theme while browsing library
TVshow Next Aired display next aired infos from tvrage.com
Logo Downloader Script download Logo/clearart/show thumbs/poster/banner
Bande-Annonce Allociné plugin watch trailers in french and vo
SportLive Script Live score match info in XBMC (not compatible dharma)
Reply
#4
I had the same error when I was having video card driver problems that disabled DirectX. The previous poster is likely right about RD and DirectX
Desktop / Media Server: Win10 x64, ThermalTake Commander G42 case, Asus Maximus VII Hero, Intel Core i5 4460 3.20GHz, Gigabyte Geforce GTX750, CM M 1000w, 8GB GSkill, Samsung SSD 840 Pro 120GB, 2x WD Black 1TB RAID 1, WD 6TB + WD 4TB spanned, single 3TB

Intel NUC with Openelec in TV room.
Reply
#5
YodaEXE Wrote:Why exactly are you trying to run XBMC via Remote Desktop?

I have my main server in the living room, and sometimes i want to connect with the laptop remotely to do some changes from elsewere.
Reply
#6
Cash Wrote:I have my main server in the living room, and sometimes i want to connect with the laptop remotely to do some changes from elsewere.

I have the same issue. I posted a log here

I also want to connect through RDP for similar reasons (got my HTPC connected to a projector in the living room and I don't want to start up the projector just to make a small change in XBMC or to test something quickly). I'm running the latest beta (rev 33323) and I think two or three revisions prior to this XBMC worked fine through remote desktop, so I know it is possible.

Edit: It works if you load XBMC and then connect through RDP afterwards.
Reply
#7
I think I might have figured out how to work around it (or why it worked before).

I changed the video setting to "use fullscreen window rather than true fullscreen" and now it's working.

I'm not 100% that's what did it, but it's working now and that's the only recent change I can think of that could have fixed the issue.
Reply
#8
pedram Wrote:I think I might have figured out how to work around it (or why it worked before).

I changed the video setting to "use fullscreen window rather than true fullscreen" and now it's working.

I'm not 100% that's what did it, but it's working now and that's the only recent change I can think of that could have fixed the issue.

I can confirm that Pedram is correct. My RDP connection also failed to work after updating to Dharma. I changed to fullscreen window mode and now I am able to work in XBMC through RDP.

Thanks for the info Pedram!
Reply
#9
I usually use either RDP or UltraVNC and neither are working. I am getting the same error with RDP as above, but viewing in Full Screen doesn't fix it.
1 Original XBOX XBMC with every game under the sun
3 Raspberry Pi's w/ Openelec Kodi shared MySQL db
1 Win7 Kodi hosting shared MySQL and media
1 Mythbuntu backend v.27 and HD Homerun Prime 3 tuners
Image
Reply
#10
My personal experience that XBMC won't launch if an RDP concurrent session is open.

So, I have to log out of the concurrent session - and then launch XBMC.

Then log back into the RDP session.

If you're dependent on launching XBMC via RDP, then you might consider picking up a cheapo MCE remote and configuring the green button to launch XBMC.
Image
Image
Image
Reply
#11
jwdv22 Wrote:I usually use either RDP or UltraVNC and neither are working. I am getting the same error with RDP as above, but viewing in Full Screen doesn't fix it.

True, but they are not viewing it in full screen. They are viewing it in a fullscreen WINDOW...
Reply
#12
Go into Settings -> System -> Video Output and Make sure "Use a fullscreen windows rather than true fullscreen" is selected or checked.
1 Original XBOX XBMC with every game under the sun
3 Raspberry Pi's w/ Openelec Kodi shared MySQL db
1 Win7 Kodi hosting shared MySQL and media
1 Mythbuntu backend v.27 and HD Homerun Prime 3 tuners
Image
Reply
#13
@jwdv22, I know this is an old thread but I just wanted to let you know that your answer just helped me out and saved me from pulling out what is left of my hair. Many thanks!

Dennis
Reply
#14
Yes, this setting does indeed allow XBMC to run over RDP.

If, like me, your server does not have a keyboard / monitor, then you must change this setting by hand in the config file. If you look at %appdata%\XBMC\userdata\guisettings.xml, the important change to make is under the <videoscreen> element. The value of the <fakefullscreen> element must be set to true like so:

<videoscreen>
<blankdisplays>false</blankdisplays>
<fakefullscreen>true</fakefullscreen>
<guicalibration></guicalibration>
<resolution>0</resolution>
<screen>0</screen>
<screenmode>DESKTOP</screenmode>
<vsync>2</vsync>
</videoscreen>

Furthermore, if you intend to keep an instance of XBMC running on a file server (to receive notifications from SickBeard, CouchPotato, etc), which is the closest you'll get to headless XBMC, then it will likely be beneficial to you to run the UI in windowed mode and minimize it. This setting is under System Settings -> Video Output -> Display Mode (Windowed).

From what I can tell, the settings here that must be changed from above are:

<resolution>12</resolution>
<screen>-1</screen>
<screenmode>WINDOW</screenmode>
Reply
#15
Lightbulb 
(2010-09-07, 02:46)pedram Wrote: I think I might have figured out how to work around it (or why it worked before).

I changed the video setting to "use fullscreen window rather than true fullscreen" and now it's working.

I'm not 100% that's what did it, but it's working now and that's the only recent change I can think of that could have fixed the issue.

You guys who tested and posted are my saving :angels thx for your post I solved my problem

(2011-01-20, 16:01)jwdv22 Wrote: Go into Settings -> System -> Video Output and Make sure "Use a fullscreen windows rather than true fullscreen" is selected or checked.

You guys who tested and posted are my saving :angels thx for your post I solved my problem
Reply



CApplication::Create() failed REMOTE DESKTOP00