The TVDB scraper is currently broken due to upgrade works at TheTVDB site. We hope this issue will be resolved quickly.

  •   
  • 1
  • 123
  • 124
  • 125(current)
  • 126
  • 127
  • 315
  •   
  Thread Closed
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
CrazyCoder Wrote:2.9.0 version for pre-eden builds if you can't wait until repository is updated:
http://swnet.spb.ru/files/xbmc-addons.zip
(includes all the required dependencies, tested on Windows with XBMC Eden beta2 build).
Installed on Eden Beta 2, Win7 64. Just unzipped in Addons dir with overwrite existing.

Videos now stream play, but won't "download video". Popup just sits at "Preparing download".

errors from log:

Several instances of :

Code:
21:29:31 T:7728   ERROR: ADDON: extension 'downloader\' is not currently supported for service addon

Code:
21:31:01 T:4632  NOTICE: -->Python Interpreter Initialized<--
21:31:01 T:4632  NOTICE: YouTube-2.9.0
21:31:01 T:4632  NOTICE: CommonFunctions-0.9.1
21:31:01 T:4632   ERROR: ADDON: extension 'downloader\' is not currently supported for service addon
21:31:03 T:1248   ERROR: Previous line repeats 1 times.
21:31:03 T:1248   ERROR: C:\Users\West\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib\DialogDownloadProgress.py:136: DeprecationWarning: object.__init__() takes no parameters
                                              xbmcgui.WindowXMLDialog.__init__(self, *args, **kwargs)
21:31:03 T:7728   ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Users\West\AppData\Roaming\XBMC\addons\script.module.simple.downloader
21:31:04 T:1248   ERROR: Exception in thread Thread-1:
                                            Traceback (most recent call last):
                                              File "C:\Program Files (x86)\XBMC\system\python\Lib\threading.py", line 532, in __bootstrap_inner
                                                self.run()
                                              File "C:\Program Files (x86)\XBMC\system\python\Lib\threading.py", line 484, in run
                                                self.__target(*self.__args, **self.__kwargs)
                                              File "C:\Users\West\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib\SimpleDownloader.py", line 125, in _startDownload
                                                self._processQueue()
                                              File "C:\Users\West\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib\SimpleDownloader.py", line 167, in _processQueue
                                                status = self._downloadURL(filename, item)
                                              File "C:\Users\West\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib\SimpleDownloader.py", line 413, in _downloadURL
                                                self._updateProgress(filename, item, params)
                                              File "C:\Users\West\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib\SimpleDownloader.py", line 485, in _updateProgress
                                                speed = int((get("bytes_so_far") / 1024) / (new_mark - get("mark")))
                                            ZeroDivisionError: float division
Yep, download didn't work for me as well.
Anyone with apple tv eden beta 1 can confirm working youtube plugin after update to version 2.9.0? I have downloaded the update today but the plugin does not load at all (script fails)
http://swnet.spb.ru/files/xbmc-addons.zip is not a plug-in, it's just a zipped directory with plug-ins that you need to unpack into XMBC addons directory by hand.
CrazyCoder Wrote:http://swnet.spb.ru/files/xbmc-addons.zip is not a plug-in, it's just a zipped directory with plug-ins that you need to unpack into XBMC addons directory by hand.

Well, I was not talking about the zip file, the official repository offered an update today of the youtube plugin to version 2.9.0, so I simply downloaded the updated directly in apple tv and now the plugin does not work at all....So are you suggesting that whereas the official repository update does not work, the alternative update through the zip file will help?
No, I thought that you were trying the zip, sorry.
Trying to login, and get the 2-step digit window up. But still I get login false.

Code:
20:46:44 T:140302557071104  NOTICE: YouTube-2.9.0
20:46:44 T:140302557071104  NOTICE: CommonFunctions-0.9.1
20:46:44 T:140302557071104   ERROR: ADDON: extension 'downloader/' is not currently supported for service addon
20:46:44 T:140302557071104   ERROR: Previous line repeats 1 times.
20:46:44 T:140302557071104  NOTICE: Thread Background Loader start, auto delete: false
20:46:44 T:140303079061312   ERROR: GetDirectory - Error getting plugin://plugin.video.youtube/?path=/root/login&action=settings&
20:46:44 T:140303079061312   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/?path=/root/login&action=settings&) failed
20:46:44 T:140302557071104  NOTICE: Thread Background Loader start, auto delete: false

Not sure what I'm doing wrong. Worked just a couple of days ago.

Running XBMC 11.0-BETA1 Git:22ad8e4 (Compiled: Jan 17 2012). Any changes upstream which could be explaining this?

Thanks for the plugin though Smile Loving it when it works.
MindTooth Wrote:Trying to login, and get the 2-step digit window up. But still I get login false.

Code:
20:46:44 T:140302557071104  NOTICE: YouTube-2.9.0
20:46:44 T:140302557071104  NOTICE: CommonFunctions-0.9.1
20:46:44 T:140302557071104   ERROR: ADDON: extension 'downloader/' is not currently supported for service addon
20:46:44 T:140302557071104   ERROR: Previous line repeats 1 times.
20:46:44 T:140302557071104  NOTICE: Thread Background Loader start, auto delete: false
20:46:44 T:140303079061312   ERROR: GetDirectory - Error getting plugin://plugin.video.youtube/?path=/root/login&action=settings&
20:46:44 T:140303079061312   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/?path=/root/login&action=settings&) failed
20:46:44 T:140302557071104  NOTICE: Thread Background Loader start, auto delete: false

Not sure what I'm doing wrong. Worked just a couple of days ago.

Running XBMC 11.0-BETA1 Git:22ad8e4 (Compiled: Jan 17 2012). Any changes upstream which could be explaining this?

Thanks for the plugin though Smile Loving it when it works.

Full log to pastebin please.
wmansir Wrote:Installed on Eden Beta 2, Win7 64. Just unzipped in Addons dir with overwrite existing.

Videos now stream play, but won't "download video". Popup just sits at "Preparing download".

errors from log:

Several instances of :

Code:
21:29:31 T:7728   ERROR: ADDON: extension 'downloader\' is not currently supported for service addon

Code:
21:31:01 T:4632  NOTICE: -->Python Interpreter Initialized<--
21:31:01 T:4632  NOTICE: YouTube-2.9.0
21:31:01 T:4632  NOTICE: CommonFunctions-0.9.1
21:31:01 T:4632   ERROR: ADDON: extension 'downloader\' is not currently supported for service addon
21:31:03 T:1248   ERROR: Previous line repeats 1 times.
21:31:03 T:1248   ERROR: C:\Users\West\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib\DialogDownloadProgress.py:136: DeprecationWarning: object.__init__() takes no parameters
                                              xbmcgui.WindowXMLDialog.__init__(self, *args, **kwargs)
21:31:03 T:7728   ERROR: CLocalizeStrings::ClearBlock: Trying to clear non existent block C:\Users\West\AppData\Roaming\XBMC\addons\script.module.simple.downloader
21:31:04 T:1248   ERROR: Exception in thread Thread-1:
                                            Traceback (most recent call last):
                                              File "C:\Program Files (x86)\XBMC\system\python\Lib\threading.py", line 532, in __bootstrap_inner
                                                self.run()
                                              File "C:\Program Files (x86)\XBMC\system\python\Lib\threading.py", line 484, in run
                                                self.__target(*self.__args, **self.__kwargs)
                                              File "C:\Users\West\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib\SimpleDownloader.py", line 125, in _startDownload
                                                self._processQueue()
                                              File "C:\Users\West\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib\SimpleDownloader.py", line 167, in _processQueue
                                                status = self._downloadURL(filename, item)
                                              File "C:\Users\West\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib\SimpleDownloader.py", line 413, in _downloadURL
                                                self._updateProgress(filename, item, params)
                                              File "C:\Users\West\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib\SimpleDownloader.py", line 485, in _updateProgress
                                                speed = int((get("bytes_so_far") / 1024) / (new_mark - get("mark")))
                                            ZeroDivisionError: float division

CrazyCoder Wrote:Yep, download didn't work for me as well.

I tried a clean install and downloading worked fine.

If you installed with the unofficial zip provided above, please uninstall it and upgrade/install through the repository.

ETA: This has been confirmed and is being looked at.
@tobias

I tried uninstalling the plugin, and even manually deleting the helper scripts that were included in the zip and letting XBMC reinstall everything, but I couldn't get it to work. Eventually I backed up my XBMC profile and then did a complete uninstall/reinstall of Eden b2.

It looks like everything is working fine now. I just have to restore some bits of my profile.

EDIT: Tried restoring my profile databases and it reverted to same broken behavior. Deleted Addons.db, Addon15.db and commoncache.db, that seems to have fixed it. Maybe it will save someone a reinstall.
Thanks for pushing the 2.9 update out. Much appreciated.
I really like the addition of the watch later and liked videos but nothing's coming up for these lists. Is this a known gap or are these features working for other folks?
I know most of the focus is on PC and ATV, but does anyone here use YouTube with the original XBOX1? I actually still use mine (it is the cheapest set top player and I have used it for years for playing offline videos but wanted to know if anyone could possibly help me with playing YouTube videos? Thanks!
Hey guys i think the update to 2.9 or some of its dependancies may have caused Justin.tv plug in to break.


The following script error started after
-youtube update 2.9.0
-common plugin update
-simple downloader update

14:12:27 T:2896272240 ERROR: Error Type: <type 'exceptions.ValueError'>
14:12:27 T:2896272240 ERROR: Error Contents: No JSON object could be decoded
14:12:27 T:2896272240 ERROR: Traceback (most recent call last):
File "/storage/.xbmc/addons/plugin.video.jtv.archives/default.py", line 559, in <module>
Categories()
File "/storage/.xbmc/addons/plugin.video.jtv.archives/default.py", line 117, in Categories
data = json.loads(result[0])
File "/usr/lib/python2.7/json/__init__.py", line 326, in loads
return _default_decoder.decode(s)
File "/usr/lib/python2.7/json/decoder.py", line 366, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File "/usr/lib/python2.7/json/decoder.py", line 384, in raw_decode
raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
14:12:27 T:3018414800 ERROR: GetDirectory - Error getting plugin://plugin.video.jtv.archives
14:12:27 T:3018414800 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.jtv.archives) failed
14:12:27 T:2896272240 NOTICE: Thread Background Loader start, auto delete: false
14:12:36 T:2896272240 NOTICE: Thread XBPyThread start, auto delete: false
14:12:36 T:3018414800 ERROR: Control 1 in window 10099 has been asked to focus, but it can't
Hi,

Thank you for updating the plugin, just a little thing, I use two step login, and I'm asked for my pin on every single video I play, well I have disabled two step for the moment, but it would be great to have it back.

On the other hand, may be I'm missing something obvious, but, how can I invert the order for "watch later" videos? rigth now latest videos are at the end, so I have to click more videos to get to the latest (and this will grow every time I add a new video)
RGB_Gamer Wrote:I know most of the focus is on PC and ATV, but does anyone here use YouTube with the original XBOX1? I actually still use mine (it is the cheapest set top player and I have used it for years for playing offline videos but wanted to know if anyone could possibly help me with playing YouTube videos? Thanks!

We do not support xbmc4xbox in any way shape or form.

Other people have ported the plugin to the xbox, but you will have to find out the details on the xbmc4xbox site.
  •   
  • 1
  • 123
  • 124
  • 125(current)
  • 126
  • 127
  • 315
  •   
  Thread Closed
 
Thread Rating:
  • 28 Vote(s) - 4.14 Average



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only4.1428