•   
  • 1
  • 170
  • 171
  • 172(current)
  • 173
  • 174
  • 315
  •   
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
(2012-11-27, 22:28)Salabim Wrote: There is 1 problem with the Youtube add-on, for some reason it never shows any video's for this subscription :
https://www.youtube.com/user/Nudelyn (Notice the username is 'Leo Davidson')
... perhaps the space in the username is making the add-on not show any contents ?

Hi,

I think I managed to fix this with a simple patch to YouTubeCore.py. The code is using the displayname not the actual username.

Basically the API returns a yt:username (which has no spaces, while there is a 'display' attribute which has the display name in the same tag. I am not very familiar with python or the youtube plugin, so I have no idea if it is the right fix, but it certainly has the desired result for me which is all my subscriptions where the display name has a space now work fine. I have about 5 subscriptions that fit this category.

The following patch against 3.3.0 has fixed the issue for me. Its a one line change.

http://code.google.com/p/youtubexbmc/iss...tail?id=62

(2012-12-14, 12:35)JasonPell Wrote:
(2012-11-27, 22:28)Salabim Wrote: There is 1 problem with the Youtube add-on, for some reason it never shows any video's for this subscription :
https://www.youtube.com/user/Nudelyn (Notice the username is 'Leo Davidson')
... perhaps the space in the username is making the add-on not show any contents ?

Hi,

I think I managed to fix this with a simple patch to YouTubeCore.py. The code is using the displayname not the actual username.

Basically the API returns a yt:username (which has no spaces, while there is a 'display' attribute which has the display name in the same tag. I am not very familiar with python or the youtube plugin, so I have no idea if it is the right fix, but it certainly has the desired result for me which is all my subscriptions where the display name has a space now work fine. I have about 5 subscriptions that fit this category.

The following patch against 3.3.0 has fixed the issue for me. Its a one line change.

http://code.google.com/p/youtubexbmc/iss...tail?id=62

Thanks a lot Jason, it works now ! Blush
Will this fix get included in the official release please ?
(2012-12-14, 14:17)Salabim Wrote:
(2012-12-14, 12:35)JasonPell Wrote:
(2012-11-27, 22:28)Salabim Wrote: There is 1 problem with the Youtube add-on, for some reason it never shows any video's for this subscription :
https://www.youtube.com/user/Nudelyn (Notice the username is 'Leo Davidson')
... perhaps the space in the username is making the add-on not show any contents ?

Hi,

I think I managed to fix this with a simple patch to YouTubeCore.py. The code is using the displayname not the actual username.

Basically the API returns a yt:username (which has no spaces, while there is a 'display' attribute which has the display name in the same tag. I am not very familiar with python or the youtube plugin, so I have no idea if it is the right fix, but it certainly has the desired result for me which is all my subscriptions where the display name has a space now work fine. I have about 5 subscriptions that fit this category.

The following patch against 3.3.0 has fixed the issue for me. Its a one line change.

http://code.google.com/p/youtubexbmc/iss...tail?id=62

I am not a developer do who knows. I have posted the bug report and patch so hopefully it will
Thanks a lot Jason, it works now ! Blush
Will this fix get included in the official release please ?

I am having a problem with the Youtube Addon.
It just gives me empty directory when i click on explore
I am using Openelec 2.95 Beta 5.

Here is the log
http://pastebin.com/7svbMYvr
(2012-12-08, 04:30)sthomas13 Wrote: this may have already been discussed, but call me lazy, I don't feel like reading through 250+ pages to find an answer, and can't seem to get what I'm looking for with search.... is there an 'auto-play next video' feature in this application??

I've got GoogleTV for another tv in our house, and the youtube app for that continuously plays the videos... with this one however, all I can seem to find is a 'queue video' button to add more. This works great, BUT it's kind of a pain to have to go through and select all the videos I want to play, would be much nicer to just click on the first one and let 'em run.

any help would be greatly appreciated!

anyone got an answer for this?
(2012-12-14, 15:00)JasonPell Wrote:
(2012-12-14, 14:17)Salabim Wrote:
(2012-12-14, 12:35)JasonPell Wrote: Hi,

I think I managed to fix this with a simple patch to YouTubeCore.py. The code is using the displayname not the actual username.

Basically the API returns a yt:username (which has no spaces, while there is a 'display' attribute which has the display name in the same tag. I am not very familiar with python or the youtube plugin, so I have no idea if it is the right fix, but it certainly has the desired result for me which is all my subscriptions where the display name has a space now work fine. I have about 5 subscriptions that fit this category.

The following patch against 3.3.0 has fixed the issue for me. Its a one line change.

http://code.google.com/p/youtubexbmc/iss...tail?id=62

I am not a developer do who knows. I have posted the bug report and patch so hopefully it will
Thanks a lot Jason, it works now ! Blush
Will this fix get included in the official release please ?


the patch was accepted and committed to the plugin repo so should be in next release
(2012-12-15, 03:23)JasonPell Wrote:
(2012-12-14, 15:00)JasonPell Wrote:
(2012-12-14, 14:17)Salabim Wrote: I am not a developer do who knows. I have posted the bug report and patch so hopefully it will
Thanks a lot Jason, it works now ! Blush
Will this fix get included in the official release please ?


the patch was accepted and committed to the plugin repo so should be in next release

Can we use the patch right now? I am running openelec and getting the login error.
(2012-12-15, 03:46)richardmeehan Wrote:
(2012-12-15, 03:23)JasonPell Wrote:
(2012-12-14, 15:00)JasonPell Wrote:


the patch was accepted and committed to the plugin repo so should be in next release

Can we use the patch right now? I am running openelec and getting the login error.

I believe Jason's patch is only for certain "My Subscription" not to show up empty.Wink
Hi,

Download a video is not working anymore :

PHP Code:
...
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0lock 'SimpleDownloaderLock'
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0lock 'Downloader'
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0_sock_init ''
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0_sock_init 'Done: '/home/n0rad/.xbmc/temp/commoncache.socket''
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0_connect 'Exception: error(2, 'No such file or directory')'
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0_connect 'Exception: '/home/n0rad/.xbmc/temp/commoncache.socket''
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0lock 'Failed'
21:14:06 T:140625953412864  NOTICE: [YouTube-3.3.0_startDownload 'Downloader is active, Queueing item.'
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0lock 'SimpleDownloaderQueueLock'
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0lock 'Downloader'
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0_sock_init ''
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0_sock_init 'Done: '/home/n0rad/.xbmc/temp/commoncache.socket''
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0_connect 'Exception: error(2, 'No such file or directory')'
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0_connect 'Exception: '/home/n0rad/.xbmc/temp/commoncache.socket''
21:14:06 T:140625953412864  NOTICE: [StorageClient-1.3.0lock 'Failed'
21:14:06 T:140625953412864  NOTICE: [YouTube-3.3.0_addItemToQueue 'Couldn't lock

Tested with a 2 month installation and a fresh installation.

I don't know since when its not working.
Q: does anyone know if I pay for a live stream youtube video online if it will show up in the list of feeds when I refresh the youtube addon?
(2012-12-15, 03:46)richardmeehan Wrote:
(2012-12-15, 03:23)JasonPell Wrote:
(2012-12-14, 15:00)JasonPell Wrote:


the patch was accepted and committed to the plugin repo so should be in next release

Can we use the patch right now? I am running openelec and getting the login error.


Login is working in the beta version. No idea when it will be release or if it is a simple fix.
(2012-12-16, 20:42)vikjon0 Wrote:
(2012-12-15, 03:46)richardmeehan Wrote:
(2012-12-15, 03:23)JasonPell Wrote: the patch was accepted and committed to the plugin repo so should be in next release

Can we use the patch right now? I am running openelec and getting the login error.


Login is working in the beta version. No idea when it will be release or if it is a simple fix.

I have an error every time I try to login to the youtube addon.

Are you saying that this problem is fixed in the next version of the addon?
I am saying that it is working in the beta version found in the source repository.
Simple words from the developers: The plugin is not yet "Frodo" ready
(2012-12-16, 21:44)vikjon0 Wrote: I am saying that it is working in the beta version found in the source repository.

ok I get you, thanks.
  •   
  • 1
  • 170
  • 171
  • 172(current)
  • 173
  • 174
  • 315
  •   



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only28
This forum uses Lukasz Tkacz MyBB addons.