•   
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 315
  •   
  Thread Closed
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
#91
As a last resort I wiped my xbmc install and reinstalled. I'm now logged in watching my favorites. Sorry for all the trouble, guess I did the upgrade thing one two many times.:o
#92
Redneck Wrote:As a last resort I wiped my xbmc install and reinstalled. I'm now logged in watching my favorites. Sorry for all the trouble, guess I did the upgrade thing one two many times.:o

No no, is fine.

If you still have the log from when it logged in, would you mind uploading it anyways. Maybe it was the backup code that helped, and i might glean something if the first login failed.
#93
TobiasTheCommie Wrote:Possibly, try with version 0.9.6, and if it still fails give us a new debug log.

here is the new log

http://pastebin.com/ekZvi8A5
#94
mighty_bombero Wrote:For those anxious to try on Xbox. Here a patched up version. I had to disable open settings but with some more time I'm positive this can be fixed up too. Will hopefully clean this up soon and provide patches upstream.

http://ul.to/y9hxhw

@henrik & Tobias: Hope you don't mind me providing this version?

MB

Of course not. Smile
#95
THIS SHOULD FIX THE LOGIN ISSUES.

Release 0.9.7
- Minor bugfixes
- Improve messages
- General cleanup
- Hardening certain function.
- Replaced some icons to fix license issues.
- Add icon licenses file.
- Tested against revision 33122 on linux(ubuntu and arch), Windows vista, and Snow Leopard.
- Added login loop. Max 10 tries, 1 second delay.


http://code.google.com/p/youtubexbmc/downloads/list

Or

http://www.mediafire.com/?x7po7paygnsfalh

SHA: 696571c972fda51f23b456dcd52e5731da77d282
md5: a4c5a6c95cda91566df80610b15da9ad


There will now be a login message that says "[0] Logged in"

If the number is more than 0 it means that en error happened and it had to retry the login. In which case i would be interested in a log.

Notes:
- RTMPE worked on all systems when tested with this video: http://www.youtube.com/watch?v=8wxOVn99F...S&hl=en_US

- I have tried running the login code with urllib2, httplib and httplib2. The failure is consistent over all three of those libraries.

- This version has been tested on revision 33122 on all platforms. But some of the systems(a linux arch and a windows vista) have had some of the login errors reported in this thread. The login errors are not fixed. But i think it just needs a few tries to go through. So i have told it to try 10 times in a row and hope that will give people access. This is not a fix, this is a test/work-around.
#96
feerlessleadr Wrote:here is the new log

http://pastebin.com/ekZvi8A5


Your version of the plugin is at least two versions old, but there was some version confusion with 0.9.6 so that might be the reason.

Please try with a new one.
#97
TobiasTheCommie Wrote:No no, is fine.

If you still have the log from when it logged in, would you mind uploading it anyways. Maybe it was the backup code that helped, and i might glean something if the first login failed.

I don't think this has what your looking for. I did have to restart xbmc after I installed from zip, for it to work. http://pastebin.com/hGrEatn0
#98
procrastinator Wrote:Hey,
Ultra-quick update: Just updated to the latest nightly of XBMC (r33122) and the latest version of the plugin from the google code page (0.9.6). No luck on any of the rtmpe videos from my previous posts. Did not even get playback for a limited time (as I had previously on the non-age restricted video) - just completely failed to play this time. No luck with the Test video you posted a link to either. Error message for all was "uncaught error".

As I say: it's an ultra-quick update for now, but I'll post a full debug log when I've got more time (prob tomorrow night).

Could you enable xbmc debug for the log? Just in case there is something weird happening in XBMC and not in our plugin.

Oh, and of course do it with the new 0.9.7 Wink
#99
Redneck Wrote:I did have to restart xbmc after I installed from zip, for it to work.

Now that is annoying.
TobiasTheCommie Wrote:Your version of the plugin is at least two versions old, but there was some version confusion with 0.9.6 so that might be the reason.

Please try with a new one.

this is really strange, but i downloaded from your google code page and installed from zip file.

I checked the changelog in the \xbmc\portable_addons\addons\plugin.video.youtube.beta folder and it 0.9.4 was the latest entry. I then unzipped the file I downloaded from google code and the changelog said 0.9.6 (which should have been 0.9.7, but that is a different story). No matter what I did, everytime I installed from the zip file, the wrong files were being copied to the portable addons folder above. eventually, I just copied the extracted folder to the \xbmc\addons\ folder and restarted and now it works fine.

Perhaps the problem was that when I first installed your plugin I just copied the folder to the \xbmc\addons folder and I didn't use 'install from zip'. (I did delete the original plugin from the \xbmc\addons\ folder when I was troubleshooting this problem)
Ah, it's good that it works now.

Your changelog says 0.9.6? The changelog in my file says 0.9.7. This is very weird.
yea, i redownloaded it twice, but still the change log says 0.9.6.

maybe if you upload your version to mediafire or something like that. Maybe there is a problem with google code?
Ok, here is a mediafire upload.

http://www.mediafire.com/?x7po7paygnsfalh

Ok, uploaded there, and i downloaded it and changelog says 0.9.7
sweet, that is 0.9.7

thanks for uploading it.
I've had trouble downloading and installing it as well.

I used Chrome on linux and kept on receiving the 0.9.4 version. It downloaded correctly when I used the rapidshare link. When I tried to download the 0.9.7 version with Chrome from google, I kept on getting the 0.9.4 zip. I only got the latest version when I used Firefox. Perhaps Chrome is caching the zip by filename...?

The second problem was installing the zip file. Even though I checked that I had the latest version by unzipping the file, XBMC was somehow re-installing the 0.9.4 version each time. I could only install it by manually copying the files to my .xbmc/addons directory.
  •   
  • 1
  • 5
  • 6
  • 7(current)
  • 8
  • 9
  • 315
  •   
  Thread Closed
 
Thread Rating:
  • 28 Vote(s) - 4.14 Average



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only4.1428