•   
  • 1
  • 165
  • 166
  • 167(current)
  • 168
  • 169
  • 315
  •   
  Thread Closed
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
Youtube broken again. script fails then xbmc freezes. Here is something: http://paste.ubuntu.com/1363537/
Image
HTPC: Motherboard: Asus F2A85-V, CPU: AMD A10 6800K, RAM: Kingston XMP BEAST 16GB, Samsung 840 EVO 250GB, LG CH12NS30 Blu-Ray drive, Samsung, and WD various 2 and 3TB for storage, Windows 8.1, one for all remote/FLIRC, Logitech z906 surround system.
Yes. Youtube is broken.

Here the log: http://paste.ubuntu.com/1364561/

and here: http://paste.ubuntu.com/1364554/
it isn't. i went back to 11.0 eden and everything works again.
i had the aforementioned youtube problems, as well as other problems with some video addons.

i'll wait a while until i give frodo another try...
On v12 beta 1 (Linux Mint 12) the "My Subscriptions" doesn't work (in addition to all the stuff that didn't work on v11) so don't try v12 b1 if you care about "My Subscriptions." (For the "Search" function to work you have to manually edit YouTubeCore.py as mentioned here previously.)

On v12 beta 1 if you're having audio problems, check the audio settings - I had to change options before .flv files would play with audio - new audio engine.
(2012-11-16, 20:44)zarac Wrote:
(2012-11-16, 15:51)VelvetKevorkian Wrote: weird: i updated to frodo beta1, and now "my subscriptions" (most important for me) won't work (script failed), everything else works fine :-?

I have the same problem, but in my case the search function doesn't work as well. It doesn't error out, but when I click on "search" it opens search subfolder with only ".." there, no "search" link.

Here's my log: http://xbmclogs.com/show.php?id=14660

Also worth mentioning: I had to switch on "debug" option in youtube plugin to be able to login using google two-step authentification, otherwise the window asking for code wouldn't pop up.

I'm on Ubuntu 12.04 32-bit, XBMC version 2:11.9.7~git201211131826~37e8e4e-1~ppa1~precise.

I also have the same problem with the "..". On Beta 1 and OS X 10.8.2

Debug log: http://xbmclogs.com/show.php?id=14736

Edit: Just seen jackparsons comments above and will give editing YouTubeCore.py a shot.
(2012-11-17, 12:14)jackparsons Wrote: For the "Search" function to work you have to manually edit YouTubeCore.py as mentioned here previously.

Unfortunately editing line 769 in YouTubeCore.py didn't solve the search issue for me.
As far as I understood, that edit should fix errors while displaying search results. But this issue is different as I can't even type in the search query.
(2012-11-17, 16:08)zarac Wrote: Unfortunately editing line 769 in YouTubeCore.py didn't solve the search issue for me.
As far as I understood, that edit should fix errors while displaying search results. But this issue is different as I can't even type in the search query.
Zarac you are correct, what I didn't notice was that it was my saved searches that are showing up, and showing results for videos that actually play, but there is no ability to make a new search.

I think it's a Python version issue, the newer XBMC has a newer Python which exposes bugs in the plugin code. Only some plugins are affected by this, for instance the Trailers plugin still seems to function for me.

Hi !

I am the maintainer of the XBMC translation project up at transifex.com.
I added this plugin to the project:
https://www.transifex.com/projects/p/XBM...o-youtube/

I will maintain and keep in sync all language files for this addon here:
https://github.com/xbmc/translations/tre...eo.youtube

The plugin was already translated for most of the languges by now. I made a zip of the language files which I attach.

Could you please in the future just pull in the fresh files from the link above, from time to time. That would help my work a lot.

Thanks, Let me know if you have any questions,
Cheers,
Attila
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Note: these remarks directed at users of V12 b1 who can't browse "My Subscriptions."

Tried the 3.2.999 development version, which shows as "YouTube Beta," but it seems just as broken in general. However, I have a workaround of sorts which involves this version which has a working "My Contacts" option.

Add the channel(s) you want to watch to your YouTube "Contacts" via your YouTube address book:
http://www.youtube.com/address_book

You can browse via the v3.2.999 plugin "My Contacts" to the channel's "Uploads" section and play the videos would you get in "Subscriptions."

Somebody wake me up if the plugin actually gets fixed.
(2012-11-17, 17:16)jackparsons Wrote:
(2012-11-17, 16:08)zarac Wrote: Unfortunately editing line 769 in YouTubeCore.py didn't solve the search issue for me.
As far as I understood, that edit should fix errors while displaying search results. But this issue is different as I can't even type in the search query.
Zarac you are correct, what I didn't notice was that it was my saved searches that are showing up, and showing results for videos that actually play, but there is no ability to make a new search.

I think it's a Python version issue, the newer XBMC has a newer Python which exposes bugs in the plugin code. Only some plugins are affected by this, for instance the Trailers plugin still seems to function for me.

Search is not working for me either, basically no search option, only search history.
My workaround is to do my searches, and ad subscriptons on my phone and then use xbmc to see it at my big screeen...
Yeah I've been using airplay with Jasmine, which works fine, but it would be nice if the plugin were fixed.
Hi,

I rum Eden and have version 3.3.0 plugin and when I try to play a playlist I get a youtube script error message ( below is from log file)
Any ideas??


Code:
20:19:08 T:5996   DEBUG: Python thread: start processing
20:19:08 T:5996  NOTICE: -->Python Interpreter Initialized<--
20:19:08 T:5996   DEBUG: XBPyThread::Process - The source file to load is C:\Users\deppeler\AppData\Roaming\XBMC\addons\plugin.video.youtube\default.py
20:19:08 T:5996   DEBUG: XBPyThread::Process - Setting the Python path to C:\Users\deppeler\AppData\Roaming\XBMC\addons\plugin.video.youtube;C:\Users\deppeler\AppData\Roaming\XBMC\addons\script.module.cryptopy\lib;C:\Users\deppeler\AppData\Roaming\XBMC\addons\script.module.demjson\lib;C:\Users\deppeler\AppData\Roaming\XBMC\addons\script.module.simplejson\lib;C:\Users\deppeler\AppData\Roaming\XBMC\addons\script.module.beautifulsoup\lib;C:\Program Files (x86)\XBMC\addons\script.module.pil\lib;C:\Users\deppeler\AppData\Roaming\XBMC\addons\script.common.plugin.cache\lib;C:\Users\deppeler\AppData\Roaming\XBMC\addons\script.module.simple.downloader\lib;C:\Users\deppeler\AppData\Roaming\XBMC\addons\script.module.free.cable.database\lib;C:\Users\deppeler\AppData\Roaming\XBMC\addons\script.module.coveapi\lib;C:\Users\deppeler\AppData\Roaming\XBMC\addons\script.module.buggalo\lib;C:\Users\deppeler\AppData\Roaming\XBMC\addons\script.module.mechanize\lib;C:\Users\deppeler\AppData\Roaming\XBMC\addons\script.module.parsedom\lib;C:\Users\deppeler\AppData\Roaming\XBMC\addons\script.module.elementtree\lib;C:\Program Files (x86)\XBMC\addons\script.module.pysqlite\lib;C:\Program Files (x86)\XBMC\system\python\DLLs;C:\Program Files (x86)\XBMC\system\python\Lib;C:\Program Files (x86)\XBMC\python26.zip;C:\Program Files (x86)\XBMC\system\python\lib\plat-win;C:\Program Files (x86)\XBMC\system\python\lib\lib-tk;C:\Program Files (x86)\XBMC;C:\Program Files (x86)\XBMC\system\python;C:\Program Files (x86)\XBMC\system\python\lib\site-packages;
20:19:08 T:5996   DEBUG: XBPyThread::Process - Entering source directory C:\Users\deppeler\AppData\Roaming\XBMC\addons\plugin.video.youtube
20:19:08 T:5996   DEBUG: Instantiating addon using automatically obtained id of "plugin.video.youtube" dependent on version 2.0 of the xbmc.python api
20:19:08 T:5996  NOTICE: YouTube-3.3.0
20:19:08 T:5996  NOTICE: CommonFunctions-1.3.0
20:19:09 T:5996    INFO: -->Python script returned the following error<--
20:19:09 T:5996   ERROR: Error Type: <type 'exceptions.TypeError'>
20:19:09 T:5996   ERROR: Error Contents: an integer is required
20:19:09 T:5996   ERROR: Traceback (most recent call last):
                                              File "C:\Users\deppeler\AppData\Roaming\XBMC\addons\plugin.video.youtube\default.py", line 110, in <module>
                                                navigation.executeAction(params)
                                              File "C:\Users\deppeler\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeNavigation.py", line 156, in executeAction
                                                self.playlist.playAll(params)
                                              File "C:\Users\deppeler\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubePlaylistControl.py", line 91, in playAll
                                                listitem = self.xbmcgui.ListItem(label=video("Title"), iconImage=video("thumbnail"), thumbnailImage=video("thumbnail"))
                                            TypeError: an integer is required
20:19:09 T:5996    INFO: -->End of Python script error report<--
20:19:09 T:4936   DEBUG: ------ Window Init (DialogKaiToast.xml) ------
20:19:09 T:5996    INFO: Python script stopped

thanks
Installed YouTube video plugin v3.3.0 on v12 b1 (Frodo) on Linux Mint 12, having deleted the previous plugin version.
  • "My Subscriptions" functions as expected
  • playlist function works as expected
  • "Search" functions as expected
  • "Explore YouTube" now has some functionality
So far has only been about 10 minutes but is looking good. It seems Frodo users can upgrade and expect improvement. ("My Contacts" is not present as it was in the beta I tried, although it appeared to work in that.)
(2012-11-21, 11:43)jackparsons Wrote: So far has only been about 10 minutes but is looking good. It seems Frodo users can upgrade and expect improvement. ("My Contacts" is not present as it was in the beta I tried, although it appeared to work in that.)
Thanks! I have a ION box running Ubuntu with XBMC 12.0 beta 1 and I was tempted to try the v3.3.0 but an issue with dependency made me desist. Anyway I installed only script.module.simplejson and the 3.3.0 version was able to go.
It was good to find also that even if I uninstalled youtube addon 3.2.0 before proceeding with this upgrade, the settings (youtube account, etc.) were preserved.
  •   
  • 1
  • 165
  • 166
  • 167(current)
  • 168
  • 169
  • 315
  •   
  Thread Closed
 
Thread Rating:
  • 28 Vote(s) - 4.14 Average



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only4.1428