•   
  • 1
  • 74
  • 75
  • 76(current)
  • 77
  • 78
  • 315
  •   
  Thread Closed
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
Just confirming that my YT plugin is also broken. Sounds like an update is needed to the plugin to extract the correct values again. Is anyone working on this yet? Any ETA?

EDIT: Just in case anyone wants to track it down, the _extractVariables function is from lines 818-846 in "YouTubeCore.py" in the YouTube plugin folder. At least that is where it is in plugin v2.0.5 on my Ubuntu 10.04 XBMC box.
Well it looks like there was another upside in helping test the beta I'm not having the same non-playback issues as anyone else, you will have to wait for Henrik or Tobias to see when there will be a fix for the stable version although Henrik did say that 2.6 should be out by the end of the week for pre-eden.
Hi,

We've been aware that YouTube was rolling out a new player on their page for some time, which included changes in the way videos are served. As such we've prepared new playback code in trunk but haven't backported it to dharma yet, since we weren't sure if/when the switch was gonna happen (and it still needs some testing).

This changes things though, so I'll look into making a port asap.
Henrik, once again, I extend my thanks for your hard work on this great plugin, Looking forward to the new version indeed!
Henrik, I'm on Eden Pre (obviously) is there a version I can grab that works ? I'm on 2.5.0 now
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


Image
Changelog:
Version 2.1.0
- Fixed YouTube playback and downloading by back-porting code from trunk
pike Wrote:Henrik, I'm on Eden Pre (obviously) is there a version I can grab that works ? I'm on 2.5.0 now

Hi pike.

I'm working on a port to eden-pre now, the code is very different so it might be a little while Smile
HenrikDK Wrote:Changelog:
Version 2.1.0
- Fixed YouTube playback and downloading by back-porting code from trunk

I haven't tested extensively yet, but so far it seems to be working flawlessly once more, in fact, It feels like there is a shorter wait time until the video starts streaming than before.

Amazing work as always! Thank you!
salvi Wrote:I haven't tested extensively yet, but so far it seems to be working flawlessly once more, in fact, It feels like there is a shorter wait time until the video starts streaming than before.

Amazing work as always! Thank you!

This code should also be way more persistent now.

It tries to get the information from three different places(two different sources).

I hadn't noticed a speed increase though.. interesting.
Maybe it's down to network congestion due to the hours, I usually use the add-on later on in the day. But from the time the little Waiting animation alert pops-up at the bottom right after you click on a video, it takes now about 1 second for the video to start, definitely less than 2 seconds. I seem to recall a longer wait in previous versions, around 2 to 3 seconds.
Henrik_DK Told me the same thing when i asked him.

Apparantly just me that is too dim to notice anything.
HenrikDK Wrote:Changelog:
Version 2.1.0
- Fixed YouTube playback and downloading by back-porting code from trunk

This backport includes the 4oD code. So 4oD content (and all other rtmp content) should now play.

This does require librtmp 2.4.

One thing that MIGHT work with this code(we haven't tested) is watching a movie that you have to pay for. I can't personally test this, but it might work.
The plugin updated and shows release 2.10 in the addons. I am getting errors on opening a movie, below is the error from the log. But the log is showing 2.0.5 as the YouTube version?

Code:
10:20:53 T:3031915376 M:1820262400  NOTICE: YouTube-2.0.5 construct video url failed contents of video item {'count': 0, 'Plot': 'Date Uploaded: 2011-04-18, View count: 0\nCelebrate the season Scooby-Doo style as Scooby-Doo and the Mystery, Inc. gang faces off against festive frights, frosty nights, and - jeepers - the ghost of Christmas, who wants to wish everyone a scary Christmas! In this collection of cold-weather capers, Scooby-Doo and the gang unwrap a series of mysteries in order to stop a group of chilling crooks from stealing the spirits of the season!  MPAA Rating: NOTRATED', 'Title': 'ScoobyDoo: Winter Wonderdog', 'apierror': u"Couldn't extract video url", 'Rating': 5.0, 'videoid': u'1N8xts-WwXY', 'next': 'false', 'Duration': '75:38', 'Genre': 'Movies', 'Studio': 'warnervod', 'user': 'warnervod', 'Date': '2011-04-18T16:48:39.000Z', 'url_map': 'true', 'thumbnail': u'http://i.ytimg.com/vi/1N8xts-WwXY/0.jpg'}
10:20:53 T:3031915376 M:1820262400   ERROR: Error Type: exceptions.AttributeError
10:20:53 T:3031915376 M:1820262400   ERROR: Error Contents: YouTubePlayer instance has no attribute 'showMessage'
10:20:53 T:3031915376 M:1820262400   ERROR: Traceback (most recent call last):
                                              File "/home/XBMC/.xbmc/addons/plugin.video.youtube/default.py", line 48, in ?
                                                navigator.executeAction(params)
                                              File "/home/XBMC/.xbmc/addons/plugin.video.youtube/YouTubeNavigation.py", line 203, in executeAction
                                                player.playVideo(params)
                                              File "/home/XBMC/.xbmc/addons/plugin.video.youtube/YouTubePlayer.py", line 57, in playVideo
                                                self.showErrorMessage(self.__language__(30603), video["apierror"], status)
                                              File "/home/XBMC/.xbmc/addons/plugin.video.youtube/YouTubePlayer.py", line 365, in showErrorMessage
                                                self.showMessage(title, result)
                                            AttributeError: YouTubePlayer instance has no attribute 'showMessage'
10:20:53 T:3078174592 M:1820262400   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.youtube/?path=/root/explore/movies&action=play_video&videoid=1N8xts-WwXY]

Edit: Looks like I am getting an age error, darn it. I still do not know why it is showing release 2.05. I deleted the addon_data folder for youtube and restarted xbmc. Funny thing is if I search for a movie using YoutTube search feature " Jonah: A VeggieTales Movie" it works.

Ubuntu 10.10
xbmc build march 9 2011 git unknown
When i hit that video it tells me it is a rental that isn't available in my country.

I would very much like a full debug log of your problem.

Even though it says 2.0.5 you have version 2.1.0, A slight mistake in our rush to fix the plugin this morning.

ETA: Since this is a rental you most likely need an updated rtmp library (version 2.4)

If you are running mac or windows, installing the latest nightly of eden should give you that.
I have YouTube plugin 2.1.0 and while I don't watch movies on YouTube, regular videos (including searching) seems to work fine for me
  •   
  • 1
  • 74
  • 75
  • 76(current)
  • 77
  • 78
  • 315
  •   
  Thread Closed
 
Thread Rating:
  • 28 Vote(s) - 4.14 Average



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only4.1428