•   
  • 1
  • 84
  • 85
  • 86(current)
  • 87
  • 88
  • 315
  •   
  Thread Closed
Release [depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only
seems Im having trouble starting youtube.. I start it up and crashes.. dont know if this is the skin or addons or xbmc itself. Running this on my atv2 (Built on Aug 15 2011 (Git:20110815-82f48cd)

see logs

logs
http://paste2.org/p/1618954

old log
http://paste2.org/p/1618956
Nvidia Shield with Kodi 18
RGB_Gamer Wrote:Is there any way to add a feature in the Youtube add on so that after doing a search, the results are alphabetized? I often use Youtube for watching episodes, and many episodes are split up into multiple parts. It kinda sucks when I do a search and multi part episodes are listed on different pages. Would be nice if after doing a search on Youtube, the results are alphabetized so that the multi part episodes are listed together.

Perhaps I need to ask the author of the Youtube add on about this? If so, how would I reach them?

I've looked at the api and youtube doesn't seem to expose this, we do allow the user to sort a view within xbmc so perhaps that could help you?
PantsOnFire Wrote:When looking at a list of subscribed channels, is it possible to make the list alphabetical order? It would make things smarter, easier and in line with the rest of xbmc listview file listings.

This is already done in the beta
rflores2323 Wrote:seems Im having trouble starting youtube.. I start it up and crashes.. dont know if this is the skin or addons or xbmc itself. Running this on my atv2 (Built on Aug 15 2011 (Git:20110815-82f48cd)

see logs

logs
http://paste2.org/p/1618954

old log
http://paste2.org/p/1618956

Hi

I've looked at those log and I can't really see anything going wrong (theres no backtrace):

Code:
11:05:41 T:148135936  NOTICE: YouTube2.6.2
....
11:05:41 T:129708032   DEBUG: WaitOnScriptResult- plugin returned successfully
11:05:41 T:148135936    INFO: Scriptresult: Success

Sadly you didn't enable the plugins debug mode so i cant really see anymore than that, but i suspect the error to be in the apple tv build you're using.
HenrikDK Wrote:I've looked at the api and youtube doesn't seem to expose this, we do allow the user to sort a view within xbmc so perhaps that could help you?

true you change the view/sort after performing a search, but there is no option in the youtube add on for saving the view/sort type. so in effect, you have to set the desired view/sort type after every search you make. If it were up to me, i would set the sort to always be big list and the view to be by name and set it so it always displays search results this way every time.
feerlessleadr Wrote:I recently had to change my google account password due to a suspected security breach, and I believe that I have found a bug.

My current password has a space in it, which works fine for logging in through a browser, but not so much with this plugin.

When I enter in my username (full gmail address) and password then run the script, i get a dialog that says loading youtube, then xbmc notifies me that the script has failed. Here is the relevant portion:

Code:
23:25:57 T:5500   ERROR: Error Type: <type 'exceptions.ValueError'>
23:25:57 T:5500   ERROR: Error Contents: No JSON object could be decoded
23:25:57 T:5500   ERROR: Traceback (most recent call last):
                                              File "C:\Users\Kevin\AppData\Roaming\XBMC\addons\plugin.video.youtube\default.py", line 66, in <module>
                                                __login__.login()
                                              File "C:\Users\Kevin\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeLogin.py", line 74, in login
                                                (result, status) = self._apiLogin()
                                              File "C:\Users\Kevin\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeLogin.py", line 133, in _apiLogin
                                                oauth = json.loads(ret["content"])
                                              File "C:\Program Files (x86)\XBMC\system\python\Lib\json\__init__.py", line 307, in loads
                                                return _default_decoder.decode(s)
                                              File "C:\Program Files (x86)\XBMC\system\python\Lib\json\decoder.py", line 319, in decode
                                                obj, end = self.raw_decode(s, idx=_w(s, 0).end())
                                              File "C:\Program Files (x86)\XBMC\system\python\Lib\json\decoder.py", line 338, in raw_decode
                                                raise ValueError("No JSON object could be decoded")
                                            ValueError: No JSON object could be decoded
23:25:57 T:2780   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.youtube/
23:25:57 T:2780   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.youtube/) failed
23:25:57 T:2816 WARNING: XFILE::CFactoryDirectory::Create - Unsupported protocol(script) in script://

Thanks!

We'll look into it Smile
nitehawk_98 Wrote:@feerlessleadr

If you are using the nightly builds installing version 2.6.2 from http://code.google.com/p/youtubexbmc/downloads/list solved the problem for me.

you the man (or woman lol)!!!

Thanks
nitehawk_98 Wrote:@feerlessleadr

If you are using the nightly builds installing version 2.6.2 from http://code.google.com/p/youtubexbmc/downloads/list solved the problem for me.

HenrikDK Wrote:We'll look into it Smile

Thanks Henrik, but I think you have already solved the issue with 2.6.2 from GC Smile
Hello,
I am in troble getting the plugin to work. I updated the chipset and video drivers, the flash version... i dont know what else to do Smile.

he log is here: http://pastebin.com/yQjn1CQY

Thank you very much!
dreq Wrote:Hello,
I am in troble getting the plugin to work. I updated the chipset and video drivers, the flash version... i dont know what else to do Smile.

he log is here: http://pastebin.com/yQjn1CQY

Thank you very much!

Hmm seems you're python installation is missing the json lib, we've already added a simplejson dependency to the plugin so im not really sure why your installation is failing. Could you try upgradeing to a later nightly build of xbmc (yours is from march 8 which is pretty old)?
0k, i installed 2 night6ly builds 30.08 and 31.08 and now i caN search for videos but when i click them the xbmc stops responding and i have to kill it. i tried to login but i keep getting login failed. can you recomend a stable night build?

http://pastebin.com/2KG81gEe

thank you very much!
Sounds fun at the minute I can't get any of the plugins to work, this includes YouTube, TVCatchup, Apple Trailers Lite, Yahoo Movie Trailers and Game Trailers just comes up with Script error every time I try and load them.
**** EDIT: I have managed to 'fix it' myself. Actually i updated the XBMC build to the nightly from 31st August 2011 and now 4OD content plays correctly. Who'd a thunk it?

I have a problem with the plugin version 2.6.2 on XBMC for the Apple TV 2.

Basically, although the plugin seed 4OD content it will not play it.

I have taken a quick look at the xbmc.log and it seems this section details the error:
Code:
15:49:32 T:121696256 M:119574528   DEBUG: ------ Window Deinit (DialogProgress.xml) ------
15:49:32 T:147783680 M:119939072 WARNING: HandShake: Type mismatch: client sent 6, server answered 9
15:49:33 T:147783680 M:119930880 WARNING: HandShake: Server not genuine Adobe!
15:49:33 T:147783680 M:119930880   ERROR: RTMP_Connect1, handshake failed.
15:49:33 T:147783680 M:119930880   ERROR: CDVDPlayer::OpenInputStream - error opening [rtmpe://cp59009.edgefcs.net/youtube?auth=daEdobcaQdQcPbgd6bdaUcraad_bzaqdEbd-boy4_3-eS-LyFCFnpd&aifp=YT2008121701&slist=c2/id/fa51787587f7169f/itag/34&stream=c2/id/fa51787587f7169f/itag/34&itag=34 swfurl=http://s.ytimg.com/yt/swfbin/watch_as3-vflUXLhsZ.swf swfvfy=1 playpath=c2/id/fa51787587f7169f/itag/34?ptchn=4oDDocumentaries&ptk=channel4]
15:49:33 T:147783680 M:119926784  NOTICE: CDVDPlayer::OnExit()
15:49:33 T:147783680 M:119926784  NOTICE: CDVDPlayer::OnExit() deleting input stream

Seemingly wants a genuine Adobe flash player?

I include the full xbmc.log here (Pastebin).



Thanks
Andy
edit: i uninstalled xbmc, installed a fresh build and everything works! thx for your suport.


dreq Wrote:0k, i installed 2 night6ly builds 30.08 and 31.08 and now i caN search for videos but when i click them the xbmc stops responding and i have to kill it. i tried to login but i keep getting login failed. can you recomend a stable night build?

http://pastebin.com/2KG81gEe

thank you very much!

so i installed later a night build from 4.09 and everything worked just fine! only the volume up button wasnt working, so i installed 3.09 and then the youtube woujldnt work again. i went back to 4.09 and is not working either. any ideas?
hey guys,

quick question when clicking "queue folder"

i have a playlist set to sort by "rating"<------ closest thing i can get to shuffle songs

but when i click queue folder it skips songs in alphabetic order

any ideasHuh

thanks
  •   
  • 1
  • 84
  • 85
  • 86(current)
  • 87
  • 88
  • 315
  •   
  Thread Closed
 
Thread Rating:
  • 28 Vote(s) - 4.14 Average



Logout Mark Read Team Forum Stats Members Help
[depricated] old YouTube Plugin - XBMC 13.0 Frodo/Gotham only4.1428