• 1
  • 43
  • 44
  • 45(current)
  • 46
  • 47
  • 50
24p and audio sync issues
You know what's wierd that I've discovered.... I need 160ms delay for 24p material, but via UPnP I don't need any delay. I wonder why?
Reply
For the very same content you mean?
Reply
Yes. It's all streaming from the same NAS box. The TVs are near identical (one is the 55" version, one is 32" of the same Samsung model). And both a running on Lenovo Tiny M52 PCs with Intel graphics (one of which is a HDD clone of the other). It would be interesting to know if this is the same for anyone else that needs to apply a delay - do they have to apply the same delay if streaming via uPnP?
Reply
I also noticed that for 14.1 I needed even more delay (from -250ms to -425ms) but in 14.2 it seems that -250ms is enough again...

Strange...
Reply
(2014-11-13, 03:02)I Wrote: I've tested only briefly with a handful of files using SW decoding and PS renderer only, will test more in the next couple of days using different streams/files/decoding/rendering. So far, it looks like this is fixed, though.

Oops, completely forgot that...
For me, there's no difference in sync delay anymore, regardless whether using SW or DXVA decoding with PS, DXVA or DXVA-HD rendering, respectively. I don't think I ever tested using software rendering, though.

All specific tests at 24p using Helix (14.0/14.1/14.2). Delay needed with my setup is around 170ms for all frame rates (the difference between frame rates is negligible now).

So I can confirm that - at least for me - the issue is fixed.

This is with Win7 / Intel HD4600, True full screen, "Sync playback to display" enabled with method "Video clock (resample audio)".

There still is an issue with a/v sync, though, when the "missed vsync" counter keeps counting up, which unfortunately happens a lot with Helix. The only way I found to stop this is pausing playback for a couple of seconds, then resuming (sometimes several times in a row). So all of you who still have this issue, press "O" during playback and watch the "missed" counter in the last row. If it keeps counting up, pause/unpause playback until the counter stops.
Reply
I was recently advised to turn off the 'sync method' option rather than using video or audio clock and that solved some sync issues for me (and stuttering).
Reply
"Missed vsync" means: shitty and utterly broken driver - can you turn off AERO? Also make sure "Sync Playback to Display" only makes sense with "Resample Audio" _and_ passthrough completely disabled.
First decide what functions / features you expect from a system. Then decide for the hardware. Don't waste your money on crap.
Reply
(2015-04-02, 08:48)fritsch Wrote: "Missed vsync" means: shitty and utterly broken driver - can you turn off AERO?
Next time I'm talking to an Intel rep, I'll tell him "your drivers are shitty and utterly broken." Wink NOT. This used to work perfectly, but I don't remember at which point (read: which XBMC rev.) it stopped working. It's a Kodi issue, not a driver issue and I was actually planning to look into it before Helix release, but lacking the time, unfortunately. So I was hoping that any of the Isengard changes (e.g. afedchin's DX11 update) fixes it as a side effect.
As for turning off Aero, I can try and report - didn't think of that. Update: No change when disabling Aero.
Note that earlier builds did not show the "missed vsync" issue with Aero enabled or disabled, no matter. Again, talking about my box(es) only, as I understand that others were seeing the "missed" counter in action across all XBMC versions.
Quote:Also make sure "Sync Playback to Display" only makes sense with "Resample Audio" _and_ passthrough completely disabled.
I assume you mean "resample only works with passthrough disabled". Correct, did I say otherwise? As far as I could read from the PRs, this has finally been fixed in Isengard, ie. Isengard won't allow users to enable passthrough and resample at the same time. This is offtopic, though, since with passthrough enabled, Helix will just ignore the "sync to display" setting, causing stutter but not a/v desync, iirc.
Reply
I've added the delay in advancedsettings. It works fine but aren't you supposed to see the delay in the GUI somewhere, e.g. Codec Info? Never mind. I see it says "ad:-300"

I've tried using various audio sync videos, but they don't really work that good. Do people really find those files helpful? I can't really see much of a difference unless I do extreme delay/ahead changes. While if I use a video with people talking the difference between 0 delay and 300 ms is very noticeable. I've tried various 24p videos and they all seem to be synced at 300 ms, so it's not that the delay is different for every video.
Reply
I find nothing beats sound/video sycing than just watching dialogue and manually adjusting until correct.
Reply
Sorry to bring this thread back, but I wanted to mention that I am still having issues with 24fps content in the latest Isengard release. This issue only cropped up for me in XBMC releases close to the name switches and Kodi releases thereafter. I've been running the same hardware before the issue and now.

System Configuration is as follows:
Old NVidia ION2 + Intel Atom HTPC, hardware DXVA2 decoder for H264
Windows 7.1 32bit
Updated NVidia display and audio driver
Old 120hz Samsung TV piped through a Yamaha RX-V675 receiver ("auto-lipsync" off)
VSync and all graphics settings put to "Application Controlled"
Aero disabled & service disabled

Kodi Configuration:
1080p out w/no crop or overscan
Fullscreen window - Disabled (no difference when enabled)
Blank other displays - Disabled (no difference when enabled)
Vertical blank sync - Always Enabled (see below)
WASAPI over HDMI audio out (see below)
Stereo Upmix - Disabled
Passthrough enabled - WASAPI
All receiver codecs register as supported

Adjust display refresh rate - Always (see below)
Pause during rate change - 2.5s
Sync playback to display - Enabled
Render method - autodetect
Allow DXVA2

Test files:
Mix of MKV and MP4 containers, 480p-1080p which play smoothly, AC3, AAC, and MP3 audio. I do not have a DTS test file handy.

Hardware passthrough on AC3 bitstreamable file:
With that configuration, the delay sits right around 160-170ms behind. If I disable "Sync playback to display", it goes all the way to 500ms behind. Disabling "Vertical blank sync" seems to clear up the synchronization issue entirely, but then the screen tears badly (as expected). It improves regardless of any change to Sync playback, Fullscreen window, or Blank displays.

Software decoding:
Delay seems to be eliminated regardless of VSync status or Sync playback setting

When I try a similar test with my non-HTPC, a GTX670 + Intel [email protected], I get the same results. I do not think it is an issue with decoding speed or audio latency. The sync issue occurs exclusively when bitstreaming. While I acknowledge that reverting to software decoding fixes the issue, it sorta defeats the purpose of having a surround system and HTPC. Please let me know if I can provide any logs or feedback to help diagnose the issue. Thanks for developing Kodi!

edit: log file is here http://xbmclogs.com/pmoqdgpio - plays 4 files: 1-ac3 bitstream laggy, 2-software decode aac no issue, 3-ac3 bitstream laggy, 4-ac3 bitstream but vsync disabled so no lag
Reply
Hasn't gotten any better here, either. I resorted to adding the 250ms delay in the advanced settings file, like someone here mentioned they had done.
Reply
On most TVs, you will notice 24p having a roughly twice as high delay as e.g. 50p, just because of how the TV's picture enhancers work - it needs X frames for reference, which means roughly 2x time for 24p compared to 50p. If your TV has a game mode, try that - picture enhancers are usually completely off in game mode.

Note that auto-lipsync will not help with 24p delay issues, again because of the way it works. Auto-lipsync is a fixed (!) value in the TV's EDID, ie. it always reports the same, even if your TV actually has different delays for different frame rates.
Reply
Regarding picture enhancers: All of those features are turned off on my TV and it is in full-res PC mode. It is luckily an early enough model that a lot of the stuff that you see now in 120hz TVs isn't really even there. Considering that there is no delay when software decoding 24p content and there is delay when hardware decoding through the same receiver/TV, something else might be going on.
Reply
I realized that I never before tested using passthrough audio. So here you go:

I just re-tested using the same Kodi settings you posted above, except for rendering (DXVA-HD). Not tested with sync playback off or vsync off (useless settings).
Result: No issue. Delay stays the same, regardless whether using SW or DXVA decoding, audio passthrough (AC3) or decode (AAC) in Kodi 15.0 Isengard.

My hardware and OS setup for this box is completely different to yours, though (Win8.1x64, Intel G45 GPU using Win7 drivers, Denon AVR, Panasonic 100Hz TV 2013 model).

You might want to test with your 3770K's internal gfx to rule out an Nvidia issue.
Reply
  • 1
  • 43
  • 44
  • 45(current)
  • 46
  • 47
  • 50

Logout Mark Read Team Forum Stats Members Help
24p and audio sync issues8
This forum uses Lukasz Tkacz MyBB addons.