•  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 24
  • Next 
 
Thread Rating:
  • 7 Vote(s) - 5 Average
[RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC
#16
matiasw Wrote:Hello,
First, thank you, looks like a great plugin! Smile
I have a slight problem getting it to work, however. I am running XBMC version 2:10.00~svn33778-lucid1 on Ubuntu 10.04 (kernel 2.6.32-24). I have installed the plugin as per the instructions at http://code.google.com/p/vimeoxbmc/.
The error I get when trying to run it through Video -> Video Plugins is
"ERROR: Script Failed!: Vimeo"
xbmc.log has this (the only error):
"ERROR: Failed to create common scripts symlink."

Anyone have a clue what's going on? Smile

Hmm I'm a bit mystified by this it should just work, the only thing i can think of is wrong is that it's an internal xbmc problem. In any case, could you try removing the folder you created and using the install from zip option that's available in xbmc?

---- EDIT ----
Oh and a paste of the complete debug log would be nice Smile
Reply
#17
Oops! It looks like I forgot to update this thread. :o

Anyway, the issue was user error on my part.
I actually came here to post about Vimeo's new Couch Mode. The only things I'm actually missing from the XBMC addon compared to this are autoplay and support for the Watch Later queue. It would be awesome to have these features in some later revision of vimeoxbmc. I've looked at the source code, but I'm no python expert, so I don't know if I'll be any help - plus I've been having a lot to do, lately...

Anyway, thanks for the addon! Nod
Reply
#18
matiasw Wrote:Oops! It looks like I forgot to update this thread. :o

Anyway, the issue was user error on my part.
I actually came here to post about Vimeo's new Couch Mode. The only things I'm actually missing from the XBMC addon compared to this are autoplay and support for the Watch Later queue. It would be awesome to have these features in some later revision of vimeoxbmc. I've looked at the source code, but I'm no python expert, so I don't know if I'll be any help - plus I've been having a lot to do, lately...

Anyway, thanks for the addon! Nod

We're actually just finnishing off the plugin and gearing up for release into the repo, but I'll look into adding a "My Watch Later" on the plugin home screen before we release.

The auto play functionality is sadly limited by xbmc, the only way to achieve this is to play back an item and then queue up the folder, that way xbmc will add them to the current playlist and keep playing videos.
Reply
#19
HenrikDK Wrote:We're actually just finnishing off the plugin and gearing up for release into the repo, but I'll look into adding a "My Watch Later" on the plugin home screen before we release.

The auto play functionality is sadly limited by xbmc, the only way to achieve this is to play back an item and then queue up the folder, that way xbmc will add them to the current playlist and keep playing videos.

Awesome work guys, has this been released into the plugins for RC1 yet ?
4x ATV2's (v4.3) XBMC Frodo12.2. Raspberry Pi running MYSQL 5.5.31-0+wheezy1. NAS is a Drobo FS
Reply
#20
matbor Wrote:Awesome work guys, has this been released into the plugins for RC1 yet ?

Sadly no, I've discovered a bug with the vimeo api that will some times make the "my likes" feed return nothing. I've contacted vimeo about this but they have yet to answer and until I've gotten confirmation that this is a problem with vimeo's API, the plugin will probably remain unavailable from the repo (Im not very fond of releasing broken code Oo)
Reply
#21
I've installed this plugin and video plays back perfectly. I don't seem to be able to get it to show the logged in view though.

I get a successful login notification appear, and I can see it as an extension on vimeo.

Is this a known bug?
Reply
#22
jim0thy Wrote:I've installed this plugin and video plays back perfectly. I don't seem to be able to get it to show the logged in view though.

I get a successful login notification appear, and I can see it as an extension on vimeo.

Is this a known bug?

No it should just "work" (or at least it does for me), but a debug log with the plugins debug mode enabled would go along way to tell me if somethings wrong Smile
Reply
#23
Here's a debug log from today: http://pastebin.com/4q4UDDvN

Thanks for the help.
Reply
#24
jim0thy Wrote:Here's a debug log from today: http://pastebin.com/4q4UDDvN

Thanks for the help.

Hi jim0thy, That debug log doesn't really say anything went wrong. But I just remembered theres a section under settings that allow you to disable folders and i think there was a problem with it in the version you're running. could you try to disable enable some of the folders you're missing?

Im currently preparing a new version with better debug logging for release which will hopefully give me a better understanding of whats going on.
Reply
#25
Hi, thanks for the reply. I tried disabling/enabling a few folders but nothing happened.

The log file now has this though:

Code:
19:38:42 T:2838551408 M:1433710592  NOTICE: -->Python Interpreter Initialized<--
19:38:42 T:2838551408 M:1433710592  NOTICE: Vimeo-0.5.0 ARGV: ['plugin://plugin.video.vimeo.beta/', '1', '']
19:38:46 T:2838551408 M:1433354240  NOTICE: Vimeo-0.5.0 __init__
19:38:46 T:2838551408 M:1433354240  NOTICE: icon DefaultFolder.png
19:38:46 T:2838551408 M:1433354240  NOTICE: thumbnail explore
19:38:46 T:2838551408 M:1433354240  NOTICE: icon DefaultFolder.png
19:38:46 T:2838551408 M:1433354240  NOTICE: thumbnail search
19:38:46 T:3078702976 M:1433354240 WARNING: GetLabel - Unknown nodetype requested 6
19:38:46 T:3078702976 M:1433354240   ERROR: GetDirectory - Error getting plugin://plugin.video.vimeo.beta/?path=/root/login&action=settings&
19:38:46 T:3078702976 M:1433354240   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.vimeo.beta/?path=/root/login&action=settings&) failed
19:38:46 T:3078702976 M:1433354240 WARNING: GetLabel - Unknown nodetype requested 6
Reply
#26
Hello, Is it just me?... This add-on loads thumbnails, but doesn't seem to play videos. I think Vimeo may have changed things up a little, rather recently. Thanks for all of the hard work on the add-on, BTW (HenrickDK)... I absolutely love it!Nod
Reply
#27
remint Wrote:Hello, Is it just me?... This add-on loads thumbnails, but doesn't seem to play videos. I think Vimeo may have changed things up a little, rather recently. Thanks for all of the hard work on the add-on, BTW (HenrickDK)... I absolutely love it!Nod

Seems they're having playback problems with the site:
http://vimeo.com/forums/topic:32050
I myself can't access videos with firefox right now (although it is working from internet explorer), and since we're emulating firefox in the plugin it'll probably have the same problems.

---------------------- EDIT -----------------------
Ok I've had some time to look into it and you were right, vimeo has indeed rolled out a new backend and now serve up videos differently than before. I have already have a fix to restore playback and im working on releasing it tonight Smile
Reply
#28
New version available from the site, this one fixes the playback issue and adds a number of features and fixes. Changelog for this version:

Vimeo 0.6.0
- Replaced xml mini dom with BeautifulStoneSoup
- Searches would sometimes fail due to vimeo not honoring the invalid xml chars part of the xml spec.
- Cleaned up confusion over folder Settings, now every folder is default on.
- Added support for Vimeo's "My Watch Later", including adding and removing videos
- Downloads folder now accessible from plugin.
- Reworked view mode switch to correspond to youtube plugin.
Reply
#29
Hello,
FYI: Could not install the plugin.video.vimeo.beta-0.6.0.zip in XBMC on Vista OS. Tried "install from zip file", and XBMC said there was an error. I may have done something wrong, but just wanted to report it. Thanks!
Reply
#30
Installation from ZIP fails for me either (Win7 x86). New versions of Vimeo and Youtube plugins alike.
Reply
  •  Previous
  • 1
  • 2(current)
  • 3
  • 4
  • 5
  • 24
  • Next 



[RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC57