[LIVE] Suspend works only once then autoreumes even without remote
#1
I've been trying to track down an issue with suspend / wake from remote. Tried everything I could find without success. Then I discovered the suspend issue was happening even without the remote plugged in. "Suspend" seems to work the very first time it is used. It wakes up correctly, but the next time it tries to suspend then wakes up by itself.

I've tried with these iso's - and they all do it! (as downloaded and updated to a later kernel)

xbmc-Dharma_beta1-live.iso
xbmcfreak-10.00-svn33324.iso
xbmcfreak-10.08-svn32696-lucid1.iso
xbmc-9.11-live-repack.iso
OpenELEC-ION.i386-devel-20100910-r3938

Steps.
1 - Fresh boot
2 - Use keyboard to suspend
3 - Machine suspends fine for the first time.
4 - Resume from suspend with keyboard
5 - Select suspend again with keyboard
6 - Machine tries to suspend then immediately wakes again (auto resumes). Same thing happens using the idle shutdown timer in the GUI)

So this issue is NOT remote related.

Can someone please help me figure out was it going on. I've spent a week trying to resolve this. I'm using the 5Vdual USB jumper (the default one) on the M/b.

I"m running a ZOTAC IONITX-D-E Intel Atom N330 Dual Core 1.6 GHz NVIDIA ION M/b.

Here is a debug log of several suspends - first the one that works, then at least two that don't (the first suspend always works correctly after booting from scratch) http://pastebin.com/ABWAgAVK (not sure what iso it was from)

There is a setting in the bios that restores everything to factory settings - Still didn't work!

There is another bios setting for failsafe settings. With this set, suspend wouldn't work at all.

What do I do?? Eek

Thx
ZOTAC IONITX-D-E Intel Atom N330 Dual Core 1.6 GHz NVIDIA ION with LIVE on SSD
Reply
#2
Is there any useful information from dmesg (probably also echoed to /var/log/messages and/or /var/log/kern.log and/or /var/log/debug - dependent on your syslog settings - with more readable timestamping) about what's going on at kernel level, rather than from the xbmc.log at application level ?

In theory it should record what device/event actually caused the state change.
Reply
#3
kurai Wrote:Is there any useful information from dmesg (probably also echoed to /var/log/messages and/or /var/log/kern.log and/or /var/log/debug - dependent on your syslog settings - with more readable timestamping) about what's going on at kernel level, rather than from the xbmc.log at application level ?

In theory it should record what device/event actually caused the state change.

I'll track down how to use this command and see what it produces. Thx
ZOTAC IONITX-D-E Intel Atom N330 Dual Core 1.6 GHz NVIDIA ION with LIVE on SSD
Reply
#4
Seems like I've solved my issue.

Using the "dmesg" I spotted an issue
Code:
ACPI: resource nForce2_smbus [0x4e00-0x4e3f] conflicts with ACPI region SM00 [0x4e00-0x4e3f]

I'd read about this in this article http://wiki.xbmc.org/?title=HOW-TO_Insta...Autoresume along with the fix. I had found this article early on and had tried the fix many times without success. I found I was actually editing the wrong place in the grub file. There are two lines that show
Code:
GRUB_COMMAND_LINE_DEFAULT="quiet splash"
and I was editing the wrong one. The correct one to edit is the 2nd one - without the # in front of it (I saw the #, but wasn't sure what it meant - perhaps a comment??)

Also, the wiki article doesn't quite show exactly how to add the fix and use the correct syntax, because the line includes other commands. My resultant edit looked like this - and it fixes my suspend issue
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1 acpi_enforce_resources=lax xbmc=autostart,nodiskmount,setvolume loglevel=0 video=vesafb"

Okay...so to edit this file use
Code:
sudo pico /etc/default/grub

Scroll down and replace or alter the above line. Then crtl x, "Y" then enter.

Then type

Code:
sudo update-grub


This post also helped, and really showed me that my issue was the same http://ubuntuforums.org/showthread.php?t=1359382

Now I am able to suspend the box as it should work.

Man....I've got a major buzz from getting it to work Laugh
ZOTAC IONITX-D-E Intel Atom N330 Dual Core 1.6 GHz NVIDIA ION with LIVE on SSD
Reply
#5
KidKiwi Wrote:I saw the #, but wasn't sure what it meant - perhaps a comment??

Yep, exactly. A # at the start of a line in a script/conf file comments it out.

KidKiwi Wrote:Man....I've got a major buzz from getting it to work Laugh
Congrats Big Grin
Reply
#6
THANK YOU!

I've been looking everywhere for a solution to this problem. Thanks so much for not only finding it but posting exactly how to fix it. Very much appreciated!
Reply
#7
Could you put [SOLVED] in your thread description
Media Companion Dev.
Media Companion - Kodi / XBMC - Media Companion
Reply



Logout Mark Read Team Forum Stats Members Help
[LIVE] Suspend works only once then autoreumes even without remote0
This forum uses Lukasz Tkacz MyBB addons.