Dropped frames / choppy playback of Discovery HD-TV-shows
#1
Hi,

unfortunately I can not properly play TV shows from Discovery HD (german). Playback is very choppy once in a while.

Material is 1080i 50Hz, H.264. I have generated a XBMC-log file and a mediainfo file of the ts-file played while generating the log.

http://dl.dropbox.com/u/7782292/S06E09.txt
http://dl.dropbox.com/u/7782292/xbmc.log

My Setup: Mini 2010, 10.6.3, Video / Audio via HDMI.

Does anyone have an ideas what the reason might be? If have tons of files in exactly this format, and it would be great to play them via XBMC.

BTW, HW acceleration is switched off (when switched to on with those kind of files, XBMC crashes right at the beginning of playback).

Thanks in advance,

Chris
Reply
#2
ix400 Wrote:Hi,

unfortunately I can not properly play TV shows from Discovery HD (german). Playback is very choppy once in a while.

Material is 1080i 50Hz, H.264. I have generated a XBMC-log file and a mediainfo file of the ts-file played while generating the log.

http://dl.dropbox.com/u/7782292/S06E09.txt
http://dl.dropbox.com/u/7782292/xbmc.log

My Setup: Mini 2010, 10.6.3, Video / Audio via HDMI.

Does anyone have an ideas what the reason might be? If have tons of files in exactly this format, and it would be great to play them via XBMC.

BTW, HW acceleration is switched off (when switched to on with those kind of files, XBMC crashes right at the beginning of playback).

Thanks in advance,

Chris

I had the idea to re-encode the file mentioned in my last post with handbrake. For that purpose I used the following handbrake settings (I linked a screenshot):

http://dl.dropbox.com/u/7782292/handbrake_settings.tiff

Interestingly, the re-encoded mkv shows the same "choppy behavior" than the original file! Loads of dropped frames.

But here it comes: With the newly encoded file I can turn on the hardware accelaration without XBMC crashing when I start playback of this file. As I posted above, the original file caused an XBMC crash when playback was started with HW accelaration.

Here is the mediainfo of the new file:

http://dl.dropbox.com/u/7782292/S06E10_recoded_mkv.txt

How can this be? Isn't that really strange?

It will take me ages to re-encode all the TV shows I have recorded...

Cheers,

Chris
Reply
#3
ix400 Wrote:I had the idea to re-encode the file mentioned in my last post with handbrake. For that purpose I used the following handbrake settings (I linked a screenshot):

http://dl.dropbox.com/u/7782292/handbrake_settings.tiff

Interestingly, the re-encoded mkv shows the same "choppy behavior" than the original file! Loads of dropped frames.

But here it comes: With the newly encoded file I can turn on the hardware accelaration without XBMC crashing when I start playback of this file. As I posted above, the original file caused an XBMC crash when playback was started with HW accelaration.

Here is the mediainfo of the new file:

http://dl.dropbox.com/u/7782292/S06E10_recoded_mkv.txt

How can this be? Isn't that really strange?

It will take me ages to re-encode all the TV shows I have recorded...

Cheers,

Chris

Do you even look at the MediaInfo details ? Smile The big diff, Interlaced -> Progressive. VDA Decoder does not handle Interlaced Content.
Reply
#4
... yep I saw this.

Do you have an idea why the original, interlaced file can't be played properly? Is there any hint in the mediainfo and log file from my first post?

Chris
Reply
#5
ix400 Wrote:... yep I saw this.

Do you have an idea why the original, interlaced file can't be played properly? Is there any hint in the mediainfo and log file from my first post?

Chris

1920x1080. framerate: 25.00 interlaced. Depending on de-interlace method -> 50fps.

WARNING: Decode - avcodec_decode_video didn't consume the full packet. size: 29398, consumed: 0

Bet your CPU usage is near 200 percent. You are CPU bound. Try different de-interlace methods.
Reply
#6
davilla Wrote:1920x1080. framerate: 25.00 interlaced. Depending on de-interlace method -> 50fps.

WARNING: Decode - avcodec_decode_video didn't consume the full packet. size: 29398, consumed: 0

Bet your CPU usage is near 200 percent. You are CPU bound. Try different de-interlace methods.

mmh, I did set the deinterlacing to 'off' whe I was testing.

Got to check different settings.

Thanks,

Chris
Reply
#7
ix400 Wrote:mmh, I did set the deinterlacing to 'off' whe I was testing.

Got to check different settings.

Thanks,

Chris

Okay, I did some tests with the de-interlacing settings. It seems that the problem is not connected to the deinterlacing settings. And the CPU load is always way below 200%.

Would it help if I load a little demo file on my iDisk?

Thanks,

Chris
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
Dropped frames / choppy playback of Discovery HD-TV-shows00