[RELEASE] YouJizz.com Plugin (Adult Content)
#1
Thumbs Up 
I saw a plugin request for this site a while back. So here it is. This is my first attempt at any plugin development. Thanks to wonderful tutorial by Voinage and some code borrowed from the Tube8 plugin. Please post bugs if you see any. Thanks.

http://www.mediafire.com/?ztp5y8k8zar4q90
Reply
#2
lazyguy Wrote:I saw a plugin request for this site a while back. So here it is. This is my first attempt at any plugin development. Thanks to wonderful tutorial by Voinage and some code borrowed from the Tube8 plugin. Please post bugs if you see any. Thanks.

http://www.mediafire.com/?ztp5y8k8zar4q90

I put this in my video plugin folder and it did not do anything. Does this work on 9.11 or only the new release on dharma?
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#3
i can confirm with rflores2323 that the plugin/addon does not function however, it is because it is missing critical files for the new addon framework.
I've been attempting to bring a script i use back to life, so im learning from scratch myself.

looks like youve done the hard work on the addon, you just have to add a few files, addon.xml etc.. and change the format (i.e name the parent folder plugin.video.you.jizz and zip the parent folder and all the content. use a lowercase "D" on default.py, linux is very touchy to caselettering)
im not too keen on plugins but im learning scripts pretty well.
Reply
#4
just to give you a heads up this is what you need to have make a text doc call it addon.xml and put this into it
philw132 Wrote:<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<addon id="plugin.video.you.jizz"
name="YouJizz.com"
version="1.0.0"
provider-name="Pillager">
<requires>
<import addon="xbmc.python" version="1.0"/>
</requires>
<extension point="xbmc.python.pluginsource"
library="default.py">
<provides>video</provides>
</extension>
<extension point="xbmc.addon.metadata">
<platform>all</platform>
<license>GPL 2.0</license>
<summary lang="en">YouJizz.com</summary>
<description lang="en">****ADULT CONTENT***** Watch Content from YouJizz.com</description>
</extension>
</addon>
now also add this to the header of your default.py file
philw132 Wrote:__scriptname__ = "YouJizz.com"
__author__ = "Pillager"
__url__ = "http://www.mediafire.com/?ztp5y8k8zar4q90"
__scriptid__ = "plugin.video.you.jizz"
__credits__ = "Pillager"
__version__ = "1.0.0"
I would also make a changelog.txt file to include a brief change description such as
philw132 Wrote:1.0.0
- Initial release
I'm not sure if its required for the plugin to work, but i believe its a requirement for an addon for submittion that the GPL license txt included in all scripts/plugins/addons
but if it is, get a copy and call it license.txt

I was able to get functionally after the changes I've made to the plugin, I am using Dharma beta 2 installed livecd.

remember zip up the parent folder and call the zip plugin.video.you.jizz.zip

hope this helps you on your first attempt! good job, I tested a few videos and i can confirm that they do play and the plugin does load and function now.
Reply
#5
philw132 Wrote:just to give you a heads up this is what you need to have make a text doc call it addon.xml and put this into it

now also add this to the header of your default.py file

I would also make a changelog.txt file to include a brief change description such as

I'm not sure if its required for the plugin to work, but i believe its a requirement for an addon for submittion that the GPL license txt included in all scripts/plugins/addons
but if it is, get a copy and call it license.txt

I was able to get functionally after the changes I've made to the plugin, I am using Dharma beta 2 installed livecd.

remember zip up the parent folder and call the zip plugin.video.you.jizz.zip

hope this helps you on your first attempt! good job, I tested a few videos and i can confirm that they do play and the plugin does load and function now.

can you upload your file?
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#6
Thank you phil for your input.

I must admit, I have not played with the latest cutting edge of xbmc. I am at the moment quite content with the older release on my apple tv. This addon feature is completely new to me.

If you could upload what you have gathered, that would help many of the addon users. Again appreciate your help.
Reply
#7
Sure, not a problem. I'm at work at the moment but once I get home ill upload a file for you to use.
I THINK these changes will not affect the older versions. Ill install it on my win7 laptop its running an older version of xbmc. If it runs you should be able to use it in older and newer releases as you see fit.

I've worked hard to redo some OLD scripts made for the xbox so I've learned a little about the new addon system. Its a good challenge Smile

Ill post when I get home.

Phil

lazyguy Wrote:Thank you phil for your input.

I must admit, I have not played with the latest cutting edge of xbmc. I am at the moment quite content with the older release on my apple tv. This addon feature is completely new to me.

If you could upload what you have gathered, that would help many of the addon users. Again appreciate your help.
Reply
#8
As promised, here is the link. it is configured for xbmc 10.0's new addon system however i tested it out on 9.11 and it is compatible, just change the foldername.

http://www.mediafire.com/?pyf52wmxjius5dr

rflores2323 Wrote:I put this in my video plugin folder and it did not do anything. Does this work on 9.11 or only the new release on dharma?
Reply
#9
great works for me. thanks alot.
ATV1 with crystalbuntu (12.2 frodo) as main theater. Theater remote URC MX-810, droidx with xbmc remote, or transformer tf101 with YATSE. 3 x ATV2 (V12.2 frodo).

Reply
#10
Hey, great plugin. Thanks. One downside is it seems to buffer allot....play....then buffer allot more? Anyway, great job
Reply
#11
this plugin and small updates can be found on the new xbmc-adult repository, which is listed on the Unofficial Repositories wiki page
Reply
#12
is this plugin working for anyone?
Reply
#13
Yes, but it needed some fixes...
Reply
#14
You mean it needs or "it needed" some fixes? Is it working now? In any case, FYI...there is a working version on DevilSteam. Cheers!
Reply
#15
Working fine get it from xbmc-adult
Reply
 
Thread Rating:
  • 1 Vote(s) - 5 Average



Logout Mark Read Team Forum Stats Members Help
[RELEASE] YouJizz.com Plugin (Adult Content)51