[LINUX] HOW-TO to use iMON Remote on Ubuntu 10.10 with Linux input layer on Harmony
#16
bsneaker Wrote:this method not works for me.
My usb-devices:
T: Bus=01 Lev=02 Prnt=04 Port=03 Cnt=01 Dev#= 6 Spd=1.5 MxCh= 0
D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=15c2 ProdID=0042 Rev=00.02
C: #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=00 Prot=02 Driver=lirc_imon
I: If#= 1 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=00 Prot=00 Driver=lirc_imon
My lsusb:
Bus 001 Device 006: ID 15c2:0042 SoundGraph Inc.

Device:IR Antec Veris Multimedia Station E-Z.

The original method it works with IMON Harmony config. but one keypress triggers a neverending cycle of keypresses.

Any Idea?

Help please.

Thx.
Ubuntu 10.10 wasn't working out for me, I had too many problems getting everything working. I switched back to Windows and now I am using XBMC Live, which has none of the problems I encountered on Maverick. So I can't be of any help, sry.
Reply
#17
First sorry for may bad English.

I use htpc with xbmc fronted with imon knob receiver and controlled by logitech harmony. I had 10.04 ubuntu but when I changed my old hdd to an ssd and I upgraded to 10.10 and after the lirc didn't work anymore. I have read about the new method of the lirc and I used lyka-as post (thanks for it) with successfully. Everything is worked well but it remains two big problem. The remote is in mouse mode after I started my htpc. I can change it to remote mode with the from button of the remote but I don't know how can to disable the mouse mode or how can set to default the remote mode. The default mode after the boot is always in mouse. It's very frustrating. The bigger problem is the key repetition. When I press a button (mainly the select) the key press causes accidentally never-ending cycle of key presses. I can stop with a new key pressing but It's extremely annoying.

Could somebody help me in that, please!
Reply
#18
Hey!

Quote:The remote is in mouse mode after I started my htpc.
I am experiencing exactly the same issue. Unfortunately I ve no idea what to do against than press the button to toggle between mouse and keyboard mode... Oo

Quote:The bigger problem is the key repetition
Luckily this happens to me very rarely only. My remote is a Antec Veris RM200 and I am using linux input layer with lirc.
Reply
#19
What do you think that two problems might be fixed in the future?

I am thinking of the unlimited key-press repetition and the unnecessary mouse mode.
Reply
#20
bodhidarma Wrote:What do you think that two problems might be fixed in the future?

I am thinking of the unlimited key-press repetition and the unnecessary mouse mode.

It have been working before they implemented imon driver to the ubuntu kernel. So i dont see the problem in a hopefully bright future.

As for the mouse toggle. I have lost my Imon remote so my harmoy 525 is the only remote i have right now Sad

There must be script somewhere or could be made that change the mouse pad to key presses if you can change it from the remote.
Reply
#21
8301 Wrote:It have been working before they implemented imon driver to the ubuntu kernel. So i dont see the problem in a hopefully bright future.

Do the lirc devs know about this problem?
Reply
#22
Ok, another question: Has anybody tried if this problem can be resolved by using the 2.6.37 kernel (which seemed to be quite stable to me)?
Reply
#23
I've been trying around some more, and may have something working.

First, I followed the first post of this thread.

Then I compiled the ir-keytable tool from git, as suggested here for an older version:

Code:
cd /usr/local/src
git clone http://linuxtv.org/git/v4l-utils.git
cd v4l-utils
make
cd utils/keytable
cp ir-keytable /usr/local/bin/
cp rc_keymaps /etc/

Afterwards, I ran the following commands to set the imon driver to MCE mode (as suggested here:

Code:
ir-keytable -p rc6 -w /etc/rc_keymaps/imon_mce
echo rc6 > /sys/class/rc/rc0/protocols

Now, I do get some readings with irw when I press keys on my Harmony One, which is configured as an MCE-1039. (Some keys don't yet produce results - Menu, Exit, Info, Guide, Play, Record, ... -, but I'll be looking into that later. The directions keys and Ok are working, which is quite good for a start.)

By the way, if there should still be an error with endless key repeats, there was a solution suggested by Dan Chase on the lirc mailinglist:

Code:
ir-keytable -D 150 -P 250

All of this would get me to the following commands in rc.local:

Code:
modprobe imon
ir-keytable -p rc6 -w /etc/rc_keymaps/imon_mce -D 150 -P 250
echo rc6 > /sys/class/rc/rc0/protocols
Reply
#24
I just updated to the 2.6.38 kernel and the repeating key issue is fixed.

My harmony remote and imon receiver are working perfectly now using the devinput driver.

No more need for workarounds or blacklisting.

Here is the relevant section of my hardware.conf:
Code:
#Chosen Remote Control
REMOTE="Linux input layer (/dev/input/eventX)"
REMOTE_MODULES="lirc_dev"
REMOTE_DRIVER="devinput"
REMOTE_DEVICE="/dev/input/event7"
REMOTE_SOCKET=""
REMOTE_LIRCD_CONF="/etc/lirc/lircd.conf.devinput"
REMOTE_LIRCD_ARGS=""
Reply
#25
Do you have the Harmony One configured as MCE and working?

If so, that's where I am with the 2.6.35 kernel as well, but I'm having difficulties finding a setting which recognizes all of the MCE keys. Direction keys, Ok and the numbers are working (irw recognizes them), but, e.g., Play and Stop are not (irw does not show any result if I press these keys).

So if you have the MCE setup, could you please let me know (a) how you configured your Harmony One as MCE, and (b) which file you use to have irw & co. recognize all keypresses?

Thanks.
Reply
#26
And how do we update to this kernel?
Reply
#27
SwedishGojira Wrote:And how do we update to this kernel?

easiest way is to download from here and install the debs, or wait a month for natty to be released
Reply
#28
Hammi Wrote:Do you have the Harmony One configured as MCE and working?

If so, that's where I am with the 2.6.35 kernel as well, but I'm having difficulties finding a setting which recognizes all of the MCE keys. Direction keys, Ok and the numbers are working (irw recognizes them), but, e.g., Play and Stop are not (irw does not show any result if I press these keys).

So if you have the MCE setup, could you please let me know (a) how you configured your Harmony One as MCE, and (b) which file you use to have irw & co. recognize all keypresses?

Thanks.

I was getting the same thing with direction buttons working in XBMC but no irw response at all until i setup my hardware.conf to use the devinput driver.

Essentially I followed lyka's instructions in the original post, and then added the entry for devinput.
Reply
#29
proctor Wrote:I was getting the same thing with direction buttons working in XBMC but no irw response at all until i setup my hardware.conf to use the devinput driver.

Essentially I followed lyka's instructions in the original post, and then added the entry for devinput.

I also started with lyka's approach. That left me with the following hardware.conf, which I think is identical to what you're proposing, except for the fact that "REMOTE_MODULES" is empty here (or am I missing something?):

Code:
# /etc/lirc/hardware.conf
#
#Chosen Remote Control
REMOTE="Linux input layer (/dev/input/eventX)"
REMOTE_MODULES=""
REMOTE_DRIVER="devinput"
REMOTE_DEVICE="/dev/input/event3"
REMOTE_SOCKET=""
REMOTE_LIRCD_CONF="devinput/lircd.conf.devinput"
REMOTE_LIRCD_ARGS=""

#Chosen IR Transmitter
TRANSMITTER="None"
TRANSMITTER_MODULES=""
TRANSMITTER_DRIVER=""
TRANSMITTER_DEVICE=""
TRANSMITTER_SOCKET=""
TRANSMITTER_LIRCD_CONF=""
TRANSMITTER_LIRCD_ARGS=""

#Enable lircd
START_LIRCD="true"

#Don't start lircmd even if there seems to be a good config file
#START_LIRCMD="false"

#Try to load appropriate kernel modules
LOAD_MODULES="true"

# Default configuration files for your hardware if any
LIRCMD_CONF=""

#Forcing noninteractive reconfiguration
#If lirc is to be reconfigured by an external application
#that doesn't have a debconf frontend available, the noninteractive
#frontend can be invoked and set to parse REMOTE and TRANSMITTER
#It will then populate all other variables without any user input
#If you would like to configure lirc via standard methods, be sure
#to leave this set to "false"
FORCE_NONINTERACTIVE_RECONFIGURATION="false"
START_LIRCMD=""

Thereafter, I just compiled ir-keymap from git and ran it to enable MCE mode.

I tried to change REMOTE_MODULES as suggested by you - and now, irw does not get any readings anymore with plain imon setup, even if I change it back to what I had before and reboot the machine...?! With imon switched to MCE mode, I still have the problem of only a few key being recognized.
Reply
#30
Also make sure your "devinput/lircd.conf.devinput" file exists.

Mine was located in a different place.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[LINUX] HOW-TO to use iMON Remote on Ubuntu 10.10 with Linux input layer on Harmony00
This forum uses Lukasz Tkacz MyBB addons.