[LINUX] HOW-TO to use iMON Remote on Ubuntu 10.10 with Linux input layer on Harmony
#31
simply use my config files!
I have to use no other USB device while booting on my HTPC!

Does anybody know how to set the KeyMode to default. My Remote is always MouseMode so i have to press the key above the joystick once...

1. stop lirc:

sudo /etc/init.d/lirc stop

then

etc/lirc/hardware.conf
Quote:# /etc/lirc/hardware.conf
#
#Chosen Remote Control
REMOTE="devinput/event4"
REMOTE_MODULES="lirc_dev"
REMOTE_DRIVER="devinput"
#REMOTE_DEVICE="/dev/lirc0"
REMOTE_DEVICE="/dev/input/event2"
REMOTE_SOCKET=""
REMOTE_LIRCD_CONF="/usr/share/lirc/remotes/devinput/lircd.conf.devinput"
REMOTE_LIRCD_ARGS=""

#Chosen IR Transmitter
TRANSMITTER="None"
TRANSMITTER_MODULES=""
TRANSMITTER_DRIVER=""
TRANSMITTER_DEVICE=""
TRANSMITTER_SOCKET=""
TRANSMITTER_LIRCD_CONF=""
TRANSMITTER_LIRCD_ARGS=""

#Enable lircd
START_LIRCD="true"

#Don't start lircmd even if there seems to be a good config file
#START_LIRCMD="false"

#Try to load appropriate kernel modules
LOAD_MODULES="true"

# Default configuration files for your hardware if any
LIRCMD_CONF=""

#Forcing noninteractive reconfiguration
#If lirc is to be reconfigured by an external application
#that doesn't have a debconf frontend available, the noninteractive
#frontend can be invoked and set to parse REMOTE and TRANSMITTER
#It will then populate all other variables without any user input
#If you would like to configure lirc via standard methods, be sure
#to leave this set to "false"
FORCE_NONINTERACTIVE_RECONFIGURATION="false"
START_LIRCMD=""

/etc/lirc/lircd.conf

Quote:#This configuration has been automatically generated via the Ubuntu LIRC
#package maintainer scripts.
#
#It includes the default configuration for the remote and/or transmitter
#that you have selected during package installation.
#
#Feel free to add any custom remotes to the configuration via additional
#include directives or below the existing Ubuntu include directives from
#your selected remote and/or transmitter. Configuration for the
#Soundgraph iMON PAD IR/VFD remote:
include "/usr/share/lirc/remotes/devinput/lircd.conf.devinput"

and .xbmc/userdata/Lircmap.xml

Quote:<lircmap>
<remote device="devinput">
<power>KEY_POWER</power>
<record>KEY_RECORD</record>
<play>KEY_PLAY</play>
<!--SlowMotion-->
<reverse>KEY_REWIND</reverse>
<pause>KEY_PAUSE</pause>
<forward>KEY_FASTFORWARD</forward>
<skipminus>KEY_PREVIOUS</skipminus>
<stop>KEY_STOP</stop>
<skipplus>KEY_NEXT</skipplus>
<back>KEY_BACKSPACE</back>
<select>KEY_ZOOM</select>
<menu>KEY_CONTEXT_MENU</menu>
<title>KEY_COMPOSE</title>
<!--LeftClick
RightClick-->
<select>KEY_ENTER</select>
<down>KEY_DOWN</down>
<left>KEY_LEFT</left>
<up>KEY_UP</up>
<right>KEY_RIGHT</right>
<clear>KEY_ESC</clear>
<obc1>KEY_DASHBOARD</obc1>
<!--AppLauncher-->
<info>KEY_PROG1</info>
<!--TaskSwitcher-->
<mute>KEY_MUTE</mute>
<volumeplus>KEY_VOLUMEUP</volumeplus>
<volumeminus>KEY_VOLUMEDOWN</volumeminus>
<channelplus>KEY_CHANNELUP</channelplus>
<channelminus>KEY_CHANNELDOWN</channelminus>
<!--Timer-->
<one>KEY_NUMERIC_1</one>
<two>KEY_NUMERIC_2</two>
<three>KEY_NUMERIC_3</three>
<four>KEY_NUMERIC_4</four>
<five>KEY_NUMERIC_5</five>
<six>KEY_NUMERIC_6</six>
<seven>KEY_NUMERIC_7</seven>
<eight>KEY_NUMERIC_8</eight>
<nine>KEY_NUMERIC_9</nine>
<star>KEY_NUMERIC_STAR</star>
<zero>KEY_NUMERIC_0</zero>
<hash>KEY_NUMERIC_POUND</hash>
<myvideo>KEY_VIDEO</myvideo>
<mymusic>KEY_AUDIO</mymusic>
<mypictures>KEY_CAMERA</mypictures>
<myTV>KEY_TV</myTV>
<!--Bookmark
Thumbnail
AspectRatio-->
<display>KEY_SCREEN</display>
<!--MyDVD-->
<menu>KEY_MENU</menu>
<subtitle>KEY_SUBTITLE</subtitle>
<language>KEY_LANGUAGE</language>
</remote>
</lircmap>
Reply
#32
Krautmaster Wrote:Does anybody know how to set the KeyMode to default. My Remote is always MouseMode so i have to press the key above the joystick once...

Compile the imon module from git. That fixes this problem (and the repeating/stuck key presses).
Reply
#33
Sorry, but what does it mean to
Quote: Compile the imon module from git.
Blush
Reply
#34
Hi - this link might help you.
Reply
#35
where can we find the imon module on git?
Reply
#36
imon is in the v4l-dvb code.

See the link I posted above for how to get it.
Reply
#37
Omigod that really did fix the mouse/keyboard issue with imon. Thank you Hammi!!!!!!!LaughBig GrinLaugh
Reply
#38
Thumbs Up 
Thank you very much lyka

with your first post you helped me a great deal!Big Grin
Reply
#39
Hallo guys,

especially with the help of lyka, toddwv and krautmaster I got it work with ubuntu 11.04 and kernel 2.6.38-10.

I posted the complete solution in the following post:

http://forum.xbmc.org/showpost.php?p=853616&postcount=2

Many thanks.

Greetings

Hoppel
Reply
#40
hi there. I tried to fix my double command problem with building these new modules.

My hardware.conf looks like:

Quote:# /etc/lirc/hardware.conf
#
#Chosen Remote Control
REMOTE="Soundgraph iMON Antec Veris"
REMOTE_MODULES="lirc_dev lirc_imon"
REMOTE_DRIVER=""
REMOTE_DEVICE="/dev/lirc0"
REMOTE_SOCKET=""
REMOTE_LIRCD_CONF="imon/lircd.conf.imon-antec-veris"
REMOTE_LIRCD_ARGS=""

#Chosen IR Transmitter
TRANSMITTER="None"
TRANSMITTER_MODULES=""
TRANSMITTER_DRIVER=""
TRANSMITTER_DEVICE=""
TRANSMITTER_SOCKET=""
TRANSMITTER_LIRCD_CONF=""
TRANSMITTER_LIRCD_ARGS=""

#Enable lircd
START_LIRCD="true"

#Don't start lircmd even if there seems to be a good config file
#START_LIRCMD="false"

#Try to load appropriate kernel modules
LOAD_MODULES="true"

# Default configuration files for your hardware if any
LIRCMD_CONF=""

#Forcing noninteractive reconfiguration
#If lirc is to be reconfigured by an external application
#that doesn't have a debconf frontend available, the noninteractive
#frontend can be invoked and set to parse REMOTE and TRANSMITTER
#It will then populate all other variables without any user input
#If you would like to configure lirc via standard methods, be sure
#to leave this set to "false"
FORCE_NONINTERACTIVE_RECONFIGURATION="false"
START_LIRCMD=""

it works so far but a few commands are recognized by 4 times.

Quote:[email protected]:/home/xbmc# irw
0100800000000201 00 KEY_UP Antec_Veris_RM200
01007f0000000201 00 KEY_DOWN Antec_Veris_RM200
0100007f00000201 00 KEY_RIGHT Antec_Veris_RM200
0100008000000201 00 KEY_LEFT Antec_Veris_RM200
0200006500000201 00 RightMenu Antec_Veris_RM200
0200006500000201 01 RightMenu Antec_Veris_RM200
0200006500000201 02 RightMenu Antec_Veris_RM200
0200006500000201 03 RightMenu Antec_Veris_RM200
29a595b700000201 00 Zoom Antec_Veris_RM200
29a595b700000201 01 Zoom Antec_Veris_RM200
29a595b700000201 02 Zoom Antec_Veris_RM200
29a595b700000201 03 Zoom Antec_Veris_RM200
2ab715b700000201 00 Thumbnail Antec_Veris_RM200
2ab715b700000201 01 Thumbnail Antec_Veris_RM200
2ab715b700000201 02 Thumbnail Antec_Veris_RM200
2ab715b700000201 03 Thumbnail Antec_Veris_RM200
289395b700000201 00 KEY_CHANNELUP Antec_Veris_RM200
289395b700000201 01 KEY_CHANNELUP Antec_Veris_RM200
289395b700000201 02 KEY_CHANNELUP Antec_Veris_RM200
289395b700000201 03 KEY_CHANNELUP Antec_Veris_RM200
0200002c00000201 00 KEY_SELECT Antec_Veris_RM200
0200002c00000201 01 KEY_SELECT Antec_Veris_RM200
0200002c00000201 02 KEY_SELECT Antec_Veris_RM200
01007f0000000201 00 KEY_DOWN Antec_Veris_RM200
0100007f00000201 00 KEY_RIGHT Antec_Veris_RM200
01007f0000000201 00 KEY_DOWN Antec_Veris_RM200

i increased the signal time in my harmony one configuration else some keys were not recognized.
The build of the new modules worked but lirc does not work any more then. I have to purge

lirc-modules-source & lirc and reinstall again to get it working again.

Any ideas how to fix that?
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[LINUX] HOW-TO to use iMON Remote on Ubuntu 10.10 with Linux input layer on Harmony00