[LINUX] Problems with playercorefactory
#1
Hello, I am trying to add Firefox to my PlayerCoreFactory file, but it is not working :S

PS, i have gotten xpdf to work...
here is my code:

playercorefactory.xml
Code:
<playercorefactory>
  <players>
    <player name="Acrobat" type="ExternalPlayer">
     <filename>xpdf</filename>
     <args>-fullscreen "{1}"</args>
     <hidexbmc>true</hidexbmc>
     <hideconsole>true</hideconsole>
     <warpcursor>none</warpcursor>
    </player>
    <player name="WWW" type="ExternalPlayer">
     <filename>firefox</filename>
     <args>-fullscreen "{1}"</args>
     <hidexbmc>true</hidexbmc>
     <hideconsole>false</hideconsole>
     <warpcursor>none</warpcursor>
    </player>
  </players>

  <rules action="prepend">
    <rule name="pdf" filetypes="pdf" player="Acrobat" />
    <rule name="htm" filetypes="htm" player="WWW" />
    <rule name="txt" filetypes="txt" player="WWW" />
  </rules>
</playercorefactory>
advancedsettings.xml
Code:
<advancedsettings>
  <videoextensions>
    <add>.pdf</add>
    <add>.txt</add>
    <add>.htm</add>
  </videoextensions>
</advancedsettings>

Neither .txt or .htm is found when browsing the library(pdf works... )

ps. in the xbmc.log I found this: (and it seems it should work ... )
Code:
20:52:05 T:3078420352 M:725676032  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
20:52:05 T:3078420352 M:725676032  NOTICE: Loaded playercorefactory configuration
20:52:05 T:3078420352 M:725676032  NOTICE: Loading player core factory settings from special://profile/playercorefactory.xml.
20:52:05 T:3078420352 M:725676032  NOTICE: Loaded playercorefactory configuration
20:52:05 T:3078420352 M:725676032  NOTICE: Loaded advancedsettings.xml from special://profile/advancedsettings.xml
20:52:05 T:3078420352 M:725676032  NOTICE: Contents of special://profile/advancedsettings.xml are...
                                            <advancedsettings>
                                              <videoextensions>
                                                <add>.pdf</add>
                                                <add>.txt</add>
                                                <add>.htm</add>
                                              </videoextensions>
                                            </advancedsettings>

What am I doing wrong??

PS. i have doubled checked the folders and files many times Tongue
Reply
#2
bump

Is this the wrong under-forum or something?( If so, could someone please move it? )
Reply
#3
try <add>.pdf|.txt|.htm</add>
Reply
#4
Thanx, that worked like a charm Wink
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
[LINUX] Problems with playercorefactory00