•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 8
  •   
[VBS/Pitchfork/Crunchyroll] maruchan addons repository
#61
You need a GIT build of librtmp for this to work: they upgraded security on the streaming servers at a lot of websites, including Crunchyroll. The new version has support for the new requirements.
Reply
#62
I did that, and still it still didn't work. I checked the log, and found I did log in, get the sub, ect. However, right before the movie was to play, it did a handshake that failed.

Code:
16:12:00 T:2894031728 M:396926976    INFO: RTMP_Connect1, ... connected, handshaking
16:12:00 T:2894031728 M:396926976    INFO: HandShake: Client type: 06
16:12:00 T:2894031728 M:396926976    INFO: HandShake: DH pubkey position: 259
16:12:00 T:3079243648 M:396926976   DEBUG: ------ Window Init (DialogBusy.xml) ------
16:12:00 T:2894031728 M:397271040    INFO: HandShake: Client digest offset: 1258
16:12:00 T:2894031728 M:397271040    INFO: HandShake: Initial client digest:
16:12:00 T:2894031728 M:397271040    INFO: 3d 48 03 da 04 0c 3c 3d 6e 68 fe af f5 cd a4 bb
16:12:00 T:2894031728 M:397271040    INFO: 41 bf e4 8d ff 4b d7 33 3e e4 15 a0 cf 7c 51 33
16:12:00 T:2894031728 M:        0    INFO: HandShake: Type Answer   : 09
16:12:00 T:2894031728 M:397271040 WARNING: HandShake: Type mismatch: client sent 6, server answered 9
16:12:00 T:2894031728 M:397271040    INFO: HandShake: Server Uptime : 189928892
16:12:00 T:2894031728 M:397271040    INFO: HandShake: FMS Version   : 4.0.2.1
16:12:00 T:2894031728 M:397271040    INFO: HandShake: Server DH public key offset: 403
16:12:00 T:2894031728 M:397271040    INFO: HandShake: Secret key:
16:12:00 T:2894031728 M:397271040    INFO: ae 40 3f 40 67 12 a8 7c e7 f7 b0 a7 0a 8f 06 84
16:12:00 T:2894031728 M:397271040    INFO: dd 95 bd f1 cb d2 90 24 a4 ee 7a ff 34 9a 44 04
16:12:00 T:2894031728 M:397271040    INFO: ee 74 73 ad ca b4 fa 84 3e ad 40 62 a4 b8 b5 f9
16:12:00 T:2894031728 M:397271040    INFO: bc a0 d1 a8 a8 48 95 84 d0 ff 7d cf 3b 99 97 3c
16:12:00 T:2894031728 M:397271040    INFO: 77 cf d5 c9 32 9a 6d 8d 2f 2f 93 26 f1 c2 1f cd
16:12:00 T:2894031728 M:397271040    INFO: 0f 31 98 e5 d0 bd 19 ac ac 35 d5 bf d3 70 60 1c
16:12:00 T:2894031728 M:397271040    INFO: 0c 00 e3 4f bd 6c 70 24 66 b6 f3 5e 32 49 ef 2b
16:12:00 T:2894031728 M:397271040    INFO: 3e 0b c4 4b c8 de 52 52 c8 ed f0 7a 63 6a 5d af
16:12:00 T:2894031728 M:397271040    INFO: RC4 Out Key:
16:12:00 T:2894031728 M:397271040    INFO: a9 75 50 3c 2b 33 72 e7 d5 87 69 e9 0a 9a 39 72
16:12:00 T:2894031728 M:397271040    INFO: RC4 In Key:
16:12:00 T:2894031728 M:397271040    INFO: d3 ee 7a 68 b7 1a 6e 4b 95 1a 32 92 2b 98 f8 ab
16:12:00 T:2894031728 M:397271040    INFO: HandShake: Calculated digest key from secure key and server digest:
16:12:00 T:2894031728 M:397271040    INFO: 01 55 c2 cf e4 62 91 c0 dc 04 93 f7 d4 36 7f 23
16:12:00 T:2894031728 M:397271040    INFO: fa fc 10 5f a3 17 c1 b2 32 1c 8b fd 58 21 ff 85
16:12:00 T:2894031728 M:397271040    INFO: HandShake: Client signature calculated:
16:12:00 T:2894031728 M:397271040    INFO: 4a 73 ce c7 46 64 c8 72 d3 0a ff e3 49 d7 87 90
16:12:00 T:2894031728 M:397271040    INFO: 5e b5 75 01 8b 9c 66 fc 15 a1 42 00 c7 83 e4 e8
16:12:00 T:2894031728 M:397271040    INFO: HandShake: Server sent signature:
16:12:00 T:2894031728 M:397271040    INFO: da 5c c9 37 ae ec fa 3d 9d 41 be a4 66 b4 56 0c
16:12:00 T:2894031728 M:397271040    INFO: 60 66 bb b6 fa 6d de b0 10 8d c0 e2 a1 5e eb 91
16:12:00 T:2894031728 M:397271040    INFO: HandShake: Digest key:
16:12:00 T:2894031728 M:397271040    INFO: 61 86 d7 b4 58 1c ec 26 c1 95 f0 67 0d 77 37 47
16:12:00 T:2894031728 M:397271040    INFO: 92 6c c3 ec 8b 66 7d 18 1c 2d 27 91 3d ed 33 ef
16:12:00 T:2894031728 M:397271040    INFO: HandShake: Signature calculated:
16:12:00 T:2894031728 M:397271040    INFO: b0 d2 07 cf 17 29 7f 9f 8b 09 9b 1b 54 e0 e2 dd
16:12:00 T:2894031728 M:397271040    INFO: 52 1e 30 60 c5 bc 20 db 33 6f 6f a5 c0 84 e9 aa
16:12:00 T:2894031728 M:397271040 WARNING: HandShake: Server not genuine Adobe!
16:12:00 T:2894031728 M:397271040   ERROR: RTMP_Connect1, handshake failed.
16:12:00 T:2894031728 M:397271040   ERROR: CDVDPlayer::OpenInputStream - error opening [rtmpe://crunchy.fcod.llnwd.net/a3439/e8/mp4:s/ve594140/video.mp4?s=1313871108&e=1313885508&h=9184714896e8daa7daab1b87edeb236c swfurl=http://static.lln.crunchyroll.com/flash/20110815123814.b3f6928613b48e9f940071a3d1ceecbd/ChromelessPlayerApp.swf?config_url=http%3A%2F%2Fwww.crunchyroll.com%2Fxml%2F%3Freq%3DRpcApiVideoPlayer_GetChromelessConfig&use_explicit_config=1 swfvfy=1 token=MDPMZKx0lMUTwW9+JvBRD/ZWnpI= playpath=mp4:s/ve594140/video.mp4
Reply
#63
Version 2.4-GIT of librtmp is needed specifically to fix that explicit issue.

Ergo: you did not upgrade to the unstable GIT version or XBMC is using the wrong library. Check your installation again.

Imho, the whole thing is unfortunate as the handshake update does not seem to be backported in the stable version and librtmp 2.4 is not released officially yet.

On a side note: pausing the stream crashes XBMC when I resume after a couple of minutes (15+). Perhaps things like these are the reason why 2.4 has not been released yet...
Reply
#64
Nevermind. I am using the latest ubuntu, which names librtmp as librtmp0, when I checkinstalled it made a rtmpdump package. To get it all to work with out removing packages (like gstreamer's bad plugin set) I changed the version to 2.4, the package to librtmp0, the provide to librtmp, and the remove to rtmpdump (to remove my last try). Now it works. Thanks for the help.
Reply
#65
Good to hear that it worked!

If you experience the crashes, could you let me know? They happen on my system if I play a show, pause it for 15+ minutes and try to resume later.

I'm wondering if its the git version of librtmp or something else...
Reply
#66
Well, havn't had time to find out. Got it to work, just as I was leaving. In the car actually. I'll let you know if it does that when I get home. Just start any show and pause it for at least 15 min right?

Also, a Q. In the log it shows that it got a summary of the show, but it doesn't show up in xbmc. Is there a way to do that, or is it not supported yet?

Edit:
Well, I just tried it out, and yeah, after 20min it did fail to play. Not a big problem for me, as I almost always finish what I am watching in one sitting, but it does suck when/if it happens.

And I got the summary working. Media info 2 works, but 1 doesn't if the pic is showing. Don't know why.
Reply
#67
Quick question. I'm brand new to the XBMC community and am still trying to wrap my head around everything. I have a few questions that would greatly help me get started. A quick note, i'm using Windows 7 64-bit.

Question 1: I see that this plugin requires the newest build of librtmp. To use the newest version (v2.4 from the RTMPDump website) do i need to have a special version of XBMC? Do i need to patch or compile it differently? Or can i use the stable, pre-compiled version (10.1) that is available for download from the XBMC front page and simply overwrite the existing version of librtmp.dll with the newer one?

Question 2: If the answer to the above question is that I can use the stable version (10.1), do i just need to download the pre-compiled win32 build that they linked on the front page of the RTMPDump website (dated 2011-07-23) and put it in my C:\Program Files (x86)\XBMC\system\players\dvdplayer\ folder overwriting the one that's already there? Do i need to do anything else to get XBMC to use this newer version of librtmp? (Registering the DLL or changing settings in XBMC)

The main reason for the above questions is that i did what i just outlined above, downloaded stable 10.1 version and replaced the librtmp.dll file with the pre-compiled 2.4 version from RTMPDump website, but i'm still not able to play high-res content from Crunchyroll. All i am able to watch are the sd streams. I've verified my username and password is filled in correctly but all its playing are the low res streams. It does the same thing even if I type in the wrong (deliberately) username/password. Same results.

I'm also getting some "Unsupported protocol(rtmpe)" and "Handshake: Type mismatch" warnings in my logs. I'm obviously doing something wrong. Just trying to figure out what i'm doing wrong.

Thanks!
Reply
#68
Your questions and results are a bit conflicting with what I'd expect.

Upgrading librtmp.dll should work on Windows like you described: XBMC is searching in its own path for the library. Since the interface has not changed (much) between 2.3 and 2.4, it will blindly load the newer version.

Without this, you can't view any streams on Cruchyroll - none. The fact that you actually do see content means you upgraded librtmp like you should.

Now, as far as I know, only premium members get access to HD content, just like on the site. So if you are a free user, do not expect to suddenly get access to 720p content.

If you are a premium member, you should get HD streams automatically. Check your settings in the addon: it should be set to 720p. View a recent series like Bleach or Naruto; you should get the 720p stream (video properties is a good way to check this during playback).

If you still do not get the HD streams, erase the crunchyroll cooky: in temp/addon_data/video_something_crunchyroll there is a file called something like crunchycookie - erase that while the addon is not active. If you now start the addon again, it will log in anew and you should have HD content.

BTW: This is a bug afaik; I have to remove the cookie every 2 months or something (I get the "This content is not available on your account" error when it expires)
Reply
#69
Thanks Cyberwizzard! The cookie was the problem. I removed the cookie and when i started XBMC back up it logged me in properly and i was able to play 720p content.

Also, just for reference, the exact location for the cookie in Win7 is: C:\Users\YourUsername\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.crunchyroll\

Thanks again for the help!
Reply
#70
theredbaron Wrote:Nevermind. I am using the latest ubuntu, which names librtmp as librtmp0, when I checkinstalled it made a rtmpdump package. To get it all to work with out removing packages (like gstreamer's bad plugin set) I changed the version to 2.4, the package to librtmp0, the provide to librtmp, and the remove to rtmpdump (to remove my last try). Now it works. Thanks for the help.

I apologize as I missed something here. I got the latest from the rtmp dump site, did "make SYS=posix", than a "sudo make install". It installed a bunch of librtmp to /user/local. Is it as simple as renaming these to librtmp0 and moving them into the user/lib or is that going to really mess up the package manager? How did you change the version, specify, and remove?

Sorry for my novice questions.
Reply
#71
I figured it out. I uninstalled the Ubuntu version, then used "checkinstall" to package and install the built version and in the checkinstall options gave it the same name as the Ubuntu one. Maybe not the best plan, but it seems to be working.
Reply
#72
Thanks for the VBS.tv addon! I really hate to congratulate and thank you for this addon then tell you about a bug, but I have to.

The Vice Guide To Travel section will not list any videos for some reason. If you could fix it, I would be grateful! Thanks!
Reply
#73
laukarlueng Wrote:Thanks for the VBS.tv addon! I really hate to congratulate and thank you for this addon then tell you about a bug, but I have to.

The Vice Guide To Travel section will not list any videos for some reason. If you could fix it, I would be grateful! Thanks!

VBS.TV is now VICE.com, and although a lot of the videos remain unmodified for now eventually they should all be migrating to the new site. Currently there is no addon which will play VICE.com content, so we're shit out of luck and stuck with the super-slow Ooyala flash player on the VICE website.

I was using maruchan's VBS addon all the way up until the site changed, as it actually turned out not to have been that big a problem that content served from Ooyala was broken up into small pieces. It was still better than the choppy playback from within a browser. Also it's amazing that maruchan even got those videos working in the first place Smile

*edit* for anyone else who has problems with slow flash video players within Firefox on an older PC, I just tried using Opera and it plays VICE.com content perfectly
Reply
#74
Hello Everyone, I just installed the plugin and I am getting a script failure when playing VBS TV. Does anyone have any suggestionsHuh

Thank you,
Zeee1
Apple TV 2
Reply
#75
Most of my plugins haven't been updated in a good while, VBS being one of them. As you can see from the post above yours, they recently did away with vbs.tv and just integrated their video content into vice.com. The plugin needs to be updated to reflect these changes.

In all honesty, I don't know if it's worth it. A number of videos on their site are split up into tiny little chunks, so every 3-8 seconds XBMC has to load a new video and start playing it, causing momentary pauses. It's very annoying. The Vice player is able to load these new clips in the background and do gapless playback, but XBMC doesn't have a gapless playback feature for video, so until it's added you're stuck with the video that breaks up every few seconds.
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 8
  •   



Logout Mark Read Team Forum Stats Members Help
[VBS/Pitchfork/Crunchyroll] maruchan addons repository1
This forum uses Lukasz Tkacz MyBB addons.