• 1
  • 13
  • 14
  • 15
  • 16
  • 17(current)
[LINUX] HOW-TO create a XBMC server for diskless PXE network booting clients

For me it is impossible to make work nbd.
When I am trying to mount the /dev/nbd0 I have this message :

on client : end_request: I/O error, dev nbd0, sector 0
unable to read partition table

on server :
Jan 20 11:00:46 eric-desktop nbdrootd[23017]: connect from (
Jan 20 11:00:46 eric-desktop nbd_server[23017]: connect from, assigned file is /var/lib/xbmc-diskless/images/xbmc.img
Jan 20 11:00:46 eric-desktop nbd_server[23017]: Size of exported file/device is 307118080
Jan 20 11:00:47 eric-desktop nbd_server[23017]: Send failed: Bad file descriptor
Jan 20 11:00:47 eric-desktop nbd_server[23017]: Exiting.

Can you please help me?

Eric B.
Hello i am trying to setup this diskless server but when i issue the add repository i get this error

[email protected]:~$ sudo add-apt-repository ppa:lars-opdenkamp/xbmc-diskless
Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 88, in <module>
ppa_info = get_ppa_info_from_lp(user, ppa_name)
File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 80, in get_ppa_info_from_lp
pycurl.error: (6, "Couldn't resolve host 'launchpad.net'")

please help

Thank You
I just tried adding the ppa and all went fine. have you run
sudo apt-get update
i did some research and digging and found the reason mine is failing is i have ubuntu oneiric and in the ppa folder structure he dosent have one for oneiric is there a way to still install or do i need to install karmic and go back instead
i got everything working when the client boots it says

missing parameter in configuration file autostart=xbmc

the client continues to boot but just boots to a text login asking me to login to xbmc-diskless

please help
johnson.adale Wrote:i did some research and digging and found the reason mine is failing is i have ubuntu oneiric and in the ppa folder structure he dosent have one for oneiric is there a way to still install or do i need to install karmic and go back instead

I changed the distro for just this source from oneiric to maverick (Software Sources) and will see how it goes. It updated and installed.

An afterthought. I want to use this on a ARM based PC like the CuBox or Raspberry Pi. Does anyone know if its possible?
Hi guys,

I''m having serious trouble getting my audio to work with xbmc-diskless on a Zotac ID41 (ION2).
My aplay only lists the following:

[email protected]:~$ sudo aplay -l
sudo: unable to resolve host xbmc-diskless
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
Subdevices: 1/1
Subdevice #0: subdevice #0

In alsamixer, I am able to select the HDA NVidia card, but then it says 'This sound device does not have any controls."

The lspci command shows, among other devices, that the audio device is recognized by Ubuntu:
03:00.1 Audio device: nVidia Corporation High Definition Audio Controller (rev a1)

I've tried so many things like modifying the /etc/modprobe.d/alsa-base.conf file, inserting additional options, but nothing seems to work.
Also tried to follow instructions from murph (http://forum.xbmc.org/showthread.php?tid...#pid686388) but no luck there too.
Even after updating the NVidia drivers, they seem to be corrupted in a way (other story but if anyone knows something about it...)

(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
(EE) NVIDIA: system's kernel log for additional error messages.
(II) UnloadModule: "nvidia"
(II) Unloading /usr/lib/xorg/extra-modules/nvidia_drv.so

(EE) Failed to load module "nvidia" (module-specific error, 0)
(EE) No drivers available.

Fatal server error:
no screens found

If you require more info, just let me know.


Alsa seems to be the problem. The kernel installation base is 2.6.32-21. With 2.6.32-23 and equal Alsa drivers, the aplay -l recognizes the NVidia HDMI.

Steps taken so far:
Create a new image (don't pack and install)
Then mount the nfs filesystems and chroot

Update linux kernel:
sudo apt-get install linux-headers-2.6.32-23 linux-headers-2.6.32-23-generic linux-image-2.6.32-23-generic ... from lucid-updates

Reinstall Nvidia current (bit old but it works):
sudo apt-get install --reinstall nvidia-current

Add and update Alsa:
sudo add-apt-repository ppa:ubuntu-audio-dev/ppa
sudo apt-get update
sudo apt-get install linux-alsa-driver-modules-2.6.32-23-generic

Unmount filesystems and pack and install.

Current issues:
NVidia drivers fail to load (see also my original post).
I don't have time to maintain this anymore. If someone has patches that include support for new things, e.g. new Ubuntu versions, I'll happily include them and update the builds.

>> Then mount the nfs filesystems and chroot
did you follow the "Upgrading (optional)" part of the first post? otherwise it probably won't work, because the post-install part fails.
opdenkamp / dushmaniac

xbmc-pvr [Eden-PVR builds] [now included in mainline XBMC, so no more source link here :)]
personal website: [link]

Found a problem with PVR? Report it on Trac, under "PVR - core components". Please attach the full debug log.

If you like my work, please consider donating to me and/or Team XBMC.
The upgrade option doesn't do much for me (0 updated, 0 upgraded asf).

Update 2012-03-17
Except for some minor issues still, I believe I practically solved the problem.

The following works in my situation:
* Directly after the image creation, create a backup 'target' directory (if you intend to do some 100 tests before going live)
* Mount the nfs and perform chroot to it.
* Add http://nl.archive.ubuntu.com/ubuntu/ lucid-updates main to the /etc/apt/source.list and update.
* Install packages linux-headers-2.6.32-23-generic and linux-image-2.6.32-23-generic.
* Add the 'ppa:ubuntu-audio-dev/ppa' ppa and install package linux-alsa-driver-modules-2.6.32-23-generic. In my experience, the alsa driver modules HAVE to be the same version as the kernel, but maybe compatibility changes when updating to a higher level kernel. Did not test that.
* Now pack and install the image.

The result is that aplay -l identifies the NVidia card correctly.
* XBMC Eden (from the unstable ppa) doesn't start and the system leaves me with a prompt only. Manual startup with xinit xbmc works perfectly though.
* Although the NVidia card is recognized (and I'm pretty sure it will work in XBMC), I still have to test the audio.

I'm not talking about cleanup cuz i'm not a hardcore linux user in this area yet, so if anyone could tell me how to cleanup former kernel images and its associations, that would be an extra step forward :-).
The next few weeks I will try to find out if a full dist-upgrade works in my case. If so, I'll post the results again and hope that will contribute to the existence of xbmc-diskless-server.

Few questions/remarks:
* What is the added value of the download_xbmc section in xbmc_diskless.sh? Can it be left out?
* The upgrade_system section doesn't seem to work. I'll have a look at why not.

Hello. My ION client stops with the message:
Quote:Ubuntu 10.04 LTS xbmc-diskless tty1
xbmc-diskless login:

The last messages in /var/log/daemon.log is:
Quote:Apr 4 13:00:47 XBMC-server nbd_server[3002]: connect from, assigned file is /var/lib/xbmc-diskless/images/xbmc.img
Apr 4 13:00:47 XBMC-server nbd_server[3002]: Size of exported file/device is 324141056
Apr 4 13:00:47 XBMC-server mountd[2979]: authenticated mount request from for /var/lib/xbmc-diskless/overlay (/var/lib/xbmc-diskless/overlay)

The /etc/exports line is:
there - is my server.

The system is Ubuntu 10.10, Linux 2.6.35-32-generic.
  • 1
  • 13
  • 14
  • 15
  • 16
  • 17(current)

Logout Mark Read Team Forum Stats Members Help
[LINUX] HOW-TO create a XBMC server for diskless PXE network booting clients2
This forum uses Lukasz Tkacz MyBB addons.