[Linux] Zsnes logitech rumblepad 2 cordless issues

Have been having fun with zsnes doing some retro gaming :0) I still have a problem though with my logitech rumblepad.

Googled a fair bit and cannot find anything that helps me. I have posted over at the zsnes forum http://board.zsnes.com/phpBB3/viewtopic....72&start=0

Essentially, although input works, doing complex commands such as a streetfighter 2 Ryu/Ken fireball will not work, as if the DPAD commands are not processed fast enough. Also regularly in other games I get erratic movements of the character with the dpad.

Same version of zsnes, same hardware on my windows box works fine (plain windows install, no xbmc)

I am thinking it is xbmc specific, perhaps something else hooking into the joystick commands?

I run the emulator via a launcher which sends a stop command to the xbmc-live service.

Any ideas? If I hear anything over on the other forum I will post here and vice versa

found this old thread in which someone had something similar with diagonals sticking, and had made a custom build of zsnes


I implemented the fix as follows:

sudo apt-get remove zsnes

then install his custom (lucid) build of zsnes
wget https://launchpad.net/~smaxein/+archive/ppa/+files/zsnes_1.510-2.2ubuntu4~ppa1_i386.deb
sudo dpkg -i zsnes_1.510-2.2ubuntu4~ppa1_i386.deb
Does anyone have any idea why this affects some users? I run zsnes with XBOX360 wireless controllers (had to manually install the drivers) and haven't noticed this problem, but I did lose a drunken game or two of Mortal Kombat II, which *of course* I was quick to blame on the controller Wink

I guess what I'm asking is if this seems localized to your controllers and/or some default gamepad driver, or if this will affect any gamepad with any driver when running the newest XBMC Live.
Thread Rating:
  • 0 Vote(s) - 0 Average

Logout Mark Read Team Forum Stats Members Help
[Linux] Zsnes logitech rumblepad 2 cordless issues00
This forum uses Lukasz Tkacz MyBB addons.