HTPC + LIVE + HP IR + Logitech Harmony 880
I was a long time user of XBMC on the XBOX original. A couple of years ago in my quest for high definition I handed the XBOX down to my Mom who still happily uses it and I migrated to a PS3 and PS3 Media Server software running on my Windows Home Server. The PS3 Media Server application development has died off and it can no longer accommodate new MKV due to audio encoding issues. Long story short, I've decided to use an extra PC I have and happily return to XBMC. At least "happily" is my plan. Smile

  • Ginormous PC in a 4U rack enclosure. I used to use it for hosting VST for music recording.
  • Gigabyte EP45-UDR3 motherboard with built-in audio/LAN/firewire/more
  • Intel Dual Core E52000 (not overclocked)
  • 4GB RAM
  • NVIDIA GeForce 8400
  • Internal SATA hard drive and DVD drive
  • Hewlett Packard IR receiver
  • Logitech Harmony 880
  • PS2 Key board and Mouse

I've successfully run both LIVE 9.11 and Dharma BETA 3 from bootable CD, as well as successfully installed both to the hard drive (individually, not simultaneously). Both work without issue in all regards with the exception of the remote control which I cannot get to work at all. Dharma BETA 3 is currently installed but I'm happy to install whatever is necessary.

I have spent time on the forums trying to piece together the correct setup and believe I have done so.
  • Harmony 880 has a "device" for XBMC programmed as Media Center PC > Microsoft > Windows Media Center
  • XBMC "activity" has buttons assigned to control Media Center PC.
  • XBMC has LIRC programmed as Windows Remote All, and transmitter as None

The IR receiver is in fact receiving commands per the LED. However, XBMC does not respond. Plugging the IR receiver into a Vista PC and the Harmony successfully controls Media Center on the computer, so the hardware is physically functional.

So the issue apparently lies with either the codes the Harmony is sending the IR receiver, the way the IR receiver is feeding data to XBMC, or my configuration of XBMC.

Unfortunately I lack any (not enough, simply ANY, with the exception of what I'm doing here for XBMC LIVE) Linux experience so I'm at the mercy of extremely specific directions being provided. Many of the forum posts generically refer to Linux options and commands without specifying the full directions. So I often hit a road block.

Let me recap what I've done to configure and test LIRC.
  • Access Linux prompt with CTRL+ALT+F1
  • Login with my non-root user account. The default xbmc/xbmc user account is apparently disabled, I have not figured out how to create one, nor do I know if I need root level access to successfully complete this task.
  • After successful login I run "sudo dpkg-reconfigure lirc" and select Windows Remote All, and transmitter as None. When I return to the prompt I type "SUDO REBOOT" and the system restarts.
  • XBMC still has no remote control
  • Access Linux prompt with CTRL+ALT+F1
  • Login with my non-root user account.
  • Run "SUDO IRW" which should theoretically show me all of the commands coming from the remote. However, I do not see anything on the screen. If I press keyboard buttons, I see various characters appear on screen. Just nothing when using the Harmony.

By all accounts on the more recent forum posts this hardware should work by default without any special configuration. So I'm left to assume I'm doing something wrong that is extremely obvious to everyone but myself. Smile Haha.

If I had to venture a guess I'd guess the XBMC is configured properly and the IR receiver is functional but the Harmony remote itself is not programmed correctly. However, I cannot figure out a way to determine what codes it's sending. It could be pushing out keyboard commands instead of IR codes, which from what I read will not work.

I'm not sure what additional data I can provide at this time so I'll patiently await some assistance.

Unrelated, with the exception of my remote control woes XMBC is truly superb. It overcomes all of the annoyances of the PS3's simplistic menu bar and reliance on DLNA servers.

you need to configure your LIRC as a MCE USB... should be down at the very bottom of the list.

since running xbmcFReak Live I have not had to program my LIRC at all it just works right out of the box.

my remote is setup as a Microsoft Media center same as yours is


EDIT: to further customize your buttons read my thread here for helpful information.
Yes, I did actually see multiple references to MCEUSB mentioned in other threads but I swear I never saw it in the list when configuring LIRC. The kids are using the PS3 right now so I'll have to wait to try to reconfigure it later and will report back.

Thank you kindly.
gastric Wrote:Yes, I did actually see multiple references to MCEUSB mentioned in other threads but I swear I never saw it in the list when configuring LIRC. The kids are using the PS3 right now so I'll have to wait to try to reconfigure it later and will report back.

Thank you kindly.

might be a good idea to purge your lirc and get a fresh new copy as I do believe there is a new MCE USB that handles both the old and new mce remotes in one profile.

And therein lies the problem. There is no MCE USB anywhere in either list when configuring LIRC. It simply does not exist. This is true in both LIVE 9.11 and Dharma Beta 3.

I've downloaded the latest XBMCFreak and will see if that magically fixes my issue or not.
Just in case that doesn't work:
I'm not sure how many different IR types are in the mceusb or mceusb2 driver file, but you may have to add a new one. These links are helpful.
I'm making progress, but also getting no closer to a solution. Smile
  • Here is the specific product I ordered. It's supposedly a HP receiver. Visually it's convincing.
  • Windows shows the IR receiver as "Windows eHome Infrared Transceiver" and again it does in fact work in Windows without issue
  • Running "sudo lsusb" and Linux reports it as "BUS 007 DEVICE 002: ID 1934:5168" I confirmed that is the device as it disappears when unplugging it and rerunning the lsusb command.

I found this thread that is describing the same problem I'm having.

From what I can tell I need to add the device in per the "Add support for more remotes" section of this page: which is sort of linked off one of the pages Loot87 suggested.

Getting closer....?
Gastric, you are on the right track.

I have the exact same receiver and found out I had to manually add it to the mceusb.c file and compile again.

The key is definitely the link that you have already been given.

But in my case I had no file called mceusb2 as the guide states:
4. Switch into the /usr/src/lirc-* and backup your driver.
cd /usr/src/lirc-*/lirc_mceusb2
cp lirc_mceusb2.c lirc_mceusb2.c.old

Instead I have the file
in which I added my IR receiver.

My file is here, I just named my receiver LOLLO in the file, you could name it HP (or FINTEK which is the actual supplier of the chip) if you please:

Lines 145 and 237 to be specific are the only lines needed.
Peterbo - thank you! Once that I saw the device wasn't assigned any type of product name I was pretty sure I was heading down the right path. But at 1am last night I was following those directions and couldn't figure out where the file was and didn't think of researching how to perform a file search to locate it.

I believe somewhere on that page there were directions on how to submit your device name and ID to the LIRC code base so future users don't have the same issue. I have no idea if the products we have a illegal knock offs, newer designs, or simply extremely rare models since they're coming from Hong Kong via eBay. But regardless, apparently they're not very widely used on XBMC or Linux or there would be more than a few Google results for the device ID.
Gastric, actually that HP IR and the black Microsoft ones are the preferred IR receivers for XBMC.

I recall before upgrading the xbmcFreak that my newest LIRC version did have a MCE USB to select from. and xbmcfreak just works out of the box no need to change anything. Smile

Unfortunately I couldn't install XBMCFreak for some reason. The install would proceed, install system to disc, then error out to some sort of menu system and no matter what option I chose it would simply re-install the system to the disc. I gave up on that and reinstalled Dharma Beta 3.

Researching some Linux commands I finally discovered the following:

* My file is located in /user/src/lirc-0.8.6/drivers/lirc_mceusb/lirc_mceusb.c
* My vendor is already listed in lirc_mceusb.c properly as FINTEK with the proper vendor code, it's simply the device ID that's missing from the file
* I used "VI lirc_mceusb.c" to edit one of the existing Fintek device IDs to mine which is 0x5168
* Write the change by typing ":w" and then quit the editor with ":q" Had to learn those commands.
* I could then follow the remainder of the instructions on the other page noting to change the commands to match my file path

sudo dkms remove -m lirc -v 0.8.6 --all
sudo dkms add -m lirc -v 0.8.6
sudo dkms -m lirc -v 0.8.6 build
sudo dkms -m lirc -v 0.8.6 install

Then I got to this and failed

sudo rmmod lirc_mceusb

Nothing was reported back, no error, no confirmation. When I tried the following:

sudo modprobe lirc_mceusb

I received the error "FATAL: error inserting lirc_mceusb (/lib/modules/2.6.32-25-generic/updates/dkms/lirc_mceusb.ko): Unknown symbol in module, or uknown parameter (see dmesg)

I'm assuming I bungled the file edit somehow. So I copied the .old back so the lirc_mceusb.c file was original, followed the directions to rebuild. Once I got to the following:

sudo rmmod lirc_mceusb

I received the error "ERROR: Module lirc_mceusb does not exist in /proc/modules"

And I'm at a road block again.
Hi Gastric

Perhaps a stupid suggestion but did you try using tab completion when typing part of the module name? For example just type "sudo rmmod lir" and then tab to see the possibilities.
sudo rmmod <module_name>

Otherwise, do a
lsmod | grep lirc
to see which lirc modules are loaded. Unload them all and load them again using the modprobe command.

If there are more than one lirc module you might have to unload them in the correct order, for it to unload properly. I think lirc_dev is the last to be unloaded.
Not a stupid question at all. I know NOTHING about Linux, so anytime someone suggests something and doesn't clearly specify EXACTLY what I need to type to accomplish the task I have to search how to actually do it, like how to edit the lirc_mceusb.c file.

Just to clarify. I'm not unable or unwilling to learn. It's just time consuming and challenging.

Just to put things in perspective. All I'm trying to do is plugin a $15 USB receiver. Smile

Apparently I just need a LIRC file that has my device ID in it so Linux can successfuly recognize my hardware. Which, if truly the "preferred" receiver for XMBC, assuming it's this very specific unit, must be causing countless others a huge headache like me. Otherwise it'd be in the device list so it'd be plug-n-play as everyone has described.

Not complaining, just venting. Wink The entire XBMC process is SUPER easy with LIVE. The install is fast and painless. Using it is very easy, though I'm already pretty familiar with the GUI from my softmodded XBOX days. This remote control thing is pushing my patience though. Hours of effort later and I'm still not much further ahead.
gastric are you sure you have the latest Lirc installed?

lirc-0.8.7.tar.bz2 - 813 kB
released: 06-Sep-2010

so the newest version is pretty new.
above is a list of supported hardware. your HP receiver is at the very bottom of the list listed as MCEUSB..

when doing a reconfigure of Lirc if you do not have MCEUSB you do NOT have the most recent version...

I recommend removing all instances of LIRC and using the guide below.
removal guide:


Heh, at this point I'm not sure of anything. :p

I swear one of the many, many directions I read had me uninstall lirc, update, and reinstall, which should theoretically pull the latest from what I understand. It's entirely possible I did that, then missed MCEUSB when reconfiguring. I'll try that again and see what happens.
Thread Rating:
  • 2 Vote(s) - 5 Average

Logout Mark Read Team Forum Stats Members Help
HTPC + LIVE + HP IR + Logitech Harmony 88052