XBMC Dharma RC1 / Intel Graphics
#1
Hello everyone. First I would like to thank the developers as well as the community for taking their time to not only develop but also to offer assistance with issues to people who find themselves in need.

Today I tried to install XBMC Dharma RC1, the install went through without any issues. However upon first boot the splash screen comes up and then it appears as if X gets killed and I'm sent back to a console login. From then on every few seconds the screen will go blank as if it's trying to load X again but promptly returns back to the console in what appears to be an endless loop of trying X and reverting back to a console login. After having looked at the xorg error log I noticed this error "Failed to submit batchbuffer: Input/output error" and was wondering if anyone else had experienced that?

BTW, XBMC 9.11 worked fine on this same hardware. I've since thrown on another distro quick so I'm able to post this information. The following dmesg output is NOT from xbmc but I wanted to include it so you know the graphics hardware I'm using.

agpgart-intel 0000:00:00.0: Intel 830M Chipset
However I'm quite certain the actual chipset is an Intel 945.

Once I finish up working on this project I'll be able to post the entire xorg error log as well as a complete dmesg if needed. ATM I was just wondering if others have seen this and if their was an easy fix someone could recommend with the information I'm currently able to provide.

Thanks in advance!

EDIT: Sorry, I forgot to mention one more thing.. I had also tried to apt-get update and apt-get upgrade on the installed version to see if that fixed the issue. Also XBMC Dharma RC1 will work fine in live disc mode.
Reply
#2
This is what dmesg running from the XBMC live disc shows, I pasted the relevant information in this thread and will post a link to the full output of both dmesg as well as Xorg.0.log on pastebin and provide links as the limit of characters exceeds what this forum allows.

I searched google and apparently their is a known bug which results in the error I'm getting so maybe I won't be able to resolve this. It just seems odd that it will work in live mode but not once it's installed.

relevant portion of dmesg is as follows
Code:
[    1.677132] agpgart-intel 0000:00:00.0: Intel 830M Chipset

Full dmesg located here
http://pastebin.com/cgsMRj4m

Full Xorg.0.log located here
http://pastebin.com/Hhk2eqFY

Please advise if you want the installed version of Xorg.0.conf which displays the errors. However I won't be able to do so until late tonight or tomorrow most likely.

Thanks
Reply
#3
I'll assume you're running ubuntu since you mentioned apt-get...

If you're running ubuntu 10.10 there are some pretty major issues with older intel chipsets like the one you're using and X (I only know this because I have an older laptop that uses one). If you search around you should be able to find their method for installed the intel drivers directly. What happened was, they found some bugs and decided to drop some intel cards back to standard output instead of using the GLX stuff. XBMC requires openGL, so my guess is that's what you're running into.

With X running you can type glxinfo at the command line, if it says "direct rendering: No" at the top you'll need to get the right drivers and xserver installed.

There are some negatives to installing that, but if you're planning on using XBMC you have to. Here's the link to ubuntus wiki on the subject. https://wiki.ubuntu.com/X/Bugs/Mavericki8xxStatus
Reply
#4
dan1son, Thanks for the reply.. I'm installing the XBMC Live Dharma RC1 which is built on Ubuntu 10.04 LTS. I'll have a read of the wiki and see if I can find any information that might be able to help. Appreciate the link.
Reply
#5
Also, here is a link to the installed version of the Xorg.0.log which won't load the XBMC interface.

http://pastebin.com/1G7S8Lwn

FYI: I've reinstalled XBMC 9.11 since it works, that way if anyone wants comparable logs or information from it they can be made available.
Reply
#6
Just installed RC2 and that seems to have fixed the issue Smile thanks!! Now on to testing some other things.
Reply
#7
After a bit more testing this issue doesn't seem to be fully resolved.
Reply
#8
Upgrading the Intel drivers might help you. Here is how to do it:

http://forum.xbmc.org/showthread.php?tid...ight=vaapi
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
Reply
#9
alanwww1 Wrote:Upgrading the Intel drivers might help you. Here is how to do it:

http://forum.xbmc.org/showthread.php?tid...ight=vaapi

Thanks for this, I will try it at some point today or tomorrow. Appreciate the attempt at helping me resolve this issue and will report back.
Reply
#10
Code:
sudo apt-get update
sudo apt-get install udisks upower xorg alsa-utils mesa-utils
sudo adduser YourUserName video
sudo adduser YourUserName audio
sudo reboot

This all went fine, though if memory serves on Dharma RC2 those packages were already installed and my username was already a member of both the audio and video groups.

Code:
sudo apt-get update
sudo apt-get install python-software-properties
sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install libva1 vainfo i965-va-driver libva-glx1 libva-dev
sudo reboot

Doing this I got the message:
Code:
E: Couldn't find package libva1.
Out of curiosity I removed libva1 to see if the other packages could be installed and got the following.
Code:
E: Couldn't find package vainfo

I'm not exactly sure why the packages aren't there as the repo seemed to be added fine, the output is below.

Code:
sudo add-apt-repository ppa:xorg-edgers/ppa
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv 165D673674A995B3E64BF0CF4F191A5A8844C542
gpg: requesting key 8844C542 from hkp server keyserver.ubuntu.com
gpg: key 8844C542: "Launchpad PPA for xorg crack pushers" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

This is the third time I ran that command as I didn't copy it the first time hoping that everything would work without issue.

One other thing, in the link you referenced me to it talks about a lag issue playing some movies through XBMC but they play fine in mplayer. Thats one of the issues I'm currently facing, just wanted to include that info.

Thanks again for your help thus far.
Reply
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
XBMC Dharma RC1 / Intel Graphics00