•  Previous
  • 1
  • 28
  • 29
  • 30(current)
  • 31
  • 32
  • 48
  • Next 
 
Thread Rating:
  • 18 Vote(s) - 4.5 Average
[PATCH] Dual Audio Output support for XBMC (Eden Updated)
Anybody build/recompiled binaries yet and willing to share?

Can't really figure out how I have to rebuild xbmc.bin with the sources.

Nice work XHBL !
Reply
This is just freaking awesome, thanks xhbl.

Anyone tested this on OpenELEC yet?

Note: My previous posted patches were faulty.
Reply
(2012-04-01, 10:19)schumi2004 Wrote: This is just freaking awesome, thanks xhbl.

Anyone tested this on OpenELEC yet?

EDIT:
I tried to create a patch file for Eden.
Since my Git skills are limited don't expect it to be perfect Wink

Diff agains xbmc Eden branch http://dl.dropbox.com/u/6696611/xbmc_dua...anch.patch
(rename to xbmc-11.0.1-999-dual-audio-patch.v0.1.patch)
Patch instructions http://forum.xbmc.org/showthread.php?tid...#pid931721

My other patch was against xbmc master branch which seems to be XBMC Frodo so i removed it.

Could you please post the final xbmc.bin?
I don't know git and I don't want to learn it either so please if you could just post the final .bin file it would be perfect...
Reply
@armitatz

I will if i didn't get this error Sad
Something is wrong which i need to check.

http://pastebin.com/pXrY5MQN

Maybe xhbl can tell me which xbmc commit he used to create this patch.
Reply
Final.
Image
Code:
GRANT ALL PRIVILEGES ON `xbmc_%`.* TO 'xbmc'@'%';
IF you have a mysql problem, find one of the 4 dozen threads already open.
Reply
@darkscout
Well i also made the patch on final but development doesn't stop, the "Final" today is not the same as when xhbl created the patch.

I think i'm out of luck (at least for OpenELEC) there are some other patches in OpenELEC which screw up the build for me.
I need to manual edit all files with available patches for XBMC in OpenELEC.
Reply
@schumi2004
I think he meant Final as in the Final Build and official release of Eden. Not the nightly builds that are ongoing...
Reply
(2012-04-03, 01:22)mrdally204 Wrote: @schumi2004
I think he meant Final as in the Final Build and official release of Eden. Not the nightly builds that are ongoing...

Right, the final 11.0 Eden release, not the ongoing nightly builds.
Reply
(2012-04-01, 10:19)schumi2004 Wrote: Anyone tested this on OpenELEC yet?
Seems I can't get this patch even on fresh xbmc sources. Which version should I need to dl to apply this patch?
Reply
(2012-04-02, 18:38)armitatz Wrote:
(2012-04-01, 10:19)schumi2004 Wrote: This is just freaking awesome, thanks xhbl.

Anyone tested this on OpenELEC yet?

Note: My previous posted patches were faulty.

Could you please post the final xbmc.bin?
I don't know git and I don't want to learn it either so please if you could just post the final .bin file it would be perfect...
Please test, i'll hope it works. Here it doesn't because of inappropriate graphics driver.
Running Ubuntu 10.10 (x86) in VirtualBox, that's why.

http://dl.dropbox.com/u/6696611/xbmc-final/xbmc.bin

This is what i did to get the xbmc.bin
- Get stable source code here http://xbmc.org/download/
- Replace files from first post.
- Followed this guide http://wiki.xbmc.org/index.php?title=HOW..._for_Linux
That's it.

(2012-04-03, 08:34)ultraman Wrote:
(2012-04-01, 10:19)schumi2004 Wrote: Anyone tested this on OpenELEC yet?
Seems I can't get this patch even on fresh xbmc sources. Which version should I need to dl to apply this patch?
Patch file is fixed with the help from vpeter from OpenELEC IRC channel.

http://openelec.tv/forum/13-miscellaneou...atch#30068
Reply
Thanx for the effort!

However it does not working for me... I replaced usr/lib/xbmc/xbmc.bin (old file) with the patched and it doesn't start. One comment thogh. The old is 10mb and the new is 100mb.

Reply
(2012-04-03, 18:17)armitatz Wrote: Thanx for the effort!

However it does not working for me... I replaced usr/lib/xbmc/xbmc.bin (old file) with the patched and it doesn't start. One comment thogh. The old is 10mb and the new is 100mb.
Don't know what went wrong, i just followed official guide for it.

You could try it yourself Wink
Reply
(2012-04-03, 18:30)schumi2004 Wrote:
(2012-04-03, 18:17)armitatz Wrote: Thanx for the effort!

However it does not working for me... I replaced usr/lib/xbmc/xbmc.bin (old file) with the patched and it doesn't start. One comment thogh. The old is 10mb and the new is 100mb.
Don't know what went wrong, i just followed official guide for it.

You could try it yourself Wink

That was the original idea but I installed xbmcbuntu and I already have an installation of xbmc. I don't know linux well and I don't know how to remove it.
So I want to
1. remove xbmc
2. compile it again from sources
3. spent an evening setting up again the hdmi sound and my remote

I was hoping to get away from all these steps...
Reply
I noticed a small problem using this patch/tweak.

I was watching Mission Impossible dolby digital and i noticed there wasn't any speach.
Reply
Ok now it won't play audio in our bedroom 2.0 stereo setup if I don't have the surround stereo on too! It says failed to find audio device... So I close xbmc turn on other setup with surround and turn volume way down then turn on xbmc and hit play and it plays in the bedroom. But as soon as I turn off the living room surround connection it cuts the bedroom audio! It worked good before Eden xbmc 11.0... It worked with both setups on or just one and that was with Eden rc2.
Image
Reply
  •  Previous
  • 1
  • 28
  • 29
  • 30(current)
  • 31
  • 32
  • 48
  • Next 
 
Thread Rating:
  • 18 Vote(s) - 4.5 Average



Logout Mark Read Team Forum Stats Members Help
[PATCH] Dual Audio Output support for XBMC (Eden Updated)4.518