Thread Rating:
  • 0 Vote(s) - 0 Average
Texturepacker, I need some help
#1
I have fiddled with texturepacker for a few days now. I am frustrated at this point. I have downloaded all the dependencies (dll's), texturepacker.exe, and my media folder and put them in a folder called texturepacker and no matter what I end up seeing some error or another.

Like this one...
The procedure entry point SDL_Error could not be located in the dynamic link library SDL.dll

What am I missing or doing wrong.

-DOTW
My XBMC/Gaming rig:
Cougar Evolution - AMD Phenom II 1100T @ 4ghz w/ custom Noctua 3-fan Cooler - 16gb DDR3 1866 - ASUS Sabertooth 990FX - Nvidia GTX570 superclocked -
SeaSonic Platinum 860W PSU - OCZ Agility 3 240GB SSD - 8TB storage
Mouse- Cyborg R.A.T. 5 Keyboard- Mad Catz V.7
Reply
#2
If your talking win32 here try this one from my svn its got all the current required dll and the exe
https://jezzxbmc.googlecode.com/svn/TexturePacker if that fails you have bigger issues just keep them all in 1 dir
Reply
#3
Yeah, still didn't work. Probably cause this laptop I've been doing my work on is a Win64. I'll copy things over to my HTPC and try it there.

Copied things to another PC and still doesn't work. I just don't get it, afer I double click texturepacker.exe a dialog pops up for a split second then disappears, no XBTSad

Thanks.
My XBMC/Gaming rig:
Cougar Evolution - AMD Phenom II 1100T @ 4ghz w/ custom Noctua 3-fan Cooler - 16gb DDR3 1866 - ASUS Sabertooth 990FX - Nvidia GTX570 superclocked -
SeaSonic Platinum 860W PSU - OCZ Agility 3 240GB SSD - 8TB storage
Mouse- Cyborg R.A.T. 5 Keyboard- Mad Catz V.7
Reply
#4
weird on windows 7 x64 as well and it works fine for me
Reply
#5
I use to have that problem also and I am also running Win7

Double clicking on TexturePacker.exe does not work, you have to call it from the "run" command.

This is the command I use(adjust your source/destination paths accordingly):
Code:
"C:\Program Files (x86)\XBMC\TexturePacker.exe" -i C:\Users\jpf\Desktop\texturepacker\media -o C:\Users\jpf\Desktop\texturepacker\Textures.xbt

These are all the dll's I have(some of them may belong to XBMC):
Program Files (x86)/XBMC/glew32.dll
Program Files (x86)/XBMC/java.dll
Program Files (x86)/XBMC/jpeg.dll
Program Files (x86)/XBMC/jvm.dll
Program Files (x86)/XBMC/libpng12-0.dll
Program Files (x86)/XBMC/libtiff-3.dll
Program Files (x86)/XBMC/MSVCP71.DLL
Program Files (x86)/XBMC/msvcr71.dll
Program Files (x86)/XBMC/SDL.dll
Program Files (x86)/XBMC/SDL_image.dll
Program Files (x86)/XBMC/TexturePacker.exe
Program Files (x86)/XBMC/verify.dll
Program Files (x86)/XBMC/zlib1.dll

Hope this helps
Image
iMac 27" 2.93gHz i7, OS X 10.11.4
SymLinked to
MacMini 2.3gHz i7, OS X 10.11.4
Running Kodi 16.0 with Confluence (with personal mods)
Reply
#6
jpf55 Wrote:I use to have that problem also and I am also running Win7

Double clicking on TexturePacker.exe does not work, you have to call it from the "run" command.

This is the command I use(adjust your source/destination paths accordingly):
Code:
"C:\Program Files (x86)\XBMC\TexturePacker.exe" -i C:\Users\jpf\Desktop\texturepacker\media -o C:\Users\jpf\Desktop\texturepacker\Textures.xbt

These are all the dll's I have(some of them may belong to XBMC):
Program Files (x86)/XBMC/glew32.dll
Program Files (x86)/XBMC/java.dll
Program Files (x86)/XBMC/jpeg.dll
Program Files (x86)/XBMC/jvm.dll
Program Files (x86)/XBMC/libpng12-0.dll
Program Files (x86)/XBMC/libtiff-3.dll
Program Files (x86)/XBMC/MSVCP71.DLL
Program Files (x86)/XBMC/msvcr71.dll
Program Files (x86)/XBMC/SDL.dll
Program Files (x86)/XBMC/SDL_image.dll
Program Files (x86)/XBMC/TexturePacker.exe
Program Files (x86)/XBMC/verify.dll
Program Files (x86)/XBMC/zlib1.dll

Hope this helps

*APPLAUSE*

Thank you!
That worked like a charm.

-DOTW
My XBMC/Gaming rig:
Cougar Evolution - AMD Phenom II 1100T @ 4ghz w/ custom Noctua 3-fan Cooler - 16gb DDR3 1866 - ASUS Sabertooth 990FX - Nvidia GTX570 superclocked -
SeaSonic Platinum 860W PSU - OCZ Agility 3 240GB SSD - 8TB storage
Mouse- Cyborg R.A.T. 5 Keyboard- Mad Catz V.7
Reply
#7
Same problem here in Win7 x64. Works fine if I run it with "TexturePacker.exe -input ." so it looks like it's the default value for input that's being ignored for some reason.
Reply
#8
(2010-11-28, 08:48)Jezz_X Wrote: If your talking win32 here try this one from my svn its got all the current required dll and the exe
https://jezzxbmc.googlecode.com/svn/TexturePacker if that fails you have bigger issues just keep them all in 1 dir

Thanks for this post. I couldn't get it to work with the Version from the XBMC WIKI. Would be great if this link would be added to the Wiki to save everyone else the trouble.

Best Regards
JohnC
Reply
#9
adding a 3 year old, outdated version?
nah, i don't think so ;-)
Do not PM or e-mail Team-Kodi members directly asking for support.
Always read the Forum rules, Kodi online-manual, FAQ, Help and Search the forum before posting.
Reply
#10
See https://github.com/uNiversaI/skin.conflu...ure_packer
Reply



Texturepacker, I need some help00