•   
  • 1
  • 12
  • 13
  • 14(current)
  • 15
  • 16
  • 18
  •   
[MOD] Night.Purity
Update:

- As stated before and reflected in First Page, Studio Flags are no longer included with the skin, they are used as always, but you have to copy to the folders yourself, to download go to the Film/Movie/Game Studio Flags Repo in my sig.

- TvTunes update/fixed

- New Music Wall View (sorry took this long Batemann)

- New Wall View Fanart Option. It was present (disable) in Night coding, made some little changes and enable it.


Music Wall
Image

Movie Wall Fanart Preview
Image


Wall Fanart Transition Preview (hard to show it with ss, but fanart slowly appears and covers slowly fades, try it and if you don't like it nthg is lost :p)
Image
Image
Image



Enjoy
Reply
New Music wall with fanart transition is smooooooth ! Love it man ,thanks Kisuan.
BTW is it possible if you could either put an option in the settings to get the giant paused back or could show how to , I have also like others asked for help on the main night thread but the suggestion there requires the old bartowski font which unfortunately I do not have .
I did read your previous Post re the Giant Pause ( and your dislike to all things giant size ) but I kinda miss that and without the old night i'm afraid i have no old font either. Am I gonna be giant pause free forever Sad
Reply
Will try to implement GIANT letters option in VideoOSD and DialogSeekbar through Skin settings, think it's pretty easy to do.

You want just the pause or all of them? I'm thinking in something more extreme than original Night, locating them in the middle of the screen, freaking huge in your face!! Why do thing by half right? Seriously, I think it could end nice... Big Grin
Reply
Here you have some examples...

Image

Image

Could go for massive full screen Rofl

Could add some effect like the MUTE sign.
Reply
Laugh the giant Paused Looks Scrumptious.. Freakin' awesome.. and yeah Man go for it ! don't hold back ! why stop at paused ... also maybe make the pause / letters more transparent with a drop shadow or something in the vein of clearart.. Big GrinWink
Reply
Update:

- GIANT Video Font, select through Settings>Skin>Movie/TV>Use GIANT Fonts for Video Player.

- Code cleanup...

Image

Image

Added transparency and little tweak in animations.

Enjoy
Reply
Thanks ! this is most excellent I say Big Grin
Reply
Is anyone else having choppy searching while browsing through their video library? This skin would be perfect but doing fast browsing is a pain. While in showcase view, if I hold down the right arrow key to scan through movies, it'll pause for a second every 6-7 movies. It's much slower compared to regular night skin.
Reply
Will look into it tonight, must say never noticed and code in showcase isn't that much different from original from what I remember.
Reply
It's down to HDD speed. I Have the same issue but mine is down to a slow NAS speed. My Local HDD is fast, but as soon as I get to the part in my library that has content on my NAS, it slows down. This is in part due the "ExtraFanArt" and "ExtraThumbs" folders I Have. XMBC does not cashe them. So they have to be reloaded every time you start skipping along your library.

Well that is what I think it is anyway.
Reply
jz1276 Wrote:Is anyone else having choppy searching while browsing through their video library? This skin would be perfect but doing fast browsing is a pain. While in showcase view, if I hold down the right arrow key to scan through movies, it'll pause for a second every 6-7 movies. It's much slower compared to regular night skin.

Oddsodz Wrote:It's down to HDD speed. I Have the same issue but mine is down to a slow NAS speed. My Local HDD is fast, but as soon as I get to the part in my library that has content on my NAS, it slows down. This is in part due the "ExtraFanArt" and "ExtraThumbs" folders I Have. XBMC does not cashe them. So they have to be reloaded every time you start skipping along your library.

Well that is what I think it is anyway.

Think I see what jz1276 mean.

First both skins behave in the same way with Showcase View and No ExThumb, they are the same code wise. When I underclocked one of my machines I was able to see, as stated before in both skins, a small pause when continuous scroll, this is due to the amount of info that is being displayed, there are a crap load of fields being loaded with no pause. So if you don't have a pretty heavy machine you are always going to notice this.

Then when you enable ExThumbs this behavior gets more evident, as Oddsodz stated this info is not cached by XBMC, if the file is located in a slow HD this is worst. And it's here when you can see a difference between both skins, with Purity displaying worst scrolling, this is due to the extra work of the animation and conditions for the ExThumb not present in Night and with continuous scrolling it gets kinda "stuck".

Anyway, you might find more useful, a better experience and performance by using the Navbar. I'm sorry but I don't see a way of making this better as there isn't another way to code it, unless I remove the animation/conditions, which I won't do as I don't like having the frames all the time and like the animation, so unless more people ask for it I won't change it, but can tell you how too, it's pretty simple, open Viewtype_Showcase.xml and replace this:

Code:
<animation effect="slide" start="600,0" end="0,0" time="800" delay="600" condition="![IsEmpty(Control.GetLabel(8245)) + IsEmpty(Control.GetLabel(8246))]">Conditional</animation>

for

Code:
<animation effect="slide" start="600,0" end="0,0" condition="Skin.HasSetting(extrathumbs)">Conditional</animation>

and delete this two lines

Code:
<animation effect="slide" start="0,0" end="285,0" time="0" condition="Skin.HasSetting(extrathumbs)">Conditional</animation>
Code:
<animation effect="slide" start="0,0" end="-285,0" time="400" delay="500" condition="![IsEmpty(Control.GetLabel(8245)) + IsEmpty(Control.GetLabel(8246))]">Conditional</animation>

Enjoy
Reply
Don't change it. It's a non issue for me. I Know my NAS is slow (old ide 80Gb x2 on a FreeNas with a 10/100Nic. It's slow but works as a torrent box).

It's not a big deal and to lose the animations and stuff would not be good. It's one of the main reasons for the skin. To lose them would be very bad indeed.

If anything. Try and code in a speed limiter for scrolling. This way nobody would ever see this little niggle.
Reply
KiSUAN Wrote:Think I see what jz1276 mean.

First both skins behave in the same way with Showcase View and No ExThumb, they are the same code wise. When I underclocked one of my machines I was able to see, as stated before in both skins, a small pause when continuous scroll, this is due to the amount of info that is being displayed, there are a crap load of fields being loaded with no pause. So if you don't have a pretty heavy machine you are always going to notice this.

Then when you enable ExThumbs this behavior gets more evident, as Oddsodz stated this info is not cached by XBMC, if the file is located in a slow HD this is worst. And it's here when you can see a difference between both skins, with Purity displaying worst scrolling, this is due to the extra work of the animation and conditions for the ExThumb not present in Night and with continuous scrolling it gets kinda "stuck".

Anyway, you might find more useful, a better experience and performance by using the Navbar. I'm sorry but I don't see a way of making this better as there isn't another way to code it, unless I remove the animation/conditions, which I won't do as I don't like having the frames all the time and like the animation, so unless more people ask for it I won't change it, but can tell you how too, it's pretty simple, open Viewtype_Showcase.xml and replace this:

Code:
<animation effect="slide" start="600,0" end="0,0" time="800" delay="600" condition="![IsEmpty(Control.GetLabel(8245)) + IsEmpty(Control.GetLabel(8246))]">Conditional</animation>

for

Code:
<animation effect="slide" start="600,0" end="0,0" condition="Skin.HasSetting(extrathumbs)">Conditional</animation>

and delete this two lines

Code:
<animation effect="slide" start="0,0" end="285,0" time="0" condition="Skin.HasSetting(extrathumbs)">Conditional</animation>
Code:
<animation effect="slide" start="0,0" end="-285,0" time="400" delay="500" condition="![IsEmpty(Control.GetLabel(8245)) + IsEmpty(Control.GetLabel(8246))]">Conditional</animation>

Enjoy

Thanks ... I did what you said and it didnt help at all. My machine is a Zotac ZBOXHD-ID34BR Intel Atom D525 Dual-Core NVIDIA ION2 w/2GB RAM, 250G HDD Blu-ray Mini-PC. Browsing the vids in showcase mode with regular night is flawless but it is still pausing for a second every 7-8 movies with Purity.
Reply
Well, as I stated before with that modifications the View are the same, so the problem isn't cuz Purity, maybe some problem with the guisettings. If you do this you will only loose the settings for Putiry...

Go to X:\Users\User Name\AppData\Roaming\XBMC\userdata

Open "guisettings.xml"

Find every line/setting that has "skin.night.purity" and delete it.

If this doesn't solve the problem I have no idea, beside placebo effect, like I said code in both views is the same so they have to behave in the same way, the problem is somewhere else. Maybe a complete reinstall (erase of user data included) could be fix whatever is wrong, but that would imply much work of course.


Edit

Just thought of another thing, you have "parent folders" enable? or movies without posters?
Reply
KiSUAN Wrote:Well, as I stated before with that modifications the View are the same, so the problem isn't cuz Purity, maybe some problem with the guisettings. If you do this you will only loose the settings for Putiry...

Go to X:\Users\User Name\AppData\Roaming\XBMC\userdata

Open "guisettings.xml"

Find every line/setting that has "skin.night.purity" and delete it.

If this doesn't solve the problem I have no idea, beside placebo effect, like I said code in both views is the same so they have to behave in the same way, the problem is somewhere else. Maybe a complete reinstall (erase of user data included) could be fix whatever is wrong, but that would imply much work of course.


Edit

Just thought of another thing, you have "parent folders" enable? or movies without posters?

OK.. I just tried browsing with a keyboard (I usually use a remote) and it is back to normal although my thumbs dont load up until I stop browsing. The problem only happens when I browse with my remote which is weird because it browses fine with the remote with regular night.
Reply
  •   
  • 1
  • 12
  • 13
  • 14(current)
  • 15
  • 16
  • 18
  •   



Logout Mark Read Team Forum Stats Members Help
[MOD] Night.Purity1
This forum uses Lukasz Tkacz MyBB addons.