[RELEASE] Picasa Desktop
i think the problem is in your settings. if you use an absolut path with "local" setting runs in to that error

in your case you have to set the path to:
the folder "Google/Picasa2Albums" adds the addon self

i uploaded a new version with an updated settings dialog. so its easier to understand to how the config works
I have changed the path as you suggest but I get the same error.
I have also re-downloadad from http://www.da-tom.com/xbmc/plugin.image....esktop.zip, but it is still the same version and same dialog box.
oh sorry, i uploaded the file in the wrong directory
now it should be work
I have downloaded the new version but still no success, whatever path I inset...
please post the new debug log and your settings so i can traceback the error
Here we go:

Database location: local path
Folder (as y ou suggested):

Debug log

15:59:02 T:5936 M:802058240 DEBUG: CGUIMediaWindow::GetDirectory (plugin://plugin.image.picasa-desktop/)
15:59:02 T:5936 M:802058240 DEBUG: ParentPath = [addons://sources/image/]
15:59:02 T:3876 M:802050048 DEBUG: thread start, auto delete: 1
15:59:02 T:3876 M:802045952 DEBUG: XFILE::CPluginDirectory::StartScript - calling plugin Picasa Desktop('plugin://plugin.image.picasa-desktop/','0','')
15:59:02 T:3876 M:802041856 INFO: initializing python engine.
15:59:02 T:3876 M:802041856 DEBUG: Win32DllLoader::Load(special://xbmcbin/system/python/python24.dll)
15:59:02 T:3876 M:801255424 DEBUG: msg: 'import site' failed; use -v for traceback
15:59:02 T:3876 M:801161216 DEBUG: new python thread created. id=1
15:59:02 T:3876 M:801157120 DEBUG: XFILE::CPluginDirectory::WaitOnScriptResult - waiting on the Picasa Desktop plugin...
15:59:02 T:4964 M:801153024 DEBUG: thread start, auto delete: 0
15:59:02 T:4964 M:801148928 DEBUG: Python thread: start processing
15:59:02 T:4964 M:801079296 DEBUG: msg: 'import site' failed; use -v for traceback
15:59:02 T:4964 M:801046528 NOTICE: -->Python Interpreter Initialized<--
15:59:02 T:4964 M:801042432 DEBUG: XBPyThread:Tonguerocess - The source file to load is C:\Users\giorgio\AppData\Roaming\XBMC\addons\plugin.image.picasa-desktop\default.py
15:59:02 T:4964 M:801042432 DEBUG: XBPyThread:Tonguerocess - Setting the Python path to C:\Users\giorgio\AppData\Roaming\XBMC\addons\plugin.image.picasa-desktop;C:\Users\giorgio\AppData\Roaming\XBMC\addons\script.module.dialogaddonscan\lib;C:\Users\giorgio\AppData\Roaming\XBMC\addons\script.module.simplejson\lib;C:\Users\giorgio\AppData\Roaming\XBMC\addons\script.module.beautifulsoup\lib;C:\Program Files\XBMC\addons\script.module.pil\lib;C:\Users\giorgio\AppData\Roaming\XBMC\addons\script.web.viewer\lib;C:\Users\giorgio\AppData\Roaming\XBMC\addons\script.module.elementtree\lib;C:\Program Files\XBMC\addons\script.module.pysqlite\lib;special://xbmc/system/python/DLLs;special://xbmc/system/python/Lib;special://xbmcbin/system/python/python24.zip;special://xbmc/system/python\DLLs;special://xbmc/system/python\lib;special://xbmc/system/python\lib\plat-win;special://xbmc/system/python\lib\lib-tk;C:\Program Files\XBMC
15:59:02 T:4964 M:801042432 DEBUG: XBPyThread:Tonguerocess - Entering source directory C:\Users\giorgio\AppData\Roaming\XBMC\addons\plugin.image.picasa-desktop
15:59:02 T:4964 M:801038336 INFO: -->Python script returned the following error<--
15:59:03 T:4964 M:801038336 ERROR: Error Type: exceptions.SyntaxError
15:59:03 T:4964 M:801038336 ERROR: Error Contents: ('invalid syntax', ('C:\\Users\\giorgio\\AppData\\Roaming\\XBMC\\addons\\plugin.image.picasa-desktop\\default.py', 54, 31, '\t\texcept picasaDesktop_Error as e:\n'))
15:59:03 T:4964 M:801046528 ERROR: File "C:\Users\giorgio\AppData\Roaming\XBMC\addons\plugin.image.picasa-desktop\default.py", line 54
except picasaDesktop_Error as e:
SyntaxError: invalid syntax
15:59:03 T:4964 M:801046528 INFO: -->End of Python script error report<--
15:59:03 T:4964 M:800944128 INFO: Python script stopped
15:59:03 T:4964 M:800944128 DEBUG: Thread 4964 terminating
15:59:03 T:3876 M:800956416 DEBUG: XFILE::CPluginDirectory::WaitOnScriptResult - plugin exited prematurely - terminating
15:59:03 T:5936 M:800948224 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.image.picasa-desktop/
15:59:03 T:5936 M:800944128 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.image.picasa-desktop/) failed
15:59:03 T:5936 M:800944128 DEBUG: CGUIMediaWindow::GetDirectory (addons://sources/image/)
15:59:03 T:5936 M:800944128 DEBUG: ParentPath = []
15:59:03 T:5244 M:800944128 DEBUG: thread start, auto delete: 0
15:59:03 T:5244 M:800944128 DEBUG: Thread 5244 terminating
15:59:03 T:4856 M:800923648 DEBUG: thread start, auto delete: 0
15:59:03 T:4856 M:800903168 DEBUG: Thread 4856 terminating
15:59:03 T:5936 M:800829440 DEBUG: python thread 1 destructed
15:59:03 T:5936 M:800899072 INFO: Loading skin file: DialogKaiToast.xml
15:59:03 T:5936 M:799420416 DEBUG: ------ Window Init (DialogKaiToast.xml) ------
please try the new version and restore the default settings
Done, but still the same error. I guess the new version is 0.0.4
no it should be 0.0.5
I'm still downloading 0.4 from the link http://www.da-tom.com/xbmc/plugin.image....esktop.zip
Maybe you could e-mail me the zip file to
Still no luck. I've seen that the files in the zip file are newer, but the addon is still saying version 0.0.4 and is not working. Before installing, I have de-installed the old version and also deleted the user data...
hi datom, your addon ist working very well on my W7-PC and i love it.
Is it possible to install this adon also on the ATV2? How can i do that?
Thanks for answers.
How is it going with support for linux builds?

Would love to use this! Thx man Wink
Thumbs Up 
LoL Wrote:How is it going with support for linux builds?

Would love to use this! Thx man Wink

the linux version looks good Big Grin
currently testing the addon with ubuntu 11.10 and picasa 3.0 beta

which linux and picasa version do you use?
datom Wrote:the linux version looks good Big Grin
currently testing the addon with ubuntu 11.10 and picasa 3.0 beta

which linux and picasa version do you use?

Hey datom,

Thx for the update! Didn't see it untill now.... my bad :confused2:

I'm running it on:
- XBMC: OpenELEC version (11.0 Beta2 build jan 29 2012)
- Win 7
- Picasa 3.8.0

Problem is now that it says "only default location currently supported" Sad

I would love for this to work because of the same reasons you've described:
click to create albums in picasa and watch it on my tv Big Grin

Hope you can help me out!
Thx, LoL
Thread Rating:
  • 1 Vote(s) - 5 Average

Logout Mark Read Team Forum Stats Members Help
[RELEASE] Picasa Desktop51