•   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 109
  •   
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC
#61
Desensitized Wrote:Hi, I've been trying to get this up and running. I had it runing for a while but I kept having the iewraper.exe crashing whenever i would press the "F" key to go into full screen.

Somewhere along the way i accedently delete my userinfo.txt and now the script does not work. I've since my main xbmc box is on a linux machine (i'm testing the windows version for netfilx), i reinstalled xbmc completely and I still can't get the add-in to work anymore.

Any help would me much appreciated

recreate that file, with it empty. The next release will fix when that file is missing. (code in already in there, waiting pull to xbmc repo)
Reply
#62
I am running XBMC 10.0 on my windows vista pc and love it. I use monitor 1 for configuration and web browsing. I have my second monitor out hooked to my HD flat screen for viewing. It has mostly worked out well for me although there are a few things in XBMC that are not multi-monitor aware. I was very excited when i saw this new plugin as it is almost exactly what i was looking for. the only problem is I have only been able to get it to work on monitor 1. is it possible to configure it for monitor 2? I thought about trying to adjust the command line settings but IE does not support a command line parameter for monitor. I also looked to see if i could find the source to iewrap.exe with the idea i might take a stab at adding it. any suggestions would be appreciated.
thanks
Tony
Reply
#63
thanks for this great plug-in. I was wondering, though...when I click on a TV show, it doesn't take me to a selection screen to pick an individual episode, it just kicks off the first episode. Do I have something configured wrong, or is this a limitation of the plugin?

Thanks again!
Reply
#64
I see that there's an "auto-expend TV episodes" option, which brings out all of the episodes of every series in the main list. Is that the only way to get to an individual TV episode?
Reply
#65
fekker Wrote:recreate that file, with it empty. The next release will fix when that file is missing. (code in already in there, waiting pull to xbmc repo)

I tried that. I have and empty file and still get a script error. Here's my log

Code:
04:58:38 T:4476 M:1036324864  NOTICE: loading special://masterprofile/guisettings.xml
04:58:39 T:4476 M:1036214272  NOTICE: Getting hardware information now...
04:58:39 T:4476 M:1036214272  NOTICE: Checking resolution 12
04:58:39 T:4476 M:1036201984  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
04:58:39 T:4476 M:1036193792  NOTICE: Loaded playercorefactory configuration
04:58:39 T:4476 M:1036193792  NOTICE: Loading player core factory settings from special://profile/playercorefactory.xml.
04:58:39 T:4476 M:1036181504  NOTICE: Loaded playercorefactory configuration
04:58:39 T:4476 M:1036173312  NOTICE: Loaded advancedsettings.xml from special://profile/advancedsettings.xml
04:58:39 T:4476 M:1036173312  NOTICE: Contents of special://profile/advancedsettings.xml are...
                                            <advancedsettings>
                                              <videoextensions>
                                                <add>.html</add>
                                              </videoextensions>
                                            </advancedsettings>
04:58:39 T:4476 M:1036165120  NOTICE: Getting hardware information now...
04:58:39 T:4476 M:1036165120  NOTICE: Checking resolution 12
04:58:39 T:4476 M:1036165120  NOTICE: Default DVD Player: dvdplayer
04:58:39 T:4476 M:1036165120  NOTICE: Default Video Player: dvdplayer
04:58:39 T:4476 M:1036165120  NOTICE: Default Audio Player: paplayer
04:58:39 T:4476 M:1036161024  NOTICE: Loading media sources from special://masterprofile/sources.xml
04:58:40 T:4476 M:1022259200  NOTICE: initializing playlistplayer
04:58:40 T:4476 M:1022255104  NOTICE: DONE initializing playlistplayer
04:58:40 T:4476 M:1017319424  NOTICE: initialize done
04:58:40 T:4476 M:1017319424  NOTICE: Running the application...
04:58:40 T:4476 M:1017303040  NOTICE: ES: Starting event server
04:58:40 T:2548 M:1017294848  NOTICE: ES: Starting UDP Event server on 127.0.0.1:9777
04:58:40 T:2548 M:1017270272  NOTICE: UDP: Listening on port 9777
04:58:46 T:4476 M:1002901504 WARNING: CUtil::GetMatchingSource... no matching source found for [Addons]
04:58:47 T:1492 M:1010954240  NOTICE: -->Python Interpreter Initialized<--
04:58:48 T:1492 M:1010352128   ERROR: Win32DllLoader::Load: Unable to load special://xbmc/system/python/DLLs\_ssl.pyd (5)
04:58:48 T:1492 M:1010352128   ERROR: LoadLibrary('_ssl.pyd') failed
04:58:49 T:1492 M:1008427008  NOTICE: ##########################################################
04:58:49 T:1492 M:1008427008  NOTICE: Mode: 0
04:58:49 T:1492 M:1008427008  NOTICE: Arg1: 0
04:58:49 T:1492 M:1008427008  NOTICE: Arg2:
04:58:49 T:1492 M:1008427008  NOTICE: ##########################################################
04:58:50 T:5704 M:1009647616  NOTICE: -->Python Interpreter Initialized<--
04:58:51 T:5704 M:1009356800   ERROR: Win32DllLoader::Load: Unable to load special://xbmc/system/python/DLLs\_ssl.pyd (5)
04:58:51 T:5704 M:1009356800   ERROR: LoadLibrary('_ssl.pyd') failed
04:58:52 T:5704 M:1009975296  NOTICE: ##########################################################
04:58:52 T:5704 M:1009975296  NOTICE: Mode: 10
04:58:52 T:5704 M:1009975296  NOTICE: Arg1: 0
04:58:52 T:5704 M:1009975296  NOTICE: Arg2: ?mode=10
04:58:52 T:5704 M:1009975296  NOTICE: ##########################################################
04:58:52 T:5704 M:1009942528  NOTICE: couldn't load user information from userinfo.properties file
04:58:52 T:5704 M:1009942528  NOTICE: .. getAuth called ..
04:58:52 T:5704 M:1009942528  NOTICE: OSX Setting is set to: False
04:58:52 T:5704 M:1009942528  NOTICE: .. user configured ..
04:58:52 T:5704 M:1009332224   ERROR: Error Type: exceptions.KeyError
04:58:52 T:5704 M:1009332224   ERROR: Error Contents: oauth_token
04:58:52 T:5704 M:1009233920   ERROR: Traceback (most recent call last):
                                              File "C:\Users\Media\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\default.py", line 26, in ?
                                                import resources.lib.menu as menu
                                              File "C:\Users\Media\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\menu.py", line 147, in ?
                                                getInstantQueue()
                                              File "C:\Users\Media\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 745, in getInstantQueue
                                                initApp()
                                              File "C:\Users\Media\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 740, in initApp
                                                user = getAuth(netflixClient,VERBOSE_USER_LOG)
                                              File "C:\Users\Media\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 90, in getAuth
                                                (tok, url) = netflix.user.getRequestToken()
                                              File "C:\Users\Media\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\Netflix.py", line 47, in getRequestToken
                                                requestToken = oauth.OAuthToken.from_string(response.read())
                                              File "C:\Users\Media\AppData\Roaming\XBMC\addons\plugin.video.xbmcflicks\resources\lib\oauth.py", line 142, in from_string
                                                key = params['oauth_token'][0]
                                            KeyError: oauth_token
04:58:52 T:4476 M:1009168384   ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.xbmcflicks/?mode=10
04:58:52 T:4476 M:1009168384   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.xbmcflicks/?mode=10) failed
04:58:55 T:4476 M:1009393664  NOTICE: Storing total System Uptime
04:58:55 T:4476 M:1009471488  NOTICE: Saving settings
04:58:55 T:4476 M:1009422336  NOTICE: stop all
04:58:55 T:4476 M:1009422336  NOTICE: ES: Stopping event server
04:58:55 T:2548 M:1009369088  NOTICE: ES: UDP Event server stopped
04:58:55 T:4476 M:1009422336  NOTICE: stop sap announcement listener
04:58:55 T:4476 M:1009422336  NOTICE: clean cached files!
04:58:55 T:4476 M:1009418240  NOTICE: unload skin
04:58:55 T:4476 M:1012908032  NOTICE: stop python
04:58:56 T:4476 M:1022119936  NOTICE: stopped
04:58:56 T:4476 M:1022132224  NOTICE: destroy
04:58:56 T:4476 M:1022124032  NOTICE: unload sections
Reply
#66
the iewrap is just a windows form with a web browser control dropped on it and the title bar hidden, a button was added to the top left that closes the web browser control and exits the form. The keypress hooks aren't working right so i'll have to rework those

code:
Code:
using System;
using System.Collections.Generic;
using System.Windows.Forms;

namespace iebrowser
{
    static class Program
    {
        /// <summary>
        /// The main entry point for the application.
        /// </summary>
        [STAThread]
        static void Main(string[] args)
        {
            Application.EnableVisualStyles();
            Application.SetCompatibleTextRenderingDefault(false);
            Application.Run(new frmMain(args));
        }
    }
}
and then in the forms init I added
Code:
string url = "";
            foreach (string arg in ARGS)
            {
                if (arg.Contains("showscroll"))
                {
                    webBrowser1.ScrollBarsEnabled = true;
                }
                if (arg.Contains("nobutton"))
                {
                    btnExit.Visible = false;
                }
                if (arg.Contains("notop"))
                {
                    this.TopMost = false;
                }

                if (arg.Contains(".htm"))
                {
                    url = arg;
                }
            }
            if (!string.IsNullOrEmpty(url))
            {
                webBrowser1.Navigate(url);
            }
Reply
#67
Wargazm Wrote:I see that there's an "auto-expend TV episodes" option, which brings out all of the episodes of every series in the main list. Is that the only way to get to an individual TV episode?

The tv show as a folder part is incomplete, this would be along the lines of what your asking, it's slated to be added, just short on time atm.

Code:
    Quote:
Originally Posted by fekker View Post
recreate that file, with it empty. The next release will fix when that file is missing. (code in already in there, waiting pull to xbmc repo)
I tried that. I have and empty file and still get a script error. Here's my log
1.0.7 is now in the official repo for xbmc, it includes fixes to where the data is stored which can cause the error your having.

The newer version will require that you re-auth with netflix as the data is now stored in the addons_data folder.
Reply
#68
fekker Wrote:The tv show as a folder part is incomplete, this would be along the lines of what your asking, it's slated to be added, just short on time atm.

thanks very much! I'll keep an eye on development.
Reply
#69
Hey fekker, here's an updated version of the icon.png I posted earlier:

Image
Reply
#70
Great Add-on!!! Awesome job!! Your add-on is working great for me... my problem is Silverlight and my Atom 330. When the app brings up IE and the video start it will stutter something terrible. I have to stop and rewind for it to run smoothly (works most of the time). This may not be the correct area to ask this question, but is anyone else have this problem? Is their anything I can do to fix it? I run Netflix on my Xbox360 and Vizio TV with no issue, just have the issue on my HTPC. Thanks!!
Reply
#71
fekker,

I'm running into the exact same problem igotdvds ran into. The error's in the log are identical minus file location. I've got both XML files in the resources folder of the plugin, I've got playback pointed to IE, and I still get the error. Is there something I'm missing somewhere?
Reply
#72
t_buzz Wrote:fekker,

I'm running into the exact same problem igotdvds ran into. The error's in the log are identical minus file location. I've got both XML files in the resources folder of the plugin, I've got playback pointed to IE, and I still get the error. Is there something I'm missing somewhere?

make sure the path in the playercorefactory.xml is the right path for your OS, if it's 32 bit, c:\program files.. for 64 bit, it's c:\program files (x86)

if that don't work, post a debug log for inspection... must be dharma, latest rev is 1.0.7 from xbmc addon repo, make sure your using the updated version
Reply
#73
Quote:20:53:17 T:7364 M:915451904 NOTICE: DVDPlayer: Opening: C:\Users\Josh\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\60021515.html
20:53:17 T:7364 M:915451904 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
20:53:17 T:5272 M:915439616 NOTICE: Creating InputStream
20:53:17 T:5272 M:915439616 NOTICE: Creating Demuxer
20:53:17 T:5272 M:915369984 ERROR: CDVDDemuxFFmpeg::Open - error probing input format, C:\Users\Josh\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\60021515.html
20:53:17 T:5272 M:915365888 ERROR: CDVDPlayer::OpenDemuxStream - Error creating demuxer
20:53:17 T:5272 M:915365888 NOTICE: CDVDPlayer::OnExit()
20:53:17 T:5272 M:915365888 NOTICE: CDVDPlayer::OnExit() deleting input stream
20:53:17 T:7364 M:915365888 ERROR: Playlist Player: skipping unplayable item: 0, path [C:\Users\Josh\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\links\60021515.html]
20:53:17 T:7364 M:915394560 NOTICE: CDVDPlayer::CloseFile()
20:53:17 T:7364 M:915394560 WARNING: CDVDMessageQueue(player):Tongueut MSGQ_NOT_INITIALIZED
20:53:17 T:7364 M:915394560 NOTICE: DVDPlayer: waiting for threads to exit
20:53:17 T:7364 M:915394560 NOTICE: DVDPlayer: finished waiting

There's the last attempt from the log.

advancedsettings.xml
Quote:<advancedsettings>
<videoextensions>
<add>.html</add>
</videoextensions>
</advancedsettings>

playercorefactory.xml
Quote:<playercorefactory>
<players>
<player name="IE" type="ExternalPlayer">
<filename>c:\Program Files\Internet Explorer\iexplore.exe</filename>
<args>-k "{1}"</args>
<hidexbmc>false</hidexbmc>
<hideconsole>false</hideconsole>
<warpcursor>none</warpcursor>
</player>
</players>

<rules action="prepend">
<rule name="html" filetypes="html" player="IE" />
</rules>
</playercorefactory>

That is the right directory for IE, I'm using 32bit Vista Home Premium, running XBMC 10.0 with MediaStream_redux skin running.

This is the first script or add-on I've ran into issues with ever, and I've been running XBMC for over a year now.

EDIT: And I'm using 1.07, taken directly from the Add-Ons in XBMC.
Reply
#74
t_buzz Wrote:There's the last attempt from the log.

advancedsettings.xml


playercorefactory.xml


That is the right directory for IE, I'm using 32bit Vista Home Premium, running XBMC 10.0 with MediaStream_redux skin running.

This is the first script or add-on I've ran into issues with ever, and I've been running XBMC for over a year now.

EDIT: And I'm using 1.07, taken directly from the Add-Ons in XBMC.

This is one of those times where a full debug log would be great, but i'll just have ya look in yours for these lines.. (similar to)

Code:
12:56:14 T:2264 M:4294967295  NOTICE: Checking resolution 11
12:56:14 T:2264 M:4294967295  NOTICE: Loading player core factory settings from special://xbmc/system/playercorefactory.xml.
12:56:14 T:2264 M:4294967295  NOTICE: Loaded playercorefactory configuration
12:56:14 T:2264 M:4294967295  NOTICE: Loading player core factory settings from special://profile/playercorefactory.xml.
12:56:14 T:2264 M:4294967295  NOTICE: Loaded playercorefactory configuration
12:56:14 T:2264 M:4294967295  NOTICE: Loaded advancedsettings.xml from special://profile/advancedsettings.xml

more then likely your two files are not in the correct location that they need to be in.
Reply
#75
I am very excited about this Plugin thanks you very much, I am however having a problem getting the plugin to work here is my log file of what happens, when I try to load any of the movie menus in the plugin I get script failed.

XBMC Log
----------
14:47:33 T:1912 M:4294967295 NOTICE: Getting hardware information now...
14:47:33 T:1912 M:4294967295 NOTICE: Checking resolution 11
14:47:33 T:1912 M:4294967295 NOTICE: Default DVD Player: dvdplayer
14:47:33 T:1912 M:4294967295 NOTICE: Default Video Player: dvdplayer
14:47:33 T:1912 M:4294967295 NOTICE: Default Audio Player: paplayer
14:47:33 T:1912 M:4294967295 NOTICE: Loading media sources from special://masterprofile/sources.xml
14:47:34 T:1912 M:4294967295 NOTICE: initializing playlistplayer
14:47:34 T:1912 M:4294967295 NOTICE: DONE initializing playlistplayer
14:47:34 T:1912 M:4294967295 NOTICE: initialize done
14:47:34 T:1912 M:4294967295 NOTICE: Running the application...
14:47:34 T:1912 M:4294967295 NOTICE: ES: Starting event server
14:47:34 T:4864 M:4294967295 NOTICE: ES: Starting UDP Event server on 127.0.0.1:9777
14:47:34 T:4864 M:4294967295 NOTICE: UDP: Listening on port 9777
14:47:41 T:3568 M:4294967295 NOTICE: -->Python Interpreter Initialized<--
14:47:41 T:3568 M:4294967295 NOTICE: ##########################################################
14:47:41 T:3568 M:4294967295 NOTICE: Mode: 0
14:47:41 T:3568 M:4294967295 NOTICE: Arg1: 0
14:47:41 T:3568 M:4294967295 NOTICE: Arg2:
14:47:41 T:3568 M:4294967295 NOTICE: ##########################################################
14:47:44 T:2300 M:4294967295 NOTICE: -->Python Interpreter Initialized<--
14:47:44 T:2300 M:4294967295 NOTICE: ##########################################################
14:47:44 T:2300 M:4294967295 NOTICE: Mode: 30
14:47:44 T:2300 M:4294967295 NOTICE: Arg1: 0
14:47:44 T:2300 M:4294967295 NOTICE: Arg2: ?mode=30
14:47:44 T:2300 M:4294967295 NOTICE: ##########################################################
14:47:44 T:2300 M:4294967295 NOTICE: root folder: special://home/addons/plugin.video.xbmcflicks/
14:47:44 T:2300 M:4294967295 NOTICE: working folder: special://profile/addon_data/plugin.video.xbmcflicks/
14:47:44 T:2300 M:4294967295 NOTICE: real link path: C:\Program Files (x86)\XBMC\portable_data\userdata\addon_data\plugin.video.xbmcflicks\links\
14:47:44 T:2300 M:4294967295 NOTICE: image folder: special://home/addons/plugin.video.xbmcflicks/resources/
14:47:44 T:2300 M:4294967295 NOTICE: userinfo folder: special://profile/addon_data/plugin.video.xbmcflicks/
14:47:44 T:2300 M:4294967295 NOTICE: USER INFO FILE LOC: special://profile/addon_data/plugin.video.xbmcflicks/userinfo.txt
14:47:44 T:2300 M:4294967295 NOTICE: couldn't load user information from userinfo.properties file
14:47:44 T:2300 M:4294967295 NOTICE: .. getAuth called ..
14:47:44 T:2300 M:4294967295 NOTICE: OSX Setting is set to: False
14:47:44 T:2300 M:4294967295 NOTICE: .. user configured ..
14:47:45 T:2300 M:4294967295 ERROR: Error Type: exceptions.KeyError
14:47:45 T:2300 M:4294967295 ERROR: Error Contents: oauth_token
14:47:45 T:2300 M:4294967295 ERROR: Traceback (most recent call last):
File "C:\Program Files (x86)\XBMC\portable_data\addons\plugin.video.xbmcflicks\default.py", line 26, in ?
import resources.lib.menu as menu
File "C:\Program Files (x86)\XBMC\portable_data\addons\plugin.video.xbmcflicks\resources\lib\menu.py", line 225, in ?
getNewToWatchInstant()
File "C:\Program Files (x86)\XBMC\portable_data\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 780, in getNewToWatchInstant
initApp()
File "C:\Program Files (x86)\XBMC\portable_data\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 757, in initApp
user = getAuth(netflixClient,VERBOSE_USER_LOG)
File "C:\Program Files (x86)\XBMC\portable_data\addons\plugin.video.xbmcflicks\resources\lib\iqueue.py", line 60, in getAuth
(tok, url) = netflix.user.getRequestToken()
File "C:\Program Files (x86)\XBMC\portable_data\addons\plugin.video.xbmcflicks\resources\lib\Netflix.py", line 47, in getRequestToken
requestToken = oauth.OAuthToken.from_string(response.read())
File "C:\Program Files (x86)\XBMC\portable_data\addons\plugin.video.xbmcflicks\resources\lib\oauth.py", line 142, in from_string
key = params['oauth_token'][0]
KeyError: oauth_token
14:47:45 T:1912 M:4294967295 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.xbmcflicks/?mode=30
14:47:45 T:1912 M:4294967295 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.xbmcflicks/?mode=30) failed
14:47:45 T:4876 M:4294967295 NOTICE: -->Python Interpreter Initialized<--
14:47:45 T:4876 M:4294967295 NOTICE: ##########################################################
14:47:45 T:4876 M:4294967295 NOTICE: Mode: 0
14:47:45 T:4876 M:4294967295 NOTICE: Arg1: 0
14:47:45 T:4876 M:4294967295 NOTICE: Arg2:
14:47:45 T:4876 M:4294967295 NOTICE: ##########################################################
Reply
  •   
  • 1
  • 3
  • 4
  • 5(current)
  • 6
  • 7
  • 109
  •   
 
Thread Rating:
  • 16 Vote(s) - 4.44 Average



Logout Mark Read Team Forum Stats Members Help
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC4.4416