20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

  •   
  • 1
  • 74
  • 75
  • 76(current)
  • 77
  • 78
  • 109
  •   
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC
Ok so I figured out why ... I was editing the wrong file. But I have another issue now. I cannot get firefox to load netflix. When I try to launch a movie it launches firefox in normal mode (not fullscreen) and goes to the default firefox page. What arguments do I need to fix this? Thanks!
Reply
Ok nevermind I decided to go with the iewrap method :-p ... Sorry for all of the posts :-D ... One problem with the IEwrap method ... it won't load on my secondary monitor... Anyone know how I can do this? I tried opening IEwrap.exe and moving it over to the other screen and closing it like you can with IE but it didn't work.... Thanks in advance! Sorry about all of the questions :-p
Reply
(2012-11-17, 03:55)mjcassel Wrote: I am having trouble getting XBMC Flicks working on Eden. The authorization launches; I am able to tell Netflix to link to XBMC. However, the userinfo.txt file remains blank. Also, there is a script error when I try to proceed into Netflix. Here is my log:

I have an identical problem. Can't figure out how to solve it. I have done all of the fixes since page 100.
Reply
Having a problem here.
I pointed the app to Firefox. It opens it no problem.
In XBMC it says 'click OK after you have finished the link in your browser window'
Not even sure exactly what that means... but I logged into Netflix assuming this it what it meant...

When I go back to XBMC I click OK on the remote and get...
'Script failed Confusedpudsdude: XBMC-flicks-A644263

I know I am doing something wrong but have no clue as to what....

Please help!!
Reply
(2012-11-20, 04:27)huttdes Wrote: Having a problem here.
I pointed the app to Firefox. It opens it no problem.
In XBMC it says 'click OK after you have finished the link in your browser window'
Not even sure exactly what that means... but I logged into Netflix assuming this it what it meant...

When I go back to XBMC I click OK on the remote and get...
'Script failed Confusedpudsdude: XBMC-flicks-A644263

I know I am doing something wrong but have no clue as to what....

Please help!!

Same as me and the other guy. I fixed it by having had a working install on my laptop in advance and moving over the userinfo.txt from that computer(it was blank on my desktop). I'd share it if I weren't pretty sure that it has some information of mine in it. Not sure if this is a Windows 8 issue or what.

The app works for me now, assuming the way the app is supposed to work is doing the search through xbmc and then spawning a browser for the actual viewing. A bit annoying because it doesn't work with the XBMC remote but hey, beggars can't be choosers, I'm very grateful someone made an add-on like this at all.
Reply
Having problmes with "browse by genre" all genres are there, but when opening it there is no listing?

I use the US verson of netflix from norway. Useing unblockus.com, And netflix us verson works great on other devices. If i use it in a browser it works perfect.

But looks like the genres inside xbmc not match the netflix genres.

Hopeing to get some tips on how to work this out? Is there a way to change genres somewhere to get it working?

Reply
I recently redid my whole HTPC setup and now for the life of me I cannot get this plugin to work. XMBC logs can be found here (http://pastebin.com/zmcfqQqe). Any help would be appreciated.

Thanks
Reply
Quote:Same as me and the other guy. I fixed it by having had a working install on my laptop in advance and moving over the userinfo.txt from that computer(it was blank on my desktop). I'd share it if I weren't pretty sure that it has some information of mine in it. Not sure if this is a Windows 8 issue or what.

The app works for me now, assuming the way the app is supposed to work is doing the search through xbmc and then spawning a browser for the actual viewing. A bit annoying because it doesn't work with the XBMC remote but hey, beggars can't be choosers, I'm very grateful someone made an add-on like this at all.

Well, I can choose a little bit.... if I can't get it to work properly through and with my XBMC remote then I may as well just run it right from the browser and use my Gyration mouse/remote.
This would be an incredible app if it just ran inside XBMC... if that's even possibleHuh

You mention Win8... I'm running 7 64bit with Eden.

Reply
Ubuntu PPA now available
http://www.iheartubuntu.com/2012/11/ppa-...p-app.html
Reply
Add one more user to the Script Failed pile; same result with installs of XBMC on two different machines. For the heck of it I tried installing the previous version, 10.1, as well, and got the same result. (Install XBMC Flicks, load up, tell Netflix to authorize, click OK in XBMC, brief pause and script error, which a blank userinfo file in the addon_data folder.

Seems like if I could just manually edit the userinfo.txt file (which keeps coming up blank) things would smooth over. Tanikaze, agree there's probably some personal numbers in the working file you have that probably shouldn't get shared; however, could you provide a copy with the numbers x'd over? Just sort of flailing about here, but I thought it might be worth dropping in the 'secret' and 'key' numbers extracted from the log file on my machine.

Even if it's a really stupid idea I'd be happy to try it and report back. There doesn't seem to be any other support outside this forum.
Reply
Hi guys, I think im having a similar issue to Sirrico, when I try to logon to netflix I get throught the API screen and then *boom* I get script failed..
I end up with an empty userinfo file in the addon_data_folder which I think is the issue..

I'm running eden and below is the LOG data.. , any ideas ?

Thx

09:02:01 T:5620 NOTICE: USER INFO FILE LOC: C:\Users\gday\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks\userinfo.txt
09:02:01 T:5620 NOTICE: couldn't load user information from userinfo.txt file
09:02:01 T:5620 NOTICE: .. getAuth called ..
09:02:01 T:5620 NOTICE: OSX Setting is set to: False
09:02:01 T:5620 NOTICE: .. user configured ..
09:02:03 T:5620 NOTICE: Token did not contain any errors
09:02:03 T:5620 NOTICE: browser open has completed
09:02:07 T:5200 ERROR: Control 1 in window 10099 has been asked to focus, but it can't
09:02:12 T:5620 NOTICE: The dialog was displayed, hopefully you read the text and waited until you authorized it before clicking ok.
09:02:12 T:5620 ERROR: Error Type: <class 'httplib.BadStatusLine'>
09:02:12 T:5620 ERROR: Error Contents:
09:02:12 T:5620 ERROR: Traceback (most recent call last):
File "C:\Users\gday\AppData\Roaming\XBMC\addons\spudsdude-XBMC-Flicks-a644263\default.py", line 26, in <module>
import resources.lib.menu as menu
File "C:\Users\gday\AppData\Roaming\XBMC\addons\spudsdude-XBMC-Flicks-a644263\resources\lib\menu.py", line 474, in <module>
getInstantQueue()
File "C:\Users\gday\AppData\Roaming\XBMC\addons\spudsdude-XBMC-Flicks-a644263\resources\lib\iqueue.py", line 1379, in getInstantQueue
initApp()
File "C:\Users\gday\AppData\Roaming\XBMC\addons\spudsdude-XBMC-Flicks-a644263\resources\lib\iqueue.py", line 1374, in initApp
user = getAuth(netflixClient,VERBOSE_USER_LOG)
File "C:\Users\gday\AppData\Roaming\XBMC\addons\spudsdude-XBMC-Flicks-a644263\resources\lib\iqueue.py", line 85, in getAuth
tok = netflix.user.getAccessToken( MY_USER['request'] )
File "C:\Users\gday\AppData\Roaming\XBMC\addons\spudsdude-XBMC-Flicks-a644263\resources\lib\Netflix.py", line 74, in getAccessToken
response = client.connection.getresponse()
File "C:\Program Files\XBMC Eden\system\python\Lib\httplib.py", line 990, in getresponse
response.begin()
File "C:\Program Files\XBMC Eden\system\python\Lib\httplib.py", line 391, in begin
version, status, reason = self._read_status()
File "C:\Program Files\XBMC Eden\system\python\Lib\httplib.py", line 355, in _read_status
raise BadStatusLine(line)
BadStatusLine
09:02:12 T:5200 ERROR: XFILE::CDirectory::GetDirectory - Error getting plugin://plugin.video.xbmcflicks/?mode=10
09:02:12 T:5200 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.xbmcflicks/?mode=10) failed
Reply
That looks like about the same result I get in my log file, along with the blank userinfo.

Yesterday it looks like Tanikaze (page 113, timestamp 7:09) managed to get around it by replacing the blank userinfo.txt with one from a working system. So perhaps if we could figure out the syntax for that file and input the secret and key codes that you can get from the verbose logfile into it, maybe we can bypass whatever isn't writing to it in the setup process?
Reply
(2012-10-30, 00:44)yabsie Wrote:
(2012-10-29, 04:21)yabsie Wrote: [quote='elmerohueso' pid='1219366' dateline='1350855510']
Known issues. Fixes from PatDavid start on page 100.

Edit reason: Removed enormous quote and expired link.

...
....
...



I dont know python well and I don't know this code at all, so any help would grand.

Since there appears to be no active development on this, I decided to bite the bullet and setup a python environment hooked up the debugger and tried to figure it out.

So it look like the Genre and experimental search are suing the oData APi and the other code is using the older version of the api.

I managed to figure out the proper regular expression to get the ID out of the matcher that was throwing the "CRITICAL" only to discover that the ID's returned by the odata API are different than the ID used by the player. the odata ids are 6 digit alpha numeric and the 'old' IDs are 10 digit numeric, so even though I manage to fill my lists in the genre search I dont have the 'real' ID for movie playback

so sad

So we need to
1) figure out how to map odata IDs to original IDs
2) figure out how to play via an odata id
3) figure out how to take the other meta data (year title etc) and do another search on the old school api to get the old id

I have googled a few hours worth trying to figure out 1 and/or 2 but no luck, but I am tired. so i am stopping for a while.

I have a full time coding job, a wife and 3 kids one of you young pups with more time needs to pick this up.......


oh yeah here is my code change if anyone cares....
figure out where it goes in iqueue.py

Code:
matchIds4 = re.search(r'"type": "NetflixCatalog.Model.BoxArt".*?}, ".*Url": "http://.*?.nflximg.com/us/boxshots/(small|tiny|large|ghd|small_epx|ghd_epx|large_epx|88_epx|tiny_epx)/(\d{1,15}).jpg"', curQueueItem, re.DOTALL | re.IGNORECASE | re.MULTILINE)
                    if matchIds4:
                        #print "id regex: matched matchIds4"
                        curX.FullId = matchIds4.group(1)
                        curX.ID = matchIds4.group(2)
                    else:
                        print "id regex: matched matchIds5"
                        matchIds5 = re.search(r'http.*Catalog/Titles\(\'(.*)\'\).*',curQueueItem, re.DOTALL | re.IGNORECASE | re.MULTILINE)
                        if matchIds5:
                            curX.ID = matchIds5.group(1)
                        else:
                            print "id regex: matched failed after matchIds5"
                            print "CRITICAL ERROR: Unable to parse ID of item. Stopping parse..."
                            return curX

(2012-11-20, 09:25)knutmw Wrote: Having problmes with "browse by genre" all genres are there, but when opening it there is no listing?

I use the US verson of netflix from norway. Useing unblockus.com, And netflix us verson works great on other devices. If i use it in a browser it works perfect.

But looks like the genres inside xbmc not match the netflix genres.

Hopeing to get some tips on how to work this out? Is there a way to change genres somewhere to get it working?

look up to my other resent post
Reply
(2012-11-17, 03:55)mjcassel Wrote: I am having trouble getting XBMC Flicks working on Eden. The authorization launches; I am able to tell Netflix to link to XBMC. However, the userinfo.txt file remains blank. Also, there is a script error when I try to proceed into Netflix. Here is my log:

19:45:01 T:4624 NOTICE: and run again.
19:45:01 T:4624 NOTICE: browser open has completed
19:45:30 T:4624 NOTICE: The dialog was displayed, hopefully you read the text and waited until you authorized it before clicking ok.
19:45:30 T:4624 NOTICE: user key set to: xxxxxxxxxxxxxx
19:45:30 T:4624 NOTICE: user secret set to:xxxxxxxxxxxxxx
19:45:30 T:4624 ERROR: Error Type: <class 'httplib.BadStatusLine'>
1

Not sure what the root cause of the badstatusline thingy is but i did resolve it for myself.

my main media pc has xbmc with xmbcflix on it, and it 'works' (i.e. runs without the badstatusline dealio), so I installed xbmc and xmbcflix on my dev box and no dice.

What i discovered by reading in this forum that there is a userinfo.txt file in the appdata directory. mine ius here:
C:\Users\XXXXXXX\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.xbmcflicks

However its WASNT there, so I copied the file over from my htpc box to my dev box and yup it worked, no more bad status line. Ithink it may have something to do with win7 protecting me from myself and not letting the file be written (knobs)

The problem is if you dont know what values to put into that file, you are stuck, the contents of mine are

requestKey=XXXXXXXXXXXXXXXX
requestSecret=YYYYYYYYYYYYYY
accessKey=ZZZZZZZZZZZZZZZZZZZZZZ
accessSecret=OOOOOOOOOOOOOOOOOO

now obviously those are not the real values, but I bet if you cranked up debugging you can find out what yours should be in the log.

I have no idea if this is any hekp to anyone, but there it is. Have a nice day.







Reply
That helps quite a bit actually. At least, it's gotten me a lot farther than I was before.

So, for anyone else that wanders by, here's the workaround.
-Install XBMCFlicks. Before trying it, right click the Add-On, goto Add-On Settings, Debugging Tab, and enable both options.
-Open XBMCFlicks, tell your browser okay, tell XBMC okay, enjoy the perpetual ping of failure. Close XBMC.
-Dig up your logfile, which (in Windows 7) is under username/AppData/Roaming/XBMC. It'll be the most recently modified version.
-Open it up (notepad is fine) and run a ctrl-f for 'key'; a couple clicks should take you to a line like this:
> NOTICE: and then put this key / secret in MY_USER.request: <
-Under that are two alphanumeric codes labeled 'key' and 'secret'. Copy them over, keep them secret, keep them safe, etc..
-Bounce over your userinfo file, under appdata/roaming/XBMC/userdata/addon_data/plugin.video.xbmcflicks. If there's no userinfo.txt file, I would expect it would work just fine if you created one.
-Open userinfo.txt in note pad, and copy in yabsie's syntax from above.
requestKey=XXXXXXXXXXXXXXXX
requestSecret=YYYYYYYYYYYYYY
accessKey=ZZZZZZZZZZZZZZZZZZZZZZ
accessSecret=OOOOOOOOOOOOOOOOOO
-Replace the xxxx's and zzzz's with the longer code labeled Key. Replace the YYYY's and OOOO's with the shorter code labeled secret. No spaces or apostrophe's needed apparently.
-Save, relaunch XBMC, and enjoy your hopefully now successful authentication.

Now, the bad news; while I expect most of the fault here lies with Netflix, and I'm sure whoever's putting in their valuable time to code this thing is facing an uphill struggle, the level of accessibility from with in XBMC is pretty bare. So far all that works for me are the New Arrivals sub-sections. Everything else returns blank, except for Search, which returns a script error that I'm in no mood to start troubleshooting now. I can play titles from within New Arrivals, but afterwards I have to Alt-F4 out or Alt-Tab back, due to Netflix having to run inside a full screen browser windows. That's just a disclosure from my end; maybe someone else will have better luck.
Reply
  •   
  • 1
  • 74
  • 75
  • 76(current)
  • 77
  • 78
  • 109
  •   
 
Thread Rating:
  • 16 Vote(s) - 4.44 Average



Logout Mark Read Team Forum Stats Members Help
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC4.4416