20 Nov 2019 - TVDB Scraper v3.2.0 is now available which reinstates scraping. TVDB are still in the process of fixing a number of bugs so there may still be further breakages. See this post. 2901570 (post)

  •   
  • 1
  • 82
  • 83
  • 84(current)
  • 85
  • 86
  • 109
  •   
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC
I got this working, but only the "Top 25" and "New Arrivals" works. What needs done in order to make the add-on fully functional? Instant Queue as well as all the Genres are blank, and search returns a script error. Right now I'm on 10.1, Win7 64-bit, XBMC Flicks 1.0.23.
Reply
The theme seems to be presenting itself a little more clearly. I'm glad I'm not the only one to have this problem: I can get into the app fine, I can get the Top 25 and New Arrivals, but the Instant Queue stuff is emply, and I get a script error on search. Yes, one of the main problems as I see it is the userinfo file is not being written at all. Pasting the info in this file can only at best be described as a bandaid, and it appears for Win users at least, pasting the info is not helping; the results are still blank.
Reply
I've got over 2tb of tv and movies indexed and loaded up into xbmc from my NAS, the Hulu add-on is in there and working perfectly, Netflix is the last thing I need to get working and the xbmcflix gods continue to taunt me. Damn you xbmcflix gods... damn you!

Also am I reading this correctly because it looks like it may be broken.

http://api-status.com/6404/125477/NetFlix-oAuth-API
Reply
Edit
Reply
(2013-01-06, 04:24)rahvin Wrote: I've got over 2tb of tv and movies indexed and loaded up into xbmc from my NAS, the Hulu add-on is in there and working perfectly, Netflix is the last thing I need to get working and the xbmcflix gods continue to taunt me. Damn you xbmcflix gods... damn you!

Also am I reading this correctly because it looks like it may be broken.

http://api-status.com/6404/125477/NetFlix-oAuth-API

That's a good find. They have been having issues since the 31st. Don't know for certain if that is what is causing our problems, but it does influence how patient I will be.

Thanks, I'll wait and see when they get things fixed if my problems still exist.
Reply
Regarding authentication, definitely what I was seeing was that the second API call from XBMC flicks was not getting a valid HTTP response (nothing was returned at all). But following the instructions from this thread I turned up debug and grabbed the key and secret and was able to populate the userinfo.txt file. That got me to the state that others are where the Top 25 and New Arrivals work but Instant Queue is empty. I haven't really spent any time looking into that yet but I believe there are a couple of items in this thread related to the regular expressions used that resolved the issue for some folks.
Reply
With Ickythump's comment about manually entering the keys from the debug, I was also able to get both new arrivals to work. The other options don't try to download the api any more, they just show empty folders. Is that what other people were getting?

Is XBMC Flicks essentially just launching Netflix in IE? Is there any way to just launch straight to the homepage? That isn't as ideal as having XBMC Flicks fully working, but it is a good enough workaround that I would be fine with it
Reply

I am going to ask one more time, I have asked several times but no one has responded. NF has not enabled instant queues for me, if I am on boxee,or the web, I have to instant queue , however it works just fine for me on the plugin, so what I am seeing is different that what you are seeing and until IO see what is happening I cant fix anything

if you have browse by genre working (i.e your userinfo,txt is in good shape) but your Instant Queue is empty, can you:
1) attempt to access your instant queue with debugging on and send me the xbmc.log file
2) browse to a movie, right click choose "add to instant queue", check if its shows up in the queue on the plugin and also check if it shows up in the instant queue on NF

everyone is complaining that instant queues are not working , but no one is helping, I am getting more than a little frustrated.

Reply
(2013-01-06, 20:18)Ickythump Wrote: Regarding authentication, definitely what I was seeing was that the second API call from XBMC flicks was not getting a valid HTTP response (nothing was returned at all). But following the instructions from this thread I turned up debug and grabbed the key and secret and was able to populate the userinfo.txt file. That got me to the state that others are where the Top 25 and New Arrivals work but Instant Queue is empty. I haven't really spent any time looking into that yet but I believe there are a couple of items in this thread related to the regular expressions used that resolved the issue for some folks.

Did this :

So, for anyone else that wanders by, here's the workaround.
-Install XBMCFlicks. Before trying it, right click the Add-On, goto Add-On Settings, Debugging Tab, and enable both options.
-Open XBMCFlicks, tell your browser okay, tell XBMC okay, enjoy the perpetual ping of failure. Close XBMC.
-Dig up your logfile, which (in Windows 7) is under username/AppData/Roaming/XBMC. It'll be the most recently modified version.
-Open it up (notepad is fine) and run a ctrl-f for 'key'; a couple clicks should take you to a line like this:
> NOTICE: and then put this key / secret in MY_USER.request: <
-Under that are two alphanumeric codes labeled 'key' and 'secret'. Copy them over, keep them secret, keep them safe, etc..
-Bounce over your userinfo file, under appdata/roaming/XBMC/userdata/addon_data/plugin.video.xbmcflicks. If there's no userinfo.txt file, I would expect it would work just fine if you created one.
-Open userinfo.txt in note pad, and copy in yabsie's syntax from above.
requestKey=XXXXXXXXXXXXXXXX
requestSecret=YYYYYYYYYYYYYY
accessKey=ZZZZZZZZZZZZZZZZZZZZZZ
accessSecret=OOOOOOOOOOOOOOOOOO
-Replace the xxxx's and zzzz's with the longer code labeled Key. Replace the YYYY's and OOOO's with the shorter code labeled secret. No spaces or apostrophe's needed apparently.
-Save, relaunch XBMC, and enjoy your hopefully now successful authentication.

and it's still popping up with the web browser log in. This is really pissing me off.

Reply
I am currently at the step rahvin just mentioned, with the same results. I can only access the 2 Recent sections, not the Browse by Genre, or anything else. Yabsie, per your request:

1) My log file is here: http://xbmclogs.com/show.php?id=26768 At 09:35:24 is when i started XBMC Flicks, and navigated straight to the instant queue.
2) I tried adding an item from the Top 25 Recent to my Instant Queue, but got a pop up error message. It was titled "Instant Queue: Add 70260593", and had the message text "Account Inactive".

I hope this information helps. Let me know if there is anything else i can provide
Reply
Update, it has now stopped trying to open a web browser when I click on anything in the xbmcflix addon so I believe the unserinfo.txt hack has worked. However, now I'm in then same boat as everyone else. Search doesn't work and there's no content anywhere.

I think the problem here all comes back to the API being down.

12:18:06 T:5728 M:386416640 NOTICE: matched file contents, it is in the correct format
12:18:06 T:5728 M:386416640 NOTICE: finished loading up user information from file
12:18:06 T:5728 M:386416640 NOTICE: .. getAuth called ..
12:18:06 T:5728 M:386416640 NOTICE: OSX Setting is set to: False
12:18:06 T:5728 M:386416640 NOTICE: .. user configured ..
12:18:06 T:5728 M:386416640 NOTICE: Instant set to: True
12:18:06 T:5728 M:386416640 NOTICE: Queue set to: instant
12:18:06 T:5728 M:386416640 NOTICE: Search String is: instant
12:18:06 T:5728 M:386420736 NOTICE: http:://api-public.netflix.com/catalog/titles?term=Burn%20Notice&oauth_nonce= (Line Edited)
12:18:06 T:5728 M:386289664 ERROR: Error Type: exceptions.ValueError
12:18:06 T:5728 M:386289664 ERROR: Error Contents: No JSON object could be decoded
12:18:06 T:5728 M:386109440 ERROR: Traceback (most recent call last):

I did a search for Burn Notice it looks like it's querying http://api-public.netflix.com. Which appears to still be down?

http://api-status.com/
Reply
First as this is my first post in these forums.

To the devs of XBMC:
I have been using XBMC and have loved it ever since I installed it on my modded Xbox before it was available on PC. Your efforts bring us one step closer to home theater heaven(now I just need a home theater). Thank you very much for your awesome work.


I would also like to thank the devs of XBMC Flicks and Yabsie's version. Although it still needs work, your hard work and determination to develop a plugin for netflix has certainly created a worthy plugin. I personally use it myself to a satisfactory level(see below). The only thing hold this plugin back in my setup is the WAF and KUF(Kids Usability Factor).

Yabsie,
I apologize. I responded to your post with your original request. In fact its the reason I decided to register on these forums. Unfortunately I am unsure as to why my response didn't actually post. I have no knowledge in coding in any language. I have, however, achieved an impressive mastery level in utilizing the kind efforts, instructables, and works of individuals such as yourself and many other devs/DIYers.

My Setup:
OS: Windows 7 x86 (an older but popular trimmed down version)
XBMC version: Eden (XBMC 11.0 git 20120321-14feb09)
Skin: Confluence 2.1.0
netflix plugin version: XBMC-yabsiehacks-Flicks-0.2a
relevant plugin setting: Instant queue max items to retrieve = 200, Not in Canada, Not OSX (all others are on default settings)
netflix subscription: USA, online streaming only(no dvd rentals)
External browser player: Firefox 16.0.2

Precautions:
I had previously installed spudsdude-XBMC-Flicks-a644263. Before uninstalling spudsdude-XBMC-Flicks-a644263, I browsed some menus would that display correctly at first glance. But the Recommended menu option (maybe others menu options) displayed mixed results that included items that were instant watch or disk rental only. This populated the links folder with link files. I have a suspicious that when I uninstalled spudsdude-XBMC-Flicks-a644263 the links folder was not deleted. As I still see disk rental only. Since this is my only machine and its working well enough I have gotten the nerve to uninstall the plugin and remove all traces of the plugin before reinstalling.

My Findings:
Userinfo.txt was written and populated correctly on its own. (no auth problems I can see)
I am able to browse Instant Queue: All/Movies/TV, Recommended, Top 25 New Arrivals, All New Arrivals, and Browse by Genre.

Yep it wasn't a typo, Instant Queue works for me when I set "Instant queue max items to retrieve" to less than 200

BUT.....Instant Queue does have problems. If I change max results setting to 400 or 500 I get a blank menu no matter what I do. Even after restarting XBMC. Interestingly setting max results to 300 gives different but reproducible results which I am hoping will help clue you in on the problem. I hope. On a fresh install of the plugin I set max results to 300, I get a blank screen for Instant Queue: All, but if I then click on Instant Queue: Movies or Instant Queue:TV I get my respective queue results items. I can then go back to Instant Queue: All and get my queue items. I have been playing with the settings too much to know if Instant Queue will correctly display items in definitely or if Instant Queue: Movies/TV has to be periodically accessed in order for Instant Queue: All to work.

I will PM you with the log file, I tried to remove as much personal info as possible. The lines with just a period represent lines sections that were cutout. These were just results that were successfully retrieved and displayed. If you want I can post it here for everyone to view but I would prefer it if you look at it first to make sure I am not giving out any userinfo/keys.

With 0.3 out now I am going take the risk and wipe all traces of the old install to test my "disk rental only" problem.

P.S. I think I am first to use KUF, if it sticks give me credit! j/k
Reply
I've now spent some time setting up a Plex multimedia system and guess what, Netflex is not connecting on this either. I think I'm going to give up on XBMC. I've noticed that with the limited functionality I am able to get with the add on it launches media in an external browser (I.E.) and to top it off it's launched in kiosk mode as is XBMC. This makes it very hard to get back into XBMC without ctrl-alt-del'ing or something similar. That's a deal breaker for me. Unless I can get everything to run from within XBMC or another media center GUI what's the point of having the media center. It's a shame Boxee discontinued it's support from what I can gather it did it's job very well.
Reply
(2013-01-07, 20:54)jmontes4 Wrote: Yep it wasn't a typo, Instant Queue works for me when I set "Instant queue max items to retrieve" to less than 200

Can some of you other people who are having problems with instant queues try this out.
Reply
Didn't make a difference on mine, the default is at 75 already.
Reply
  •   
  • 1
  • 82
  • 83
  • 84(current)
  • 85
  • 86
  • 109
  •   
 
Thread Rating:
  • 16 Vote(s) - 4.44 Average



Logout Mark Read Team Forum Stats Members Help
[RELEASE] XBMC Flicks - Netflix Movies / TV Shows (Video) experimental Addon for XBMC4.4416