•   
  • 1
  • 34
  • 35
  • 36(current)
  • 37
  • 38
  •   
WebServer HTTP API (HttpApi): for PocketPC and Web-client Remote Control Apps
Trex: fix uploaded. As far as your request, rather than add all the files in a folder one by one as you are currently doing wouldn't just passing the folder to AddToSlideshow do what you are after?
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
Reply
Thanks nad.

Thats what I kinda do. I send AddToPlaylist (for videos and music) then I send SetPlaylistSong. However since the xbox has also added the contents of folders in its path, my script and xbox see things differently and the wrong file plays.
WYSIWYG
Reply
Hi Guys,

The source for my slightly less impressive PDA Application can be found on sourceforge. The url is;

http://xbmcm.svn.sourceforge.net/viewvc/xbmcm/

There is a readonly repository there for Subversion users.

You will need VS2008 to compile this, and please bear in mind its a beta Wink
Enjoy

Cheers

Kev
Reply
Hi all,

ive just upgraded my xbox to the latest build, and now I cannot query via the HTTP API any queries such as;

select strTitle from songview where strArtist like '%%Muse%%';

(in HTTP land)
http://192.168.2.5/xbmcCmds/xbmcHttp?com...%%Muse%%';


if i run the same query through the SQLLite Database browser it returns results.

Any ideas why this would be?

thanks

kev Moore
Reply
Sorry,
that was meant to say ;

select strArtist from songview where strArtist like '%%Muse%%';
or
select strTitle from songview where strTitle like '%%Everybody%%';

..

has the interface changed for LIKE queries??

thanks

Kev MooreShocked
Reply
Hi Kev: I have just tried with the latest build and your queries seem to work when sending from a browser:

e.g.
http://xbox/xbmcCmds/xbmcHttp?command=qu...0'%%Muse%%'

Are you getting the wrong results returned or an error?
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
Reply
Hi Nad,

Im not getting a response at all. When I look at my debug, i see <html>\n</html>. If I use that query in SQL Lite, i get rows returned. Is there a latest version of the HTTP API I can get hold of? Im not convinced my latest build is actualy a latest build .

cheers

Kev
Reply
Hi Kev: The latest version of the httpapi is in the latest version of xbmc Big Grin
However, the SQL command hasn't changed significantly over the last few months apart from a change a few weeks ago with how the the escaped characters were handled internally. I guess this could be what you are running in to. Try executing a command that doesn't have the double %s

e.g.
Code:
http://xbox/xbmcCmds/xbmcHttp?command=querymusicdatabase&parameter=select%20strArtist%20from%20artist%20order%20by%20strArtist

When you execute:

Code:
http://xbox/xbmcCmds/xbmcHttp?command=querymusicdatabase&parameter=select%20strArtist%20from%20songview%20where%20strArtist%20like%20'%%Muse%%

in a browser do you get the same <html>\n</html> response?
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
Reply
Hi Nad,

the orderby query works ok.

the sql statement with "LIKE" returns no results when using
%%Muse%%
%Muse%

if I use no percentages, I get a repitition of the word "Muse" Wink

cheers

Kev
Reply
Hi Nad,

ive just downloaded 2.0.1 and compiled it, shoved it on the xbox and it works OK now. I clearly had a duff version on there cos the one I had was using <field> as a delimeter not <li>.

Sorry for hassling you Wink

cheers

Kev
Reply
Are you using a LIMIT in your sql statement?

There seems to be a bug when combining LIKE and LIMIT in sqlite, maybe other combinations.

Try switching to GLOB. GLOB is case sensitive though.

here's an example i use.

PHP Code:
rating_sql += "movie.c12 GLOB '* %s *' OR " % ( rating, ) 

Edit: then nevermind Smile
For python coding questions first see http://mirrors.xbmc.org/docs/python-docs/
Reply
Hi All,

Me again. Another dumb question alert !!!

I am getting a

Error:Could not play file

when attempting to use the PlayFile function ...

Code:
http://192.168.2.5/xbmcCmds/xbmcHttp?command=PlayFile&parameter=xbms://192.168.2.2:1400/Music/A/A%20Vs.%20Monkey%20Kong01%20For%20Starters.mp3

This is for all my MP3's. Are there any issues with Playfile when streaming using the XBMS protocol? I did have SMB:// shares, but was having issues with Vista and permissions which is why I switched to XBMS.

Thanks again in advance

Kev Moore
Reply
Nad,

OK, ive tracked the problem down to the "playableFile" function.

Code:
return url.GetProtocol().Equals("http")
      || url.GetProtocol().Equals("https")
      || url.GetProtocol().Equals("lastfm")
      || url.GetProtocol().Equals("shout")    
      || CFile::Exists(filename);

Im not sure if CFile::Exists() handles XBMS, as its streamed and not technically a file location.

Is there any scope here to allow for the XBMS protocol?

cheers

Kev
Reply
Hi Kev,

I had never tried xbms before but it works for me.

All I did was download and run ccXgui Lite on my Vista computer. Vista gave the regular firewall prompt which of course I approved.

The playfile and getdirectory commands workperfecty (you don't need to specify the 1400 port but it still works if you do).

You should also be able to get smb to work on Vista though I recall it was an effort and I can't remember what exactly I did on the Vista box to enable it.
Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.


[Image: badge.gif]
Reply
Can the web interface differentiate between a press and a release? In other words, When I send a d-pad up command, the curser will move up one spot. What I would like to do, but can't find if it is possible, is send a d-pad up press command, and then send a release command when I'm done so it acts just like the controller and reduces the amount of traffic. I programmed the controller I'm using to watch for a hold and then send the command through an oscellator. It works alright, but I would really like to no have to send it so many commands so quickly. Is this not possible, or I'm I just not looking in the right places?
Reply
  •   
  • 1
  • 34
  • 35
  • 36(current)
  • 37
  • 38
  •   
 
Thread Rating:
  • 0 Vote(s) - 0 Average



Logout Mark Read Team Forum Stats Members Help
WebServer HTTP API (HttpApi): for PocketPC and Web-client Remote Control Apps00