•   
  • 1
  • 9
  • 10
  • 11(current)
  • 12
  • 13
  • 14
  •   
Linux HOW-TO compile XBMC from a GIT source
NOTICE

updated main topic to make it more idiot proof (impossible I know)

Also trimmed script a bit and its all using ap-get and doubling up to make sure all dependencies are installed.

the new script can be found in http://dl.dropbox.com/u/4325533/XCI/xgb.sh

However who has libnfs problems though I cannot reproduce them I done a script without that for now, please find it a couple of posts UP.

As also to make it clear I will only support manual compiles, the script is a tool requires training, hence why its CLEARLY explained on first topic How to use it.

I will not support script failures without logs for the errors.

Cheers.
If you have script problems use the manual instructions before posting any more hairy stuff.
Reply
Smile

Not to quibble, but this last attempt I just simply ran, in order you suggested, the two pastebins scripts you led me to, and did it blindly.

I obviously was running ./XBMC_build_git.sh upgrade on all my previous attempts, and the successful usage I have been having prior to all this.

I realize, very well, that I need to have a source to compile, and I guess I should not have run the script blindly without looking inside to see what it it was, but I only did this last compile to quickly try to help out, and since it was a fresh install, I obviously had not pulled the source.

To be honest, I didn't even realize that that your git.sh you put together was essentially the same as the main script.

But like I said, I was rushing to try one more time, to see if I could help by posting my results, from a laptop on the deck while bbq-ing and was simply cutting and pasting from your last post, which was obviously a mistake, as if I had taken a second I would have seen it said refresh and not upgrade

wget http://dl.dropbox.com/u/4325533/git.sh
chmod+x git.sh
./git.sh refresh

but I missed that. I did not make this mistake previously as I manually typed the commands.

I have read every post in this thread, and will continue to, it is god info, lol, I guess I just can't read what I am cutting and pasting... which would have been fine if it was still the live install that the origional upgrade failed in, but it wasn't, should have been less hasty...

lol, I will wait and see how Neil solves it, and try that, thanks.

Until then, I will try your suggestions again, but this time, not make the refresh error, I hate making those Id10T errors, thanks again,

nc
Reply
well his problems were I think dud to libnfs which I removed from second script, but I have no issues with either version.

Ive tested 4 times already for fresh installs of xbmc live or minima _ xbmclive and they all work.

Its now 3AM I still cnat sleep and I need to gget some rest otherwise tomorrow Ill be zonked out seriously baddly.

Eh btw mistques happen but when you posted that stuff Im like wtf...
Reply
hi, sorry to bring more of this to you, but, using your instructions as they are now. Here is what i have done:

1) install xbmc-live 10.1.iso to a blank partition.
2) boot
3) login via ssh and do "sudo passwd root" create a password.
4) close putty, open putty and login as root.
5) follow your instructions copy/pasting one line at a time - you can see this on the log below.

here is a weird bit for you

Quote:]0;[email protected]: [email protected]:~# apt-get build-dep xbmc -y

Reading package lists... 0%

Reading package lists... 100%

Reading package lists... Done

Building dependency tree... 0%

Building dependency tree... 0%

Building dependency tree... 50%

Building dependency tree... 50%

Building dependency tree

Reading state information... 0%

Reading state information... 0%

Reading state information... Done
Package autopoint is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
The following packages will be REMOVED:
libcurl4-openssl-dev
The following NEW packages will be installed:
libavcodec-dev libavcodec52 libavfilter-dev libavfilter0 libavformat-dev
libavformat52 libavutil-dev libavutil49 libbluetooth-dev libbluetooth3
libcrystalhd-dev libcrystalhd3 libcurl4-gnutls-dev libcwiid-dev libcwiid1
libcwiid1-dev libgcrypt11-dev libgnutls-dev libgpg-error-dev libgsm1
libmpcdec-dev libmpcdec3 liboil0.3 libpostproc-dev libpostproc51 librtmp-dev
libschroedinger-1.0-0 libspeex1 libswscale-dev libswscale0 libtasn1-3-dev
libtheora0
The following packages will be upgraded:
libcurl3-gnutls
1 upgraded, 32 newly installed, 1 to remove and 60 not upgraded.
E: Package autopoint has no installation candidate
E: Failed to process build dependencies

full putty log upto that point - http://pastebin.com/MHuJMKf4

i picked "uk" as my location when installing xbmc-live that would mean using different servers as sources for ubuntu packages?

edit - i've installed the deps manually, by copy pasting the list from above.

when running this "make -C $HOME/setup/xbmc/lib/addons/script.module.pil" line i get:

Quote:# make -C $HOME/setup/xbmc/lib/addons/script.module.pil
make: Entering directory `/root/setup/xbmc/lib/addons/script.module.pil'
make: *** No targets specified and no makefile found. Stop.
make: Leaving directory `/root/setup/xbmc/lib/addons/script.module.pil'
Reply
Im starting to get convinced that for some bizarre reason the unstable ppa is not working as it should. This autopoint crap is definitely a bug with XBMC and i cant fix that. (why I dont get it is beyond me.)

so bypass this by doing

Code:
apt-get install ibavcodec-dev libavcodec52 libavfilter-dev libavfilter0 libavformat-dev libavformat52 libavutil-dev libavutil49 libbluetooth-dev libbluetooth3 libcrystalhd-dev libcrystalhd3 libcurl4-gnutls-dev libcwiid-dev libcwiid1 libcwiid1-dev libgcrypt11-dev libgnutls-dev libgpg-error-dev libgsm1 libmpcdec-dev libmpcdec3 liboil0.3 libpostproc-dev libpostproc51 librtmp-dev libschroedinger-1.0-0 libspeex1 libswscale-dev libswscale0 libtasn1-3-dev libtheora0 -y
then once that is all installed, please proceed with the remainder of steps, download git and compile... if it continues to fail, idk what else to suggest but beg steal and borrow...

At first DONT compile libnfs because last night you posted a few errors that I would like to avoid for now, just to ensure its not that also that's causing this freaking stupid nightmare.

4 times I installed the iso and compiled.
Reply
i've given up, i keep getting those filenfs.o errors, and i've got all dependencies, etc. followed your instructions to the tee. I just can't seem to get any joy out of it.

Thanks for all your help.

edit - http://forum.xbmc.org/showthread.php?p=842955, relevant?

gonna try again in a few days, see if everythings back to normal!
Reply
yes relevant if you have and use NFS, I did say to leave out NFS from compile this time... if you did perhaps you need to clear ccache (it caches some regularly compiled stuff if it hasn't changed), its on main post, the command is

ccache
-zcC

honestly I would ask in IRC cause what your experiencing is NOT normal and I think the compile instructions/script cant just work for some people and not for others.

I cant blame you for taking a rest or giving up.

sorry i couldnt actualy help you fix this, I also treid with teh 10.0 dhrama release and my own ppas instead of the official and that also works. its a question of making changes and all info on my signature.

Im compiling for 3rd time today...just trying to catch it. no luck
Reply
when next yo try leave out NFS completely and clear ccache as I said on previous post.
Reply
it has to be me, something i'm doing is wrong.

will leave out nfs next time.
Reply
hi,

i dont know if this is progress or not, but i just installed a desktop of 10.04.2 x86. I'm breaking it down as step-by-step as i can. I know you know you're linux, but just so I'm giving you the full picture.

when i ran the first few lines:
Quote:stop xbmc-live
apt-get install python-software-properties pkg-config -y
add-apt-repository ppa:team-xbmc/unstable
echo deb http://ppa.launchpad.net/team-xbmc/unstable/ubuntu lucid main >> /etc/apt/sources.list
echo deb-src http://ppa.launchpad.net/team-xbmc/unstable/ubuntu lucid main >> /etc/apt/sources.list
apt-get update

i also had to add the key like this:
Quote:apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 6d975c4791e7ee5e

and it built perfect.

do the same 4 lines on the xbmc-live iso and i get it asking for autopoint.

i'm just trying something, i'll let you know how it goes!

Neil
Reply
desktop is more forgiving than xbmc-live you also dont need to install xbcm-live... I been asking in IRC about your woes, and so far no luck.

when you do

add-apt-repository ppa:team-xbmc/unstable

it automatically grabs the keys but none the less its worth a shot in xbmc-live only this time I would ask you to install the version 10.0 not 10.1

anyways if you can get into chat or something Im willing to go through this shit with you. send me a pm with your msn e-mail or your preferred chat.

at leats it comiples with desktop this stupid thing is doing my head in.
Reply
hi,

i got it working! i had a feeling after playing with the desktop that adding the lines to sources.list might not be needed.

So, here is what i did, after making root passwd.
Code:
apt-get update
stop xbmc-live
apt-get install python-software-properties pkg-config -y
add-apt-repository ppa:team-xbmc/unstable
apt-get update
apt-get install python-support python-dev ccache libyajl-dev libvdpau-dev debhelper zip git-core make g++ gcc gawk pmount libtool yasm nasm automake cmake gperf gettext unzip bison libsdl-dev libsdl-image1.2-dev libsdl-gfx1.2-dev libsdl-mixer1.2-dev libfribidi-dev liblzo2-dev libfreetype6-dev libsqlite3-dev libogg-dev libasound-dev python-sqlite libglew-dev libcurl3 libcurl4-openssl-dev x11proto-xinerama-dev libxinerama-dev libxrandr-dev libxrender-dev libmad0-dev libogg-dev libvorbisenc2 libsmbclient-dev libmysqlclient-dev libpcre3-dev libdbus-1-dev libhal-dev libhal-storage-dev libjasper-dev libfontconfig-dev libbz2-dev libboost-dev libfaac-dev libenca-dev libxt-dev libxtst-dev libxmu-dev libpng-dev libjpeg-dev libpulse-dev mesa-utils libcdio-dev libsamplerate-dev libmms-dev libmpeg3-dev libfaad-dev libflac-dev libiso9660-dev libass-dev libssl-dev fp-compiler gdc libwavpack-dev libmpeg2-4-dev libmicrohttpd-dev libmodplug-dev libboost-thread-dev -y -q
apt-get build-dep xbmc -y
mkdir ~/setup
cd $HOME/setup
git clone git://github.com/xbmc/xbmc.git
cd $HOME/setup/xbmc
./bootstrap; ./configure --prefix=/usr --enable-vdpau --disable-pulse ; make -j4
make install prefix=/usr
start xbmc-live

and it worked. thanks for all your help!
Reply
Your serious? really?

I'll be dammed, adding the lines to sources.list is what mad eit work here for build-dep...

Ill revise the instructions based on your imput and revise script, it should be up in a while.
Reply
btw can you compile libnfs as well and still works?
Reply
NOTICE:

[SIZE=2]Main compile instructions been updated to remove the addition of the ppa to sources list via echo command as this was reported by Neil as being the cause for recent compile associated issues.

The script also contains these modifications.

Both script and manula compile instructions still build Libnfs by default, if you dont wnat it or need it please feel free to remove it.

thanks to Neil for his perseverance on this, even though I couldn't reproduce problem.

I hope this helps other users having similar issues.

The struggle goes on...

Thanks again Neil for the heads up.
[/SIZE]
Reply
  •   
  • 1
  • 9
  • 10
  • 11(current)
  • 12
  • 13
  • 14
  •   



Logout Mark Read Team Forum Stats Members Help
HOW-TO compile XBMC from a GIT source12
This forum uses Lukasz Tkacz MyBB addons.